summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-pvr350
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-pvr350')
-rw-r--r--media-plugins/vdr-pvr350/Manifest3
-rw-r--r--media-plugins/vdr-pvr350/metadata.xml14
-rw-r--r--media-plugins/vdr-pvr350/vdr-pvr350-1.7.3.ebuild38
-rw-r--r--media-plugins/vdr-pvr350/vdr-pvr350-1.7.4.ebuild38
-rw-r--r--media-plugins/vdr-pvr350/vdr-pvr350-1.7.5.ebuild45
5 files changed, 138 insertions, 0 deletions
diff --git a/media-plugins/vdr-pvr350/Manifest b/media-plugins/vdr-pvr350/Manifest
new file mode 100644
index 000000000000..68e53efc063c
--- /dev/null
+++ b/media-plugins/vdr-pvr350/Manifest
@@ -0,0 +1,3 @@
+DIST vdr-pvr350-1.7.3.tgz 54099 SHA256 d91e7f58b62b4ea541636582e964a67ab5973e14b0ef1097364a8684a66d37a5
+DIST vdr-pvr350-1.7.4.tgz 52592 SHA256 a1bbe68a9b44c38a146bc5d018235adad25d8d480c7a9f97199bc096fc872e01
+DIST vdr-pvr350-1.7.5.tgz 48676 SHA256 3ebc602cc53e3f4508d08c53b29f392ea66cf05c8f5bbd14da8c1e641f88bfb9 SHA512 dd29836afe4e56b6ec083210920964645568c2680c170d435b379593f7f8fc1a5420e10af53126cfb82be4764aee47d2233b8fca3efece0ccb221c1a94445d05 WHIRLPOOL 3575eddb312ec32b4744d2aa3a8f655cdaae7b726a66cc0fd0c3a13e300e1663a4ff43ef5e5a1dcb9da9e500dd5c801d06237ccfcf780aba22094a582aab23b6
diff --git a/media-plugins/vdr-pvr350/metadata.xml b/media-plugins/vdr-pvr350/metadata.xml
new file mode 100644
index 000000000000..520eec87836e
--- /dev/null
+++ b/media-plugins/vdr-pvr350/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<use>
+ <flag name='yaepg'>Enables full support for the output format of
+ <pkg>media-plugins/vdr-yaepg</pkg></flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-pvr350/vdr-pvr350-1.7.3.ebuild b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.3.ebuild
new file mode 100644
index 000000000000..cd77393a7151
--- /dev/null
+++ b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+VERSION="995"
+
+DESCRIPTION="VDR plugin: use a PVR350 as output device"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-pvr350"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="yaepg"
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-sound/mpg123
+ media-sound/twolame
+ media-libs/a52dec
+ yaepg? ( >=media-video/vdr-1.6.0[yaepg] )"
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ || ( >=sys-kernel/linux-headers-2.6.38 )"
+
+S="${WORKDIR}/${P#vdr-}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if use yaepg; then
+ BUILD_PARAMS="SET_VIDEO_WINDOW=1"
+ fi
+}
diff --git a/media-plugins/vdr-pvr350/vdr-pvr350-1.7.4.ebuild b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.4.ebuild
new file mode 100644
index 000000000000..c67844aac9e6
--- /dev/null
+++ b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+VERSION="996"
+
+DESCRIPTION="VDR plugin: use a PVR350 as output device"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-pvr350"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="yaepg"
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-sound/mpg123
+ media-sound/twolame
+ media-libs/a52dec
+ yaepg? ( >=media-video/vdr-1.6.0[yaepg] )"
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ || ( >=sys-kernel/linux-headers-2.6.38 )"
+
+S="${WORKDIR}/${P#vdr-}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if use yaepg; then
+ BUILD_PARAMS="SET_VIDEO_WINDOW=1"
+ fi
+}
diff --git a/media-plugins/vdr-pvr350/vdr-pvr350-1.7.5.ebuild b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.5.ebuild
new file mode 100644
index 000000000000..d2a8d738e152
--- /dev/null
+++ b/media-plugins/vdr-pvr350/vdr-pvr350-1.7.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="1657" # every bump, new version
+
+DESCRIPTION="VDR plugin: use a PVR350 as output device"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-pvr350"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="yaepg"
+
+DEPEND=">=media-video/vdr-2
+ media-sound/mpg123
+ media-sound/twolame
+ media-libs/a52dec
+ yaepg? ( >=media-video/vdr-2[yaepg] )"
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ || ( >=sys-kernel/linux-headers-2.6.38 )"
+
+S="${WORKDIR}/${P#vdr-}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if use yaepg; then
+ BUILD_PARAMS="SET_VIDEO_WINDOW=1"
+ fi
+}
+
+src_prepare() {
+ # remove empty language files
+ rm po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+}