summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-wirbelscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-wirbelscan')
-rw-r--r--media-plugins/vdr-wirbelscan/Manifest1
-rw-r--r--media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch46
-rw-r--r--media-plugins/vdr-wirbelscan/files/wirbelscan.mk123
-rw-r--r--media-plugins/vdr-wirbelscan/metadata.xml10
-rw-r--r--media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild35
5 files changed, 215 insertions, 0 deletions
diff --git a/media-plugins/vdr-wirbelscan/Manifest b/media-plugins/vdr-wirbelscan/Manifest
new file mode 100644
index 000000000000..ec5bf2fcb841
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/Manifest
@@ -0,0 +1 @@
+DIST vdr-wirbelscan-0.0.7.tgz 149949 SHA256 42ffc3da1efd2ec6e40e233e4750f9b19ba04aa6e887d9cac960b758e4371dd2 SHA512 754b3089b1a8536b501fd8b62ddafedaf8304518856152a49b97149113929b47d6c6299b8eb4b78b2d3dc5aba147a3e21c00554ad02d2dc5018c296f6c55d6a5 WHIRLPOOL e986d16224cc7e1cefbf08daa32f595dfc7d3d2901bf324480bb61f44b79e417ac727c5f5573a839c7ab760aab020a73509cd05dffbc47daa5d47f7e801afef3
diff --git a/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch b/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch
new file mode 100644
index 000000000000..b801803afc9d
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/files/receiver-api-fixes.patch
@@ -0,0 +1,46 @@
+Index: vdr-plugin-wirbelscan-0.0.7/statemachine.c
+===================================================================
+--- vdr-plugin-wirbelscan-0.0.7.orig/statemachine.c 2011-03-24 16:48:43.000000000 +0100
++++ vdr-plugin-wirbelscan-0.0.7/statemachine.c 2012-04-03 19:51:08.813786243 +0200
+@@ -36,12 +36,12 @@
+ while (Running()) cCondWait::SleepMs(5);
+ }; /*TODO: check here periodically for lock and wether we got any data!*/
+ public:
+- cScanReceiver(tChannelID ChannelID, int AnyPid);
++ cScanReceiver(const cChannel* chan, int AnyPid);
+ virtual ~cScanReceiver() {cReceiver::Detach(); };
+ };
+
+-cScanReceiver::cScanReceiver(tChannelID ChannelID, int AnyPid) :
+- cReceiver(ChannelID, 99, AnyPid), cThread("dummy receiver") { }
++cScanReceiver::cScanReceiver(const cChannel* chan, int AnyPid) :
++ cReceiver(chan, 99), cThread("dummy receiver") { SetPids(NULL); AddPid(AnyPid); }
+
+ ///!-----------------------------------------------------------------
+ ///! v 0.0.5, store state in lastState if different and print state
+@@ -144,7 +144,7 @@
+ ScannedTransponders.Add(ScannedTransponder);
+
+ dev->SwitchChannel(Transponder, false);
+- aReceiver = new cScanReceiver(Transponder->GetChannelID(), 99);
++ aReceiver = new cScanReceiver(Transponder, 99);
+ dev->AttachReceiver(aReceiver);
+
+ cCondWait::SleepMs(1000);
+Index: vdr-plugin-wirbelscan-0.0.7/ttext.c
+===================================================================
+--- vdr-plugin-wirbelscan-0.0.7.orig/ttext.c 2011-03-24 19:29:59.000000000 +0100
++++ vdr-plugin-wirbelscan-0.0.7/ttext.c 2012-04-03 20:03:06.903786678 +0200
+@@ -374,9 +374,10 @@
+ }
+ }
+
+-cSwReceiver::cSwReceiver(cChannel * Channel) : cReceiver(Channel->GetChannelID(),
+- 100, Channel->Tpid()), cThread("ttext") {
++cSwReceiver::cSwReceiver(cChannel * Channel) : cReceiver(Channel, 100), cThread("ttext") {
+
++ SetPids(NULL);
++ AddPid(Channel->Tpid());
+ stopped = fuzzy = false;
+ channel = Channel;
+ buffer = new cRingBufferLinear(MEGABYTE(1),184);
diff --git a/media-plugins/vdr-wirbelscan/files/wirbelscan.mk b/media-plugins/vdr-wirbelscan/files/wirbelscan.mk
new file mode 100644
index 000000000000..1c777717e25f
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/files/wirbelscan.mk
@@ -0,0 +1,123 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id$
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = wirbelscan
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o common.o frequencies.o menusetup.o satellites.o scanner.o dvb_wrapper.o
+OBJS += scanfilter.o caDescriptor.o statemachine.o countries.o ext_math.o ttext.o
+
+### The main target:
+
+all: $(SOFILE) i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-wirbelscan/metadata.xml b/media-plugins/vdr-wirbelscan/metadata.xml
new file mode 100644
index 000000000000..5f9f14619db8
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..bfed30146c22
--- /dev/null
+++ b/media-plugins/vdr-wirbelscan/vdr-wirbelscan-0.0.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: Scan for channels on DVB-? and on PVR*-Cards"
+HOMEPAGE="http://wirbel.htpc-forum.de/wirbelscan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/wirbelscan/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # remove untranslated po files
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,es_ES,el_GR,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ # new Makefile handling
+ cp "${FILESDIR}/wirbelscan.mk" "${S}/Makefile"
+
+ epatch "${FILESDIR}/receiver-api-fixes.patch"
+
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include scanfilter.h
+ fix_vdr_libsi_include scanfilter.c
+ fix_vdr_libsi_include caDescriptor.h
+}