summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2019-07-24 16:55:43 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2019-07-24 16:56:50 +0200
commit0d52299907f1182bb2cfc2e8b44ed5a0f84b4213 (patch)
treeb3516efa872106a79fcd0b02a55cbdd4c30d511f /media-radio/wsjtx
parentapp-admin/checksec: 2.0.0 (diff)
downloadgentoo-0d52299907f1182bb2cfc2e8b44ed5a0f84b4213.tar.gz
gentoo-0d52299907f1182bb2cfc2e8b44ed5a0f84b4213.tar.bz2
gentoo-0d52299907f1182bb2cfc2e8b44ed5a0f84b4213.zip
media-radio/wsjtx: Fix build of documentation
- drop unicode characters from man pages source - fix DOCDIR - fix installation of DOCS Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio/wsjtx')
-rw-r--r--media-radio/wsjtx/files/wsjtx-drop-docs.patch21
-rw-r--r--media-radio/wsjtx/files/wsjtx-fix-unicode.patch11
-rw-r--r--media-radio/wsjtx/wsjtx-2.1.0.ebuild14
3 files changed, 41 insertions, 5 deletions
diff --git a/media-radio/wsjtx/files/wsjtx-drop-docs.patch b/media-radio/wsjtx/files/wsjtx-drop-docs.patch
new file mode 100644
index 000000000000..50bd9cc095b8
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-drop-docs.patch
@@ -0,0 +1,21 @@
+--- a/CMakeLists.txt 2019-07-24 16:42:07.128890166 +0200
++++ b/CMakeLists.txt 2019-07-24 16:42:40.001023963 +0200
+@@ -1493,18 +1493,6 @@
+ )
+
+ install (FILES
+- README
+- COPYING
+- AUTHORS
+- THANKS
+- NEWS
+- INSTALL
+- BUGS
+- DESTINATION ${CMAKE_INSTALL_DOCDIR}
+- #COMPONENT runtime
+- )
+-
+-install (FILES
+ contrib/Ephemeris/JPLEPH
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/${CMAKE_PROJECT_NAME}
+ #COMPONENT runtime
diff --git a/media-radio/wsjtx/files/wsjtx-fix-unicode.patch b/media-radio/wsjtx/files/wsjtx-fix-unicode.patch
new file mode 100644
index 000000000000..925199863a11
--- /dev/null
+++ b/media-radio/wsjtx/files/wsjtx-fix-unicode.patch
@@ -0,0 +1,11 @@
+--- a/manpages/man1/jt65code.1.txt 2019-07-23 19:27:07.690602674 +0200
++++ b/manpages/man1/jt65code.1.txt 2019-07-23 19:27:22.098060819 +0200
+@@ -31,7 +31,7 @@
+
+ *jt65code*, *jt9code* and *jt4code* are utility programs that let you
+ explore the conversion of user-level messages into channel symbols or
+-“tone numbers.” These programs can be useful to someone designing a
++"tone numbers." These programs can be useful to someone designing a
+ beacon generator for JT9 or JT65, or for studying behavior of the
+ error-control codes for each of the protocols.
+
diff --git a/media-radio/wsjtx/wsjtx-2.1.0.ebuild b/media-radio/wsjtx/wsjtx-2.1.0.ebuild
index 36351332cfbd..15c7d5cf22d8 100644
--- a/media-radio/wsjtx/wsjtx-2.1.0.ebuild
+++ b/media-radio/wsjtx/wsjtx-2.1.0.ebuild
@@ -37,7 +37,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/wsjtx
-PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch" )
+PATCHES=( "${FILESDIR}/${PN}-2.0.1-hamlib.patch"
+ "${FILESDIR}/${PN}-fix-unicode.patch"
+ "${FILESDIR}/${PN}-drop-docs.patch" )
+
+DOCS=( AUTHORS BUGS NEWS README THANKS )
src_unpack() {
unpack ${A}
@@ -45,9 +49,11 @@ src_unpack() {
}
src_configure() {
+ cmake_comment_add_subdirectory debian
+
local mycmakeargs=(
-DWSJT_GENERATE_DOCS="$(usex doc)"
- -DWSJT_DOC_DESTINATION="/doc/${PF}"
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
cmake-utils_src_configure
}
@@ -59,7 +65,5 @@ src_compile() {
src_install() {
cmake-utils_src_install
rm "${D}"/usr/bin/rigctl{,d}-wsjtx || die
- rm "${D}"/usr/share/man/man1/rigctl{,d}-wsjtx.1.gz || die
- rm "${D}"/usr/share/doc/WSJT-X -R || die
-
+ rm "${D}"/usr/share/man/man1/rigctl{,d,com}-wsjtx.1.gz || die
}