summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/wspr/wspr-2.00-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/wspr/wspr-2.00-r2.ebuild')
-rw-r--r--media-radio/wspr/wspr-2.00-r2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/media-radio/wspr/wspr-2.00-r2.ebuild b/media-radio/wspr/wspr-2.00-r2.ebuild
new file mode 100644
index 000000000000..a1580669162a
--- /dev/null
+++ b/media-radio/wspr/wspr-2.00-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit autotools fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
+
+MY_P=${P}.r1714
+
+DESCRIPTION="Weak Signal Propagation Reporter"
+HOMEPAGE="http://www.physics.princeton.edu/pulsar/K1JT/wspr.html"
+SRC_URI="http://www.physics.princeton.edu/pulsar/K1JT/${MY_P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/python-imaging[tk,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ virtual/pmw[${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ media-libs/hamlib
+ media-libs/portaudio
+ media-libs/libsamplerate"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( BUGS WSPR_Announcement.TXT WSPR_Instructions.TXT WSPR_Quick_Start.TXT )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+get_fcomp() {
+ case $(tc-getFC) in
+ *gfortran* ) FCOMP="gfortran" ;;
+ * ) FCOMP=$(tc-getFC) ;;
+ esac
+}
+
+python_prepare_all() {
+ tc-export FC
+ get_fcomp
+ export FC="${FCOMP}"
+
+ local PATCHES=(
+ "${FILESDIR}"/${P}-libdir.patch
+ "${FILESDIR}"/${P}-verbose.patch
+ "${FILESDIR}"/${P}-script.patch
+ "${FILESDIR}"/${P}-PIL.patch
+ )
+
+ distutils-r1_python_prepare_all
+
+ sed -i -e "s#/usr/local/lib#/usr/$(get_libdir)#" configure.ac || die
+ sed -i -e '/makedirs/d' setup.py || die
+ eautoreconf
+}
+
+# Note: very hacky build system.
+# autoconf which doesn't really need Python
+# then custom Makefile which compiles the Python module with f2py
+# and finally hacked setup.py which relies on w.so created by make
+
+src_configure() {
+ # configure the build of the fortran module
+ econf --with-portaudio-lib-dir=/usr/$(get_libdir)
+
+ # then fork the sources
+ python_copy_sources
+ DISTUTILS_IN_SOURCE_BUILD=1
+}
+
+python_compile() {
+ # -shared is neded by f2py but cannot be set earlier as configure does
+ # not like it
+ local LDFLAGS=${LDFLAGS}
+ append-ldflags -shared
+ emake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dobin wspr
+ insinto /usr/share/${PN}
+ doins hamlib_rig_numbers
+}