summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2019-07-26 16:06:46 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2019-07-26 16:06:46 +0200
commit93a4241e7cb9e23bed3025dd678f654ad6e9a98a (patch)
treebb06521e3955b37b7595dc9387a94640417c4a1e /media-radio
parentapp-text/kup: New package, 0.7.3 initial version (diff)
downloadgentoo-93a4241e7cb9e23bed3025dd678f654ad6e9a98a.tar.gz
gentoo-93a4241e7cb9e23bed3025dd678f654ad6e9a98a.tar.bz2
gentoo-93a4241e7cb9e23bed3025dd678f654ad6e9a98a.zip
media-radio/xastir: Fix for compile error with newer Graphicsmagick
Backport from xastir-2.1.4 for stable version Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff32
-rw-r--r--media-radio/xastir/xastir-2.0.8-r1.ebuild5
2 files changed, 36 insertions, 1 deletions
diff --git a/media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff b/media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff
new file mode 100644
index 000000000000..8919239fbfde
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff
@@ -0,0 +1,32 @@
+# backported from xastir-2.1.4 (see bug #688444)
+--- a/src/map_geo.c 2019-07-26 15:54:19.534488550 +0200
++++ b/src/map_geo.c 2019-07-26 15:56:47.779713950 +0200
+@@ -125,20 +125,7 @@
+ #undef PACKAGE_TARNAME
+ #define XASTIR_PACKAGE_VERSION PACKAGE_VERSION
+ #undef PACKAGE_VERSION
+-#ifdef HAVE_GRAPHICSMAGICK
+-/*#include <GraphicsMagick/magick/api.h>*/
+-/* Define MAGICK_IMPLEMENTATION to access private interfaces
+- * such as DestroyImagePixels(). This may not be a good thing,
+- * but DestroyImagePixels() has been in this code for a long
+- * time. Defining MAGIC_IMPLEMENTATION eliminates the warning that is
+- * now (9/28/2010) being seen on some distros (Ubuntu 10.04 and
+- * OpenSuSE-11.3)
+- */
+-#define MAGICK_IMPLEMENTATION
+ #include <magick/api.h>
+-#else // HAVE_GRAPHICSMAGICK
+-#include <magick/api.h>
+-#endif // HAVE_GRAPHICSMAGICK
+ #undef PACKAGE_BUGREPORT
+ #define PACKAGE_BUGREPORT XASTIR_PACKAGE_BUGREPORT
+ #undef XASTIR_PACKAGE_BUGREPORT
+@@ -2030,7 +2017,6 @@
+ if (!SyncImagePixels(image))
+ fprintf(stderr, "SyncImagePixels Failed....\n");
+ }
+- DestroyImagePixels(image);
+ }
+
+ // If were are drawing to a low bpp display (typically < 8bpp)
diff --git a/media-radio/xastir/xastir-2.0.8-r1.ebuild b/media-radio/xastir/xastir-2.0.8-r1.ebuild
index d4421c5da9b6..c16d857f5d69 100644
--- a/media-radio/xastir/xastir-2.0.8-r1.ebuild
+++ b/media-radio/xastir/xastir-2.0.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -45,6 +45,9 @@ src_prepare() {
# do not filter duplicate flags (see bug 411095)
epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
+ # fix compile problem with newer graphicsmagic
+ epatch "${FILESDIR}"/${PN}-2.0.8-fix-graphicsmagick.diff
+
eautoreconf
}