summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-04-19 11:36:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-19 11:38:26 +0200
commit0b2fbadb6c130236218d1c744c617f0e9dd14db5 (patch)
tree00fcf0de7821b7bf47f3d833b7c97d8b57eee0d9 /media-sound/grip
parentgames-rpg/manaplus: Removed old. (diff)
downloadgentoo-0b2fbadb6c130236218d1c744c617f0e9dd14db5.tar.gz
gentoo-0b2fbadb6c130236218d1c744c617f0e9dd14db5.tar.bz2
gentoo-0b2fbadb6c130236218d1c744c617f0e9dd14db5.zip
media-sound/grip: Bump to version 3.4.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/Manifest1
-rw-r--r--media-sound/grip/grip-3.4.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index 732c22e77382..ca2afbfa161e 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1 +1,2 @@
DIST grip-3.3.1.tar.gz 812562 SHA256 d46394a1062ed066f9c633b010fd1059e63d9ed791bbb7a85bc6567cf0fd66fd SHA512 380e36cb4e58180e543e1d293d38108f4879842ed63106da875e00747e98c2c06da1e706cfaf4ff26f481bba0ca941eb1201f430de04b0f313b1307ddd7e88d3 WHIRLPOOL 7e085bf45cf1031e5dce295c8d34682937c9abe1b74119103f418e598e1b835c9ce22533e603384099512e139c15963ab31b3eb73aa088bd698281cf507bf3de
+DIST grip-3.4.0.tar.gz 721897 SHA256 8433f9adce7bee19d446af81054e0cd149a0aba413026a78f890413e36c5e784 SHA512 2e8ace9e61a2504cedc3de9dc3739c225717d928bdbdb6375310306cbb73ba1e8aebb9867fcea298405114105cd4ad23bf4716c855707bd26dc0e12420da31c3 WHIRLPOOL 863d14a9428206457c21b565494e22b87a595f2fc4397725b1a6966e31e053818467ace0723986f58d565a392af3d757309f62e5adf8bc947fb7863cbe0f297b
diff --git a/media-sound/grip/grip-3.4.0.ebuild b/media-sound/grip/grip-3.4.0.ebuild
new file mode 100644
index 000000000000..be2a64fb8c24
--- /dev/null
+++ b/media-sound/grip/grip-3.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs libtool
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ gnome-base/libgnome
+ >=gnome-base/libgnomeui-2.2.0
+ >=media-libs/id3lib-3.8.3
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ >=x11-libs/gtk+-2.2:2
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/vte:0
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+src_prepare() {
+ default
+ # fix include syntax for newer versions of bash
+ sed -i '/[.] conftest[.]id3/s: c: ./c:' configure || die
+ elibtoolize
+}
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nl pl_PL pt_BR ru zh_CN zh_HK zh_TW
+
+ econf
+}