summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-10-08 21:44:26 +0200
committerJohannes Huber <johu@gentoo.org>2018-10-08 21:44:42 +0200
commit5003fa84d007a6dca3f65ce8d2c7fccc1b8cb273 (patch)
tree8a42eee20cd85e34904b4ced5d6bfaaf64f62556 /media-sound/lollypop
parentmedia-tv/kodi: Improve consistency of mysql/mariadb use flags (diff)
downloadgentoo-5003fa84d007a6dca3f65ce8d2c7fccc1b8cb273.tar.gz
gentoo-5003fa84d007a6dca3f65ce8d2c7fccc1b8cb273.tar.bz2
gentoo-5003fa84d007a6dca3f65ce8d2c7fccc1b8cb273.zip
media-sound/lollypop: Version bump 0.9.604
Signed-off-by: Johannes Huber <johu@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-0.9.604.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index aa92b22274c9..d41a2b196862 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1 +1,2 @@
DIST lollypop-0.9.601.tar.xz 376712 BLAKE2B d3747a1e994cd8de816eed49d87a8f279394981f14e2de82785203ba5ec0e71604a569f5f3e8e57da55f9bf62066da15232d46a0d117d094c6638b6608491620 SHA512 d13bd50f6b591a0f6491010817833d345a7fe1e63ef0eaab2ebad7c877990cf5e2dfba62911a690d223d912750a150fda40be81ca9a094968ed4796c1ed66f65
+DIST lollypop-0.9.604.tar.xz 384080 BLAKE2B 6262af52ad75e6fbdc128b5c0b6ae7c7156b5f7b1d29e96ebf22f8e966f3c6f803b56dd18841606e3f3198d2d962f6b08ef03825716c4492e72ab0b28a8e8a96 SHA512 20176713c36430c3bc9bb02fc885221efaca9f19b43c7511bce88162aa54fdcd3caf3e7c7c98ee1b72f9f795dce093650c2976f85006011bbd5354361acb7c83
diff --git a/media-sound/lollypop/lollypop-0.9.604.ebuild b/media-sound/lollypop/lollypop-0.9.604.ebuild
new file mode 100644
index 000000000000..804a262419c9
--- /dev/null
+++ b/media-sound/lollypop/lollypop-0.9.604.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="caaeacbe092d931e9b16b5cb7423c2b4"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+CDEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+DEPEND="${CDEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${CDEPEND}
+ app-crypt/libsecret
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}