summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mpdscribble
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/Manifest1
-rw-r--r--media-sound/mpdscribble/files/mpdscribble.rc20
-rw-r--r--media-sound/mpdscribble/metadata.xml20
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.22.ebuild36
4 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/mpdscribble/Manifest b/media-sound/mpdscribble/Manifest
new file mode 100644
index 000000000000..e3d02c25210f
--- /dev/null
+++ b/media-sound/mpdscribble/Manifest
@@ -0,0 +1 @@
+DIST mpdscribble-0.22.tar.bz2 116981 SHA256 1cde2b5f8c70f0e3e6f059d01bf0b0f2eac2b29fbcd14b01a8a5103e603feb41
diff --git a/media-sound/mpdscribble/files/mpdscribble.rc b/media-sound/mpdscribble/files/mpdscribble.rc
new file mode 100644
index 000000000000..463d27fec89b
--- /dev/null
+++ b/media-sound/mpdscribble/files/mpdscribble.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ use mpd
+}
+
+start () {
+
+ ebegin "Starting Music Player Daemon Audioscrobbler client"
+ start-stop-daemon --start --exec /usr/bin/mpdscribble -- --pidfile /var/run/mpdscribble.pid
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping Music Player Daemon Audioscrobbler client"
+ start-stop-daemon --stop --quiet -p /var/run/mpdscribble.pid --exec /usr/bin/mpdscribble || eerror "mpdscribble is not running"
+ rm -f /var/run/mpdscribble.pid
+ eend $?
+}
diff --git a/media-sound/mpdscribble/metadata.xml b/media-sound/mpdscribble/metadata.xml
new file mode 100644
index 000000000000..5789d68fda54
--- /dev/null
+++ b/media-sound/mpdscribble/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <longdescription lang="en">
+ A client for the Music Player Daemon that sends information to
+ Audioscrobbler -- a website (www.last.fm) displaying what various people
+ listen to. This information is then used to show friends, generate
+ recommended listening information, listen to a radio station with a
+ playlist tailored to the user's taste, and to show interesting
+ statistics about your listening habits.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">musicpd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/mpdscribble/mpdscribble-0.22.ebuild b/media-sound/mpdscribble/mpdscribble-0.22.ebuild
new file mode 100644
index 000000000000..e498ca6e2e7f
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=media-libs/libmpdclient-2.2
+ curl? ( net-misc/curl )
+ !curl? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myclient=soup
+ use curl && myclient=curl
+ econf \
+ --with-http-client=${myclient} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ dodir /var/cache/mpdscribble
+}