summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-31 01:25:06 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-31 01:30:27 -0700
commite7731809f95efd02c00390ee31156a86f237499f (patch)
treedc3ed309b87ba4a8569c43993eef634fd5c4bf3f /media-sound/mps-youtube
parentdev-python/pafy: remove old (diff)
downloadgentoo-e7731809f95efd02c00390ee31156a86f237499f.tar.gz
gentoo-e7731809f95efd02c00390ee31156a86f237499f.tar.bz2
gentoo-e7731809f95efd02c00390ee31156a86f237499f.zip
media-sound/mps-youtube: update to EAPI 7 and add py37/py38 compat
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-sound/mps-youtube')
-rw-r--r--media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild27
-rw-r--r--media-sound/mps-youtube/mps-youtube-9999.ebuild11
2 files changed, 33 insertions, 5 deletions
diff --git a/media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild b/media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild
new file mode 100644
index 000000000000..a86ede03c873
--- /dev/null
+++ b/media-sound/mps-youtube/mps-youtube-0.2.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/mps-youtube.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mps-youtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pafy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+ || ( media-video/mpv media-video/mplayer )
+"
diff --git a/media-sound/mps-youtube/mps-youtube-9999.ebuild b/media-sound/mps-youtube/mps-youtube-9999.ebuild
index 7f9ca71d825c..a86ede03c873 100644
--- a/media-sound/mps-youtube/mps-youtube-9999.ebuild
+++ b/media-sound/mps-youtube/mps-youtube-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
@@ -19,8 +20,8 @@ HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mp
LICENSE="GPL-3"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/pafy[${PYTHON_USEDEP}]
virtual/ffmpeg
- || ( media-video/mplayer media-video/mpv )"
+ || ( media-video/mpv media-video/mplayer )
+"