summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qmpdclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qmpdclient')
-rw-r--r--media-sound/qmpdclient/Manifest1
-rw-r--r--media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch40
-rw-r--r--media-sound/qmpdclient/metadata.xml12
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild40
4 files changed, 93 insertions, 0 deletions
diff --git a/media-sound/qmpdclient/Manifest b/media-sound/qmpdclient/Manifest
new file mode 100644
index 000000000000..ba471ed942be
--- /dev/null
+++ b/media-sound/qmpdclient/Manifest
@@ -0,0 +1 @@
+DIST qmpdclient-1.2.2.tar.bz2 271565 SHA256 ed65705eaae8fb10fdce34ce20e010757a87423c2874479e1466e4368a866289 SHA512 2ae8a2235640c0c644f32290a9d39bcef6f041bb7eca1d269b54433975578c31067f2e5a28d9d679c229075962523b6b20e779b1ed23af7c47129ff4b63e5735 WHIRLPOOL e52e5b99892cc7b475f1c1b26a514b8125d704c83fef02b140307536acad45a94bdc4fe59adbec289d379cd599f4748452f17c5345b166ab443defbfcfeb0460
diff --git a/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch b/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch
new file mode 100644
index 000000000000..2eac669c092c
--- /dev/null
+++ b/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch
@@ -0,0 +1,40 @@
+From 20edef54b109882632f58549d181123b9985d65b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 1 Jun 2012 21:54:10 +1200
+Subject: [PATCH] First attempt at fixing lastfm scrobbling
+
+---
+ src/lastfmsubmitter.cpp | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/lastfmsubmitter.cpp b/src/lastfmsubmitter.cpp
+index cff94bc..a9b6ea9 100644
+--- a/src/lastfmsubmitter.cpp
++++ b/src/lastfmsubmitter.cpp
+@@ -112,7 +112,10 @@ void LastFmSubmitter::scrobbleNp(MPDSong & s) {
+ data += QString("l=%1&").arg(s.secs() >0 ? QString::number(s.secs()) : "100");
+ data += QString("n=%1").arg(QString(QUrl::toPercentEncoding(s.track())));
+ //qDebug() << data;
+- m_netAccess->post(QNetworkRequest(QUrl(m_npUrl)), data.toAscii());
++ QUrl url(m_npUrl);
++ QNetworkRequest request(url);
++ request.setRawHeader("Content-Type", "application/x-www-form-urlencoded");
++ m_netAccess->post(request, data.toAscii());
+ }
+
+ void LastFmSubmitter::scrobbleCurrent() {
+@@ -152,7 +155,10 @@ void LastFmSubmitter::scrobbleQueued() {
+ if (i>0) {
+ //qDebug() << "sending scrobble to " << m_subUrl.toAscii();
+ //qDebug() << "data: " << data.toAscii();
+- m_netAccess->post(QNetworkRequest(QUrl(m_subUrl)), data.toAscii());
++ QUrl url(m_subUrl);
++ QNetworkRequest request(url);
++ request.setRawHeader("Content-Type", "application/x-www-form-urlencoded");
++ m_netAccess->post(request, data.toAscii());
+ m_awaitingScrob = true;
+ }
+ }
+--
+1.7.9.4
+
diff --git a/media-sound/qmpdclient/metadata.xml b/media-sound/qmpdclient/metadata.xml
new file mode 100644
index 000000000000..4e2154e07e54
--- /dev/null
+++ b/media-sound/qmpdclient/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <longdescription lang="en">
+ QMPDClient is an easy to use Qt4 client for MPD
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild b/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..81f8eeff74e4
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit fdo-mime cmake-utils
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README THANKSTO )
+PATCHES=( "${FILESDIR}"/${P}-qt48.patch )
+
+src_prepare() {
+ sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }