summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/terminatorx/terminatorx-3.84-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/terminatorx/terminatorx-3.84-r1.ebuild')
-rw-r--r--media-sound/terminatorx/terminatorx-3.84-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/terminatorx/terminatorx-3.84-r1.ebuild b/media-sound/terminatorx/terminatorx-3.84-r1.ebuild
new file mode 100644
index 000000000000..f7c4499f6996
--- /dev/null
+++ b/media-sound/terminatorx/terminatorx-3.84-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+MY_P=${P/terminatorx/terminatorX}
+DESCRIPTION='realtime audio synthesizer that allows you to "scratch" on digitally sampled audio data'
+HOMEPAGE="http://www.terminatorx.org/"
+SRC_URI="http://www.terminatorx.org/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alsa debug mad vorbis sox"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ mad? ( media-sound/madplay )
+ vorbis? ( media-libs/libvorbis )
+ sox? ( media-sound/sox
+ media-sound/mpg123 )
+ >=x11-libs/gtk+-2.2:2
+ >=dev-libs/glib-2.2:2
+ x11-libs/libXi
+ x11-libs/libXxf86dga
+ dev-libs/libxml2
+ media-libs/audiofile
+ media-libs/ladspa-sdk
+ media-libs/ladspa-cmt
+ app-text/scrollkeeper
+ media-libs/liblrdf
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/xf86dgaproto
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Patch from debian to compile with recent zlib
+ epatch "${FILESDIR}"/${PN}-3.84-new-zlib.patch
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable mad) \
+ $(use_enable vorbis) \
+ $(use_enable sox)
+}
+
+src_install() {
+ gnome2_src_install
+ newicon gnome-support/terminatorX-app.png terminatorX.png
+ make_desktop_entry terminatorX terminatorX terminatorX AudioVideo
+}