summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /media-sound
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/id3ed/id3ed-1.10.4-r1.ebuild2
-rw-r--r--media-sound/peercast/peercast-0.1218-r2.ebuild2
-rw-r--r--media-sound/pwavecat/pwavecat-0.4.5.ebuild4
-rw-r--r--media-sound/sndpeek/sndpeek-1.4.ebuild2
-rw-r--r--media-sound/xwax/xwax-1.6.ebuild10
5 files changed, 10 insertions, 10 deletions
diff --git a/media-sound/id3ed/id3ed-1.10.4-r1.ebuild b/media-sound/id3ed/id3ed-1.10.4-r1.ebuild
index 45fd013ab93d..047402e4be69 100644
--- a/media-sound/id3ed/id3ed-1.10.4-r1.ebuild
+++ b/media-sound/id3ed/id3ed-1.10.4-r1.ebuild
@@ -26,7 +26,7 @@ src_prepare() {
}
src_compile() {
- emake CXX="$(tc-getCXX)" CFLAGS="${CFLAGS} -I./" || die
+ emake CXX="$(tc-getCXX)" CFLAGS="${CFLAGS} -I./"
}
src_install() {
diff --git a/media-sound/peercast/peercast-0.1218-r2.ebuild b/media-sound/peercast/peercast-0.1218-r2.ebuild
index 8034fe6aef9d..463ecc557718 100644
--- a/media-sound/peercast/peercast-0.1218-r2.ebuild
+++ b/media-sound/peercast/peercast-0.1218-r2.ebuild
@@ -32,7 +32,7 @@ src_compile() {
cd ui/linux
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}" \
- LD="$(tc-getCXX)" || die "emake failed"
+ LD="$(tc-getCXX)"
}
src_install() {
diff --git a/media-sound/pwavecat/pwavecat-0.4.5.ebuild b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
index 91a5792d8a0c..21a4580caba4 100644
--- a/media-sound/pwavecat/pwavecat-0.4.5.ebuild
+++ b/media-sound/pwavecat/pwavecat-0.4.5.ebuild
@@ -21,10 +21,10 @@ PATCHES=(
src_compile() {
append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
- dobin pwavecat || die
+ dobin pwavecat
default
}
diff --git a/media-sound/sndpeek/sndpeek-1.4.ebuild b/media-sound/sndpeek/sndpeek-1.4.ebuild
index 854e6e44670c..b60e397e0d76 100644
--- a/media-sound/sndpeek/sndpeek-1.4.ebuild
+++ b/media-sound/sndpeek/sndpeek-1.4.ebuild
@@ -37,7 +37,7 @@ compile_backend() {
cd "${S}/src/sndpeek"
einfo "Compiling against ${backend}"
emake -f "makefile.${backend}" CC=$(tc-getCC) \
- CXX=$(tc-getCXX) || die "emake failed"
+ CXX=$(tc-getCXX)
mv sndpeek{,-${backend}}
emake -f "makefile.${backend}" clean
cd -
diff --git a/media-sound/xwax/xwax-1.6.ebuild b/media-sound/xwax/xwax-1.6.ebuild
index 9565610d9290..fe9164967149 100644
--- a/media-sound/xwax/xwax-1.6.ebuild
+++ b/media-sound/xwax/xwax-1.6.ebuild
@@ -67,12 +67,12 @@ src_install() {
# This is easier than setting all the environment variables
# needed, running the sed script required to get the man directory
# correct, and removing the GPL-2 after a 'make install' run
- dobin xwax || die "failed to install xwax"
- newbin scan xwax-scan || die "failed to install xwax-scan"
- newbin import xwax-import || die "failed to install xwax-import"
- doman xwax.1 || die "failed to install man page"
+ dobin xwax
+ newbin scan xwax-scan
+ newbin import xwax-import
+ doman xwax.1
- dodoc ${DOCS} || die "failed to install docs"
+ dodoc ${DOCS}
insinto "/etc/security/limits.d"
newins "${FILESDIR}/xwax-etc-security-limits.conf" xwax.conf