summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-15 19:38:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-24 22:23:18 -0700
commit5ee3dffd8867dbae38871ab851ab46b6ddf53577 (patch)
tree574267fd4d94beb106cdc2c28b72a47957dd90b0 /media-sound
parentmedia-video/ffmpeg: add cpu_flags_ppc_vsx to live ebuild (diff)
downloadgentoo-5ee3dffd8867dbae38871ab851ab46b6ddf53577.tar.gz
gentoo-5ee3dffd8867dbae38871ab851ab46b6ddf53577.tar.bz2
gentoo-5ee3dffd8867dbae38871ab851ab46b6ddf53577.zip
media-sound/mpg123: migrate to CPU_FLAGS_PPC
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg123/mpg123-1.25.13.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-sound/mpg123/mpg123-1.25.13.ebuild b/media-sound/mpg123/mpg123-1.25.13.ebuild
index 2a6b18dd31c2..0b76cb7da365 100644
--- a/media-sound/mpg123/mpg123-1.25.13.ebuild
+++ b/media-sound/mpg123/mpg123-1.25.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
RDEPEND="
@@ -58,7 +58,7 @@ multilib_src_configure() {
done
fi
- use altivec && _cpu=altivec
+ use cpu_flags_ppc_altivec && _cpu=altivec
if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
use cpu_flags_x86_sse && _cpu=x86-64