summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Shkardoon <ss23@ss23.geek.nz>2020-05-02 09:25:35 +1200
committerJoonas Niilola <juippis@gentoo.org>2020-05-04 20:26:07 +0300
commitb43930e019f61c828117a2038d917f176516187d (patch)
tree78bd044333dfb1afcb81cba798a03d65dc6daf3d /media-tv
parentwww-misc/monitorix: Update for GLEP 81 (diff)
downloadgentoo-b43930e019f61c828117a2038d917f176516187d.tar.gz
gentoo-b43930e019f61c828117a2038d917f176516187d.tar.bz2
gentoo-b43930e019f61c828117a2038d917f176516187d.zip
media-tv/plex-media-server: Bump to 1.19.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stephen Shkardoon <ss23@ss23.geek.nz> Closes: https://github.com/gentoo/gentoo/pull/15602 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/plex-media-server/Manifest2
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.19.2.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index e6caaea0c27d..c146ba695816 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -7,3 +7,5 @@ DIST plexmediaserver_1.18.4.2171-ac2afe5f8_amd64.deb 86833802 BLAKE2B a59b1ff4f4
DIST plexmediaserver_1.18.4.2171-ac2afe5f8_i386.deb 73659238 BLAKE2B 3be12b14359f0e7f46f40328414855ece7c36d4cdd0c01dc30cf225ec3e7aef06504b8c2117f634e4ea0960aa387e2d2cfacb2e697d788befa1b76bc973aebf8 SHA512 9641ff170ea3379cf0b6351167206b2923194e831868b1c2245da7bd3a63af12f17ba27c42bd4b4cb8f00bb844e1be6b7427912d1f06096c6e701f579f918d66
DIST plexmediaserver_1.19.1.2645-ccb6eb67e_amd64.deb 90963992 BLAKE2B 470e0217bf42ce835b35fe08c7589f3b45ba90bc4281f549486e716b948dec88cade474ec969acc360358e778debd863fec7eef2bd5a1c53c2f2d723bceef4e2 SHA512 4bfff09efb8c0fc3832a50755b11a4be96fe642c50beaaf833bfb4689c8645428769ebb5c68f92bed82b89c61332f179cd2ca0c5b83424615a2738083da5843c
DIST plexmediaserver_1.19.1.2645-ccb6eb67e_i386.deb 74806258 BLAKE2B 092ec3020c6d895f08804c9938508ae0f3009cf195263b0b2ee977044a194a93823b61ff58581b3e5c0312edf829fb8e88e13ea7345fb9a6afde7e7dfb77fb68 SHA512 5ec858a79e6211931459d116efcc7b6d372404713b74d68366fc03f4ae9bc30566d28190d32ef9c444ae994f67f5f86930967508611b335085854071f91e4c48
+DIST plexmediaserver_1.19.2.2737-b69929dab_amd64.deb 91102918 BLAKE2B 44deeac4ba1922dbb8d1b3504447681db1ca6e56e1545e3dcc0f3a15812f9316d40456f0d95ad52e18d680dba7318f44fef20fb4f77e85e8a74de6645477fedc SHA512 4fb5fb617b56612cc00c181bc9cdf757c9df5c725975345d20adb3f656152b556c0120a48e7223c7a042663cbbd1b9da7e3ccf32cf2dfea4cc76ea5bc1b9893c
+DIST plexmediaserver_1.19.2.2737-b69929dab_i386.deb 74970900 BLAKE2B a29b6db4d21615458c4693f0bc560f552ad5e930a4b65c0b7c48055da3c092fdb3a65862a14fc82f92f117d5c03eecce9a74750704ce3dd976e4b1632490e226 SHA512 c48364f683d8a98c6fa70f1a7f16eb0a67313439670f981d54d107983c3ccc4358ddc2c45bc0e1bcdb70cd095f53c53df4625886dee3e050b0d7cccc96d6b8ca
diff --git a/media-tv/plex-media-server/plex-media-server-1.19.2.ebuild b/media-tv/plex-media-server/plex-media-server-1.19.2.ebuild
new file mode 100644
index 000000000000..5c818884733e
--- /dev/null
+++ b/media-tv/plex-media-server/plex-media-server-1.19.2.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils systemd unpacker pax-utils python-single-r1
+
+MINOR_VERSION="2737-b69929dab"
+
+_APPNAME="plexmediaserver"
+_USERNAME="plex"
+_SHORTNAME="${_USERNAME}"
+_FULL_VERSION="${PV}.${MINOR_VERSION}"
+
+URI="https://downloads.plex.tv/plex-media-server-new"
+
+DESCRIPTION="A free media library that is intended for use with a plex client"
+HOMEPAGE="https://www.plex.tv/"
+SRC_URI="
+ amd64? ( ${URI}/${_FULL_VERSION}/debian/plexmediaserver_${_FULL_VERSION}_amd64.deb )
+ x86? ( ${URI}/${_FULL_VERSION}/debian/plexmediaserver_${_FULL_VERSION}_i386.deb )
+"
+SLOT="0"
+LICENSE="Plex"
+RESTRICT="bindist strip"
+KEYWORDS="-* ~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/virtualenv[${PYTHON_MULTI_USEDEP}]
+ ')"
+BDEPEND="dev-util/patchelf"
+
+RDEPEND="
+ acct-group/plex
+ acct-user/plex
+ net-dns/avahi
+ ${PYTHON_DEPS}"
+
+QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+ "usr/lib/${_APPNAME}/.*"
+ "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
+)
+
+BINS_TO_PAX_MARK=(
+ "${ED}/usr/lib/plexmediaserver/Plex Script Host"
+ "${ED}/usr/lib/plexmediaserver/Plex Media Scanner"
+)
+
+S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}/plexmediamanager.desktop.new.patch"
+ "${FILESDIR}/plexmediaserver.service.patch"
+)
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ # Install base config file
+ insinto "/etc/plex/"
+ newins "${FILESDIR}/etc-plexmediaserver" "plexmediaserver"
+
+ # Remove Debian apt repo files
+ rm -r "etc/apt" || die
+
+ # Remove Debian specific files
+ rm -r "usr/share/doc" || die
+
+ # Copy main files over to image and preserve permissions so it is portable
+ cp -rp usr/ "${ED}"/ || die
+
+ # Make sure the logging directory is created
+ local logging_dir="/var/log/pms"
+ dodir "${logging_dir}"
+ fowners "${_USERNAME}":"${_USERNAME}" "${logging_dir}"
+ keepdir "${logging_dir}"
+
+ # Create default library folder with correct permissions
+ local default_library_dir="/var/lib/${_APPNAME}"
+ dodir "${default_library_dir}"
+ fowners "${_USERNAME}":"${_USERNAME}" "${default_library_dir}"
+ keepdir "${default_library_dir}"
+
+ # Install the OpenRC init/conf files
+ doinitd "${FILESDIR}/init.d/${PN}"
+ doconfd "${FILESDIR}/conf.d/${PN}"
+
+ # Mask Plex libraries so that revdep-rebuild doesn't try to rebuild them.
+ # Plex has its own precompiled libraries.
+ _mask_plex_libraries_revdep
+
+ # Fix RPATH
+ patchelf --force-rpath --set-rpath '$ORIGIN:$ORIGIN/../../../../../../lib' "${ED}"/usr/lib/plexmediaserver/Resources/Python/lib/python2.7/lib-dynload/_codecs_kr.so || die
+
+ # Install systemd service file
+ systemd_newunit "${FILESDIR}/systemd/${PN}.service" "${PN}.service"
+
+ # Add pax markings to some binaries so that they work on hardened setup
+ for f in "${BINS_TO_PAX_MARK[@]}"; do
+ pax-mark m "${f}"
+ done
+
+ # Install start_pms script
+ into /usr
+ dosbin "${FILESDIR}/start_pms"
+
+ einfo "Configuring virtualenv"
+ virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"/usr/lib/plexmediaserver/Resources/Python || die
+ pushd "${ED}"/usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
+ find . -type f -exec sed -i -e "s#${D}##g" {} + || die
+ popd &>/dev/null || die
+}
+
+pkg_postinst() {
+ elog "Plex Media Server is now installed. Please check the configuration"
+ elog "file in /etc/${_SHORTNAME}/${_APPNAME}"
+ elog "to verify the default settings."
+ elog "To start the Plex Server, run 'rc-config start plex-media-server',"
+ elog "you will then be able to access your library at"
+ elog "http://<ip>:32400/web/"
+}
+
+# Adds the precompiled plex libraries to the revdep-rebuild's mask list
+# so it doesn't try to rebuild libraries that can't be rebuilt.
+_mask_plex_libraries_revdep() {
+ dodir /etc/revdep-rebuild/
+
+ # Bug: 659702. The upstream plex binary installs its precompiled package to /usr/lib.
+ # Due to profile 17.1 splitting /usr/lib and /usr/lib64, we can no longer rely
+ # on the implicit symlink automatically satisfying our revdep requirement when we use $(get_libdir).
+ # Thus we will match upstream's directory automatically. If upstream switches their location,
+ # then so should we.
+ echo "SEARCH_DIRS_MASK=\"${EPREFIX}/usr/lib/plexmediaserver\"" > "${ED}"/etc/revdep-rebuild/80plexmediaserver
+}