summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dirac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dirac')
-rw-r--r--media-video/dirac/Manifest1
-rw-r--r--media-video/dirac/dirac-1.0.2-r1.ebuild57
-rw-r--r--media-video/dirac/dirac-1.0.2.ebuild53
-rw-r--r--media-video/dirac/files/dirac-0.5.2-doc.patch59
-rw-r--r--media-video/dirac/metadata.xml11
5 files changed, 181 insertions, 0 deletions
diff --git a/media-video/dirac/Manifest b/media-video/dirac/Manifest
new file mode 100644
index 000000000000..6fa4368f18e9
--- /dev/null
+++ b/media-video/dirac/Manifest
@@ -0,0 +1 @@
+DIST dirac-1.0.2.tar.gz 918366 SHA256 816b16f18d235ff8ccd40d95fc5b4fad61ae47583e86607932929d70bf1f00fd SHA512 71d49fe17da4069ea28581565d5a4c4f64565848b51d04b39a646bdaa9afc899a265e9ace34af57fba64b03562e8c2259f882f6f17c1e49d1057cd8e69d1250c WHIRLPOOL bb01f8a444f79cd194300ff83cae484bd0ff7be58c712cdaf5f525524f68474a89e093999df770d469d38fedae84559f8fab0b087cb448c52dc21daeaeb29ce8
diff --git a/media-video/dirac/dirac-1.0.2-r1.ebuild b/media-video/dirac/dirac-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..c3e2c2dd1717
--- /dev/null
+++ b/media-video/dirac/dirac-1.0.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Open Source video codec"
+HOMEPAGE="http://dirac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug doc cpu_flags_x86_mmx static-libs"
+
+RDEPEND=""
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ media-gfx/graphviz
+ || ( >=app-text/texlive-core-2014 app-text/dvipdfm )
+ )"
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.2-doc.patch
+ AT_M4DIR="m4" eautoreconf
+ export VARTEXFONTS="${T}/fonts"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable debug) \
+ $(multilib_is_native_abi && echo $(use_enable doc))
+ if ! multilib_is_native_abi ; then
+ sed -i -e 's/ encoder decoder util//' Makefile || die
+ fi
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ latexdir="${EPREFIX}/usr/share/doc/${PF}/programmers" \
+ algodir="${EPREFIX}/usr/share/doc/${PF}/algorithm" \
+ faqdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
diff --git a/media-video/dirac/dirac-1.0.2.ebuild b/media-video/dirac/dirac-1.0.2.ebuild
new file mode 100644
index 000000000000..d60ae3b9fffb
--- /dev/null
+++ b/media-video/dirac/dirac-1.0.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Open Source video codec"
+HOMEPAGE="http://dirac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug doc cpu_flags_x86_mmx static-libs"
+
+RDEPEND=""
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ media-gfx/graphviz
+ app-text/dvipdfm
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.2-doc.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ export VARTEXFONTS="${T}/fonts"
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable debug) \
+ $(use_enable doc)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ latexdir="${EPREFIX}/usr/share/doc/${PF}/programmers" \
+ algodir="${EPREFIX}/usr/share/doc/${PF}/algorithm" \
+ faqdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+}
diff --git a/media-video/dirac/files/dirac-0.5.2-doc.patch b/media-video/dirac/files/dirac-0.5.2-doc.patch
new file mode 100644
index 000000000000..211486635dbd
--- /dev/null
+++ b/media-video/dirac/files/dirac-0.5.2-doc.patch
@@ -0,0 +1,59 @@
+diff -x '*~' -ur dirac-0.5.2/configure.ac dirac-0.5.2-doc/configure.ac
+--- dirac-0.5.2/configure.ac 2005-05-20 15:05:25.000000000 +0200
++++ dirac-0.5.2-doc/configure.ac 2005-06-10 03:31:58.683588784 +0200
+@@ -105,28 +105,37 @@
+ dnl -----------------------------------------------
+ dnl Checks for optional programs.
+ dnl -----------------------------------------------
+-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
+- if test $HAVE_DOXYGEN = "false"; then
+- AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
+- fi
+-AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
++AC_ARG_ENABLE(doc, AC_HELP_STRING([--enable-doc], [enables doc building (no)]), [enabledoc=${enableval}], [enabledoc=no])
+
+-AC_CHECK_PROG(HAVE_DOT, dot, true, false)
+- if test $HAVE_DOT = "false"; then
+- AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++if test "x$enabledoc" != "xno"; then
++ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
++ if test $HAVE_DOXYGEN = "false"; then
++ AC_MSG_WARN([*** doxygen not found, code documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DOT, dot, true, false)
++ if test $HAVE_DOT = "false"; then
++ AC_MSG_WARN([*** dot not found, inheritance diagrams will not be generated in code documentation])
++ fi
++
++ AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
++ if test $HAVE_LATEX = "false"; then
++ AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
++ fi
++
++ AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
++ if test $HAVE_DVIPDFM = "false"; then
++ AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+ fi
++else
++HAVE_DOXYGEN=false
++HAVE_DOT=false
++HAVE_LATEX=false
++HAVE_DVIPDFM=false
++fi
++AM_CONDITIONAL(HAVE_DOXYGEN, $HAVE_DOXYGEN)
+ AM_CONDITIONAL(HAVE_DOT, $HAVE_DOT)
+-
+-AC_CHECK_PROG(HAVE_LATEX, latex, true, false)
+- if test $HAVE_LATEX = "false"; then
+- AC_MSG_WARN([*** latex not found, algorithm documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_LATEX, $HAVE_LATEX)
+-
+-AC_CHECK_PROG(HAVE_DVIPDFM, dvipdfm, true, false)
+- if test $HAVE_DVIPDFM = "false"; then
+- AC_MSG_WARN([*** dvipdfm not found, programmer documentation will not be built])
+- fi
+ AM_CONDITIONAL(HAVE_DVIPDFM, $HAVE_DVIPDFM)
+
+ AC_ARG_ENABLE(overlay,
diff --git a/media-video/dirac/metadata.xml b/media-video/dirac/metadata.xml
new file mode 100644
index 000000000000..0627acf562a8
--- /dev/null
+++ b/media-video/dirac/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dirac</remote-id>
+ </upstream>
+</pkgmetadata>