summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 06:42:06 +0100
committerSam James <sam@gentoo.org>2022-07-26 07:22:04 +0100
commit4c1f4ef586b880319c2d4194244c764b15dbb536 (patch)
tree20f3a8a270b4f474e7e10d83ab607e8190ab127b /media-video/harvid/harvid-0.9.0.ebuild
parentdev-python/redis-py: Remove old (diff)
downloadgentoo-4c1f4ef586b880319c2d4194244c764b15dbb536.tar.gz
gentoo-4c1f4ef586b880319c2d4194244c764b15dbb536.tar.bz2
gentoo-4c1f4ef586b880319c2d4194244c764b15dbb536.zip
media-video/harvid: add 0.9.0
Closes: https://bugs.gentoo.org/834405 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/harvid/harvid-0.9.0.ebuild')
-rw-r--r--media-video/harvid/harvid-0.9.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-video/harvid/harvid-0.9.0.ebuild b/media-video/harvid/harvid-0.9.0.ebuild
new file mode 100644
index 000000000000..e99f97aa56f7
--- /dev/null
+++ b/media-video/harvid/harvid-0.9.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTTP Ardour Video Daemon"
+HOMEPAGE="https://x42.github.io/harvid/"
+SRC_URI="https://github.com/x42/harvid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=media-video/ffmpeg-2.6:=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-editors/vim-core
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-parallel-build.patch
+)
+
+hv_make() {
+ emake \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)" \
+ STRIP="true" \
+ NM="$(tc-getNM) -B" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ PREFIX="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ hdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ "${@}"
+}
+
+src_compile() {
+ hv_make -C libharvid
+ hv_make -C src
+ hv_make
+}
+
+src_install() {
+ hv_make DESTDIR="${D}" install
+ dodoc ChangeLog README.md
+}