summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2021-01-08 09:02:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-10 16:55:08 +0200
commitacafeeedbce3a385e8fd9b8f052f3e9e7f0ee294 (patch)
treef7880f691fefff681dcd4a0601b39cf42b836d5a /media-video/shotcut
parentmedia-video/shotcut: remove old (diff)
downloadgentoo-acafeeedbce3a385e8fd9b8f052f3e9e7f0ee294.tar.gz
gentoo-acafeeedbce3a385e8fd9b8f052f3e9e7f0ee294.tar.bz2
gentoo-acafeeedbce3a385e8fd9b8f052f3e9e7f0ee294.zip
media-video/shotcut: add live ebuild
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/shotcut-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-video/shotcut/shotcut-9999.ebuild b/media-video/shotcut/shotcut-9999.ebuild
new file mode 100644
index 000000000000..598b4f6b6561
--- /dev/null
+++ b/media-video/shotcut/shotcut-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-6.22.1[ffmpeg,frei0r,fftw,jack,melt(+),opengl,qt5,sdl,xml]
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ virtual/jack
+"
+
+src_configure() {
+ eqmake5 \
+ PREFIX="${EPREFIX}/usr" \
+ SHOTCUT_VERSION="${PV}" \
+ DEFINES+=SHOTCUT_NOUPGRADE
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}