summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2023-02-01 19:20:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-24 17:46:55 +0200
commite2a6b7a45a608e6408209eb2000aa001c636427f (patch)
treefc3a8442fef30e8295aca45d1307464062182da5 /media-video/shotcut
parentmedia-fonts/noto: add github upstream metadata (diff)
downloadgentoo-e2a6b7a45a608e6408209eb2000aa001c636427f.tar.gz
gentoo-e2a6b7a45a608e6408209eb2000aa001c636427f.tar.bz2
gentoo-e2a6b7a45a608e6408209eb2000aa001c636427f.zip
media-video/shotcut: add 22.12.21
Closes: https://bugs.gentoo.org/892684 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/shotcut-22.12.21.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 3ee3a2088c56..d9cc81902075 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1,2 +1,3 @@
DIST shotcut-22.04.25.tar.gz 4600941 BLAKE2B 5f8ba47897c3a8ce078a35c06c90454c8c1df9bd9bd3330466a1be869b7b9c9ec45aaf6d3b5aad0587857ff5613ef22f15c4b5142c8247b97c81bb8345b3ff4d SHA512 e5c51868a7f6e2ead3993d8577b5439408e9c54ee20274658c822666e2ca5fceb7d2360d02b8808b464c69005d83b6742a3a750ec244ffe69f82f2abd5ad39fc
DIST shotcut-22.09.23.tar.gz 9096319 BLAKE2B 4023ca82f72e5fb3dca9dfed18912f0b8a99ef5915b0bb1ca983269b99b4b057747558801e2dfe65c89e68c4e9fcfc0a1cc9bcc24ce4d44d1e5453b94d639da2 SHA512 3c680a36ed4e22e857a824eaa25a63aa6cb830751e9730d4cd5e0a6fa2b087d9b63900232155fe5f656a4d70ae27dabc5fad52ed39d6b53f99188c954f9896d8
+DIST shotcut-22.12.21.tar.gz 9857227 BLAKE2B 94739b1f2d66c8d4ebc69ded7c90a75f973b17889fce538855403f92b5232514df45f6e3648ef772b9a22c27b547ce2b7f0f6eb391cc47dfebaf9907f0c6525f SHA512 95ca399657934becedd71c3daa74749bca1b625a0cedf8df4bfd212476602f83f5b807b26ec7c8275ee720e54893102931bf109c95153fc16f348d344e50395b
diff --git a/media-video/shotcut/shotcut-22.12.21.ebuild b/media-video/shotcut/shotcut-22.12.21.ebuild
new file mode 100644
index 000000000000..db68f3435f7b
--- /dev/null
+++ b/media-video/shotcut/shotcut-22.12.21.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+IUSE="debug"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-7.8.0[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtquickcontrols[widgets]
+ dev-qt/qtgraphicaleffects:5
+ virtual/jack
+"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+ local mycmakeargs=(
+ -DSHOTCUT_VERSION="${PV}"
+ )
+ use debug || append-cxxflags "-DNDEBUG"
+ append-cxxflags "-DSHOTCUT_NOUPGRADE"
+ cmake_src_configure
+}