summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-03-27 16:56:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-03-31 14:09:19 +0300
commit8c1a5ec7827eeb84e92b2c983c222ad62e7e1de9 (patch)
tree33cbfbd7a1aa58682399a8985ca2722de89a8197 /media-video
parentsci-visualization/gnuplot: Don't install binary demo files (diff)
downloadgentoo-8c1a5ec7827eeb84e92b2c983c222ad62e7e1de9.tar.gz
gentoo-8c1a5ec7827eeb84e92b2c983c222ad62e7e1de9.tar.bz2
gentoo-8c1a5ec7827eeb84e92b2c983c222ad62e7e1de9.zip
media-video/qmplay2: add 21.03.09
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/qmplay2/Manifest1
-rw-r--r--media-video/qmplay2/metadata.xml1
-rw-r--r--media-video/qmplay2/qmplay2-21.03.09.ebuild139
3 files changed, 141 insertions, 0 deletions
diff --git a/media-video/qmplay2/Manifest b/media-video/qmplay2/Manifest
index 25e3dcaa60e5..4f6103c9d869 100644
--- a/media-video/qmplay2/Manifest
+++ b/media-video/qmplay2/Manifest
@@ -1 +1,2 @@
DIST QMPlay2-src-20.07.04.tar.xz 1552680 BLAKE2B cc53ef842f91312f72e8d347a2d6d2e4239fe9435d0b7ac39e47e9f1f48a9a570ce614dd496512079d3701e1823ab75123b40ad752fdd2348cdb7bc8de425225 SHA512 4a6316f03d1b77bcd6c08de0daefc3f29b4c8c575eae9f901951e2b43f2739904136b9455f567b66fc9a4e4c64fe92584608f1878dd8c30c0352ea9ee1e2e314
+DIST QMPlay2-src-21.03.09.tar.xz 1568600 BLAKE2B da3a185ae2e372b0bad697e4ad7d836647c5b4bb376f0ee3f7e85e387c10b86f1a3fdaf8eb13a2c9a8d3b7d56105e282cc82f22d31043e9e418ee907776f1db2 SHA512 311fe45a9ee237556faeee29633be6161407a31b19fd3bceca5a164e92ff1757824094d20f6b556c0a4beaac07a14179e812faafc5e41ee904cf1ce1827fb138
diff --git a/media-video/qmplay2/metadata.xml b/media-video/qmplay2/metadata.xml
index dd91b14c1c27..6d801343bc9c 100644
--- a/media-video/qmplay2/metadata.xml
+++ b/media-video/qmplay2/metadata.xml
@@ -26,6 +26,7 @@
<flag name="inputs">Build with Inputs module</flag>
<flag name="libass">Build with SSA/ASS subtitles rendering support</flag>
<flag name="notifications">Build additional notifications module</flag>
+ <flag name="pipewire">Build with PipeWire support</flag>
<flag name="sid">Build Chiptune with SIDPLAY support</flag>
<flag name="shaders">Compile Vulkan shaders using <pkg>media-libs/shaderc</pkg></flag>
<flag name="videofilters">Build with VideoFilters module</flag>
diff --git a/media-video/qmplay2/qmplay2-21.03.09.ebuild b/media-video/qmplay2/qmplay2-21.03.09.ebuild
new file mode 100644
index 000000000000..b626780caa01
--- /dev/null
+++ b/media-video/qmplay2/qmplay2-21.03.09.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="A Qt-based video player, which can play most formats and codecs"
+HOMEPAGE="https://github.com/zaps166/QMPlay2"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zaps166/QMPlay2"
+else
+ SRC_URI="https://github.com/zaps166/QMPlay2/releases/download/${PV}/QMPlay2-src-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/QMPlay2-src-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+IUSE="avdevice +audiofilters +alsa cdio cuvid dbus extensions
+ gme inputs libass modplug notifications opengl pipewire portaudio
+ pulseaudio sid shaders vaapi vdpau +videofilters visualizations vulkan xv"
+
+REQUIRED_USE="
+ audiofilters? ( || ( alsa pipewire portaudio pulseaudio ) )
+ extensions? ( dbus )
+ shaders? ( vulkan )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/ffmpeg
+ || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ )
+ alsa? ( media-libs/alsa-lib )
+ cdio? ( dev-libs/libcdio[cddb] )
+ dbus? ( dev-qt/qtdbus:5 )
+ extensions? (
+ dev-qt/qtdeclarative:5
+ media-libs/taglib
+ )
+ gme? ( media-libs/game-music-emu )
+ libass? ( media-libs/libass )
+ opengl? ( virtual/opengl )
+ pipewire? ( media-video/pipewire )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sid? ( media-libs/libsidplayfp )
+ shaders? ( >=media-libs/shaderc-2020.1 )
+ vaapi? (
+ >=media-video/ffmpeg-4.1.3[vaapi]
+ x11-libs/libva[drm,opengl]
+ )
+ vdpau? ( media-video/ffmpeg[vdpau] )
+ videofilters? ( dev-qt/qtconcurrent:5 )
+ vulkan? (
+ >=dev-qt/qtgui-5.14.1:5[vulkan]
+ >=media-libs/vulkan-loader-1.2.133
+ )
+ xv? ( x11-libs/libXv )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_prepare() {
+ # disable compress man pages
+ sed -r \
+ -e 's/if\(GZIP\)/if\(TRUE\)/' \
+ -e 's/(install.+QMPlay2\.1)\.gz/\1/' \
+ -i src/gui/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # core
+ -DUSE_LINK_TIME_OPTIMIZATION=false
+ -DUSE_ALSA=$(usex alsa)
+ -DUSE_AUDIOCD=$(usex cdio)
+ -DUSE_FREEDESKTOP_NOTIFICATIONS=$(usex dbus) # https://github.com/zaps166/QMPlay2/issues/134
+ -DUSE_LIBASS=$(usex libass)
+ -DUSE_NOTIFY=$(usex notifications)
+ -DUSE_OPENGL=$(usex opengl)
+ -DUSE_VULKAN=$(usex vulkan)
+ -DUSE_GLSLC=$(usex shaders)
+ -DUSE_XVIDEO=$(usex xv)
+
+ # ffmpeg
+ -DUSE_FFMPEG_AVDEVICE=$(usex avdevice)
+ -DUSE_FFMPEG_VAAPI=$(usex vaapi)
+ -DUSE_FFMPEG_VDPAU=$(usex vdpau)
+
+ # chiptune
+ -DUSE_CHIPTUNE_GME=$(usex gme)
+ -DUSE_CHIPTUNE_SID=$(usex sid)
+
+ # modules
+ -DUSE_AUDIOFILTERS=$(usex audiofilters)
+ -DUSE_CUVID=$(usex cuvid)
+ -DUSE_INPUTS=$(usex inputs)
+ -DUSE_MODPLUG=$(usex modplug)
+ -DUSE_PIPEWIRE=$(usex pipewire)
+ -DUSE_PORTAUDIO=$(usex portaudio)
+ -DUSE_PULSEAUDIO=$(usex pulseaudio)
+ -DUSE_VIDEOFILTERS=$(usex videofilters)
+ -DUSE_VISUALIZATIONS=$(usex visualizations)
+
+ # extensions
+ -DUSE_EXTENSIONS=$(usex extensions)
+ -DUSE_TAGLIB=$(usex extensions)
+ -DUSE_LASTFM=$(usex extensions)
+ -DUSE_LYRICS=$(usex extensions)
+ -DUSE_MEDIABROWSER=$(usex extensions)
+ -DUSE_MPRIS2=$(usex extensions)
+ )
+
+ # find and link vulkan libs permanently
+ if use vulkan; then
+ mycmakeargs+=( -DQMVK_FIND_VULKAN=true )
+ fi
+
+ if [[ ${PV} == *9999 ]]; then
+ mycmakeargs+=( USE_GIT_VERSION=true )
+ else
+ mycmakeargs+=( USE_GIT_VERSION=false )
+ fi
+
+ cmake_src_configure
+}