summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/arping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/arping')
-rw-r--r--net-analyzer/arping/Manifest1
-rw-r--r--net-analyzer/arping/arping-2.15-r2.ebuild27
-rw-r--r--net-analyzer/arping/arping-2.15.ebuild41
-rw-r--r--net-analyzer/arping/files/arping-2.15-setgroups.patch23
-rw-r--r--net-analyzer/arping/metadata.xml5
5 files changed, 97 insertions, 0 deletions
diff --git a/net-analyzer/arping/Manifest b/net-analyzer/arping/Manifest
new file mode 100644
index 000000000000..aaf05e8be906
--- /dev/null
+++ b/net-analyzer/arping/Manifest
@@ -0,0 +1 @@
+DIST arping-2.15.tar.gz 149061 SHA256 9d45dae3a88749092cef1dd7f5cbb4d3b7be8715a938384ef3139790884251f3 SHA512 89fb5ef1d7663d3577094e250751675ed9bc54fe95fa96d85138a2cf31f422c9b829c90902877bd6dd3f1102194ce0b53af9ef483fbb7e33ce2ae81283b5d52b WHIRLPOOL 2dd43c644f57182c8372c2bc14820352db72309eab594b2797e123af20e3f8af7a6016c22e5b014f93102b689bb7e60ace349f2b14d9ff00d5de944c6e2e4d6f
diff --git a/net-analyzer/arping/arping-2.15-r2.ebuild b/net-analyzer/arping/arping-2.15-r2.ebuild
new file mode 100644
index 000000000000..93b1d790862a
--- /dev/null
+++ b/net-analyzer/arping/arping-2.15-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="${DEPEND}
+ !net-misc/iputils[arping(+)]"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.15-setgroups.patch
+
+ eautoreconf
+}
diff --git a/net-analyzer/arping/arping-2.15.ebuild b/net-analyzer/arping/arping-2.15.ebuild
new file mode 100644
index 000000000000..c2cdc98995dc
--- /dev/null
+++ b/net-analyzer/arping/arping-2.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f Makefile
+
+ # since we install as arping2, use arping2 in documentation
+ sed -i \
+ -e "s|\(${PN}\)|\12|g" \
+ -e "s|\(${PN}\)\(\W\)|\12\2|g" \
+ -e "s|${PN}2-|${PN}-|g" \
+ -e "s|(${PN}2 2.*\.x only)||g" \
+ doc/${PN}.8 || die
+ sed -i \
+ -e "s|\(${PN}\) |\12 |g" \
+ extra/${PN}-scan-net.sh || die
+}
+
+src_install() {
+ # since we install as arping2, we cannot use emake install
+ newsbin src/${PN} ${PN}2
+ newman doc/${PN}.8 ${PN}2.8
+ dodoc README extra/arping-scan-net.sh
+}
diff --git a/net-analyzer/arping/files/arping-2.15-setgroups.patch b/net-analyzer/arping/files/arping-2.15-setgroups.patch
new file mode 100644
index 000000000000..59b675814814
--- /dev/null
+++ b/net-analyzer/arping/files/arping-2.15-setgroups.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,7 @@
+ stdlib.h \
+ sys/socket.h \
+ time.h \
++grp.h \
+ sys/time.h \
+ sys/types.h \
+ sys/capability.h \
+--- a/src/arping.c
++++ b/src/arping.c
+@@ -98,6 +98,10 @@
+ #endif
+ #include <pcap.h>
+
++#if HAVE_GRP_H
++#include <grp.h>
++#endif
++
+ #include "arping.h"
+
+ #ifndef ETH_ALEN
diff --git a/net-analyzer/arping/metadata.xml b/net-analyzer/arping/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/arping/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>