summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-25 18:36:23 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-25 18:40:31 +0200
commit711e19ade6d70c3b33b175580560bdef1d1b8726 (patch)
tree849f1559959bc6e11690370d37d920ca46e2a76b /net-analyzer/netio
parentdev-db/sqlite: Stabilize 3.33.0 arm64, #738220 (diff)
downloadgentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.tar.gz
gentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.tar.bz2
gentoo-711e19ade6d70c3b33b175580560bdef1d1b8726.zip
net-analyzer/netio: Version 1.33
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Closes: https://bugs.gentoo.org/731196 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/netio')
-rw-r--r--net-analyzer/netio/Manifest1
-rw-r--r--net-analyzer/netio/files/netio-1.26-linux-include.patch3
-rw-r--r--net-analyzer/netio/netio-1.33.ebuild44
3 files changed, 45 insertions, 3 deletions
diff --git a/net-analyzer/netio/Manifest b/net-analyzer/netio/Manifest
index cd3890f6d5e0..ade3fa30d715 100644
--- a/net-analyzer/netio/Manifest
+++ b/net-analyzer/netio/Manifest
@@ -1 +1,2 @@
DIST netio132.zip 162484 BLAKE2B 921b28d25a8042b5567393b088fbede3f8bff2d4bf6c8afcaab03a76487ddc48e6cd640b2cbe7114b022cacef9fcf5ccc3deaa9eed2b648898d7f2dfb40e133c SHA512 3473b6b41c4a1e054fa0eb3316bc16e799034b4b9402c7751f29724d8ec70c674d3de59140fdbdc301c53f2a24b44d58e8cd50a68f107bd892b1d17b6e695232
+DIST netio133.zip 235931 BLAKE2B e664700b5991e38ad056333b13ba6ec40efd2a9a496dd9235ad40482b281f21ca54f49e037a0155d3ca0b1d77bd54330462d08abe5f809c6ee337b672c979995 SHA512 79a4d8ad5a5d9750a19bf7f8f4cc762e6d1a866a63138bfc1cf8614057eb8ade147817e489f93210990ce9d82be03a5053821663212fbee71c4cd46c2f9c9232
diff --git a/net-analyzer/netio/files/netio-1.26-linux-include.patch b/net-analyzer/netio/files/netio-1.26-linux-include.patch
index e006c82d71aa..591cae323842 100644
--- a/net-analyzer/netio/files/netio-1.26-linux-include.patch
+++ b/net-analyzer/netio/files/netio-1.26-linux-include.patch
@@ -1,6 +1,3 @@
-Add missing include (see inet(3)) - JeR
-
-
--- a/netio.c
+++ b/netio.c
@@ -199,6 +199,7 @@
diff --git a/net-analyzer/netio/netio-1.33.ebuild b/net-analyzer/netio/netio-1.33.ebuild
new file mode 100644
index 000000000000..b1b367dca376
--- /dev/null
+++ b/net-analyzer/netio/netio-1.33.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit edos2unix toolchain-funcs
+
+DESCRIPTION="Network benchmark using TCP and UDP protocols"
+HOMEPAGE="https://web.ars.de/netio/"
+SRC_URI="https://www.ars.de/${PN}${PV/.}.zip"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+RESTRICT="mirror" # bug #391789 comment #1
+
+DEPEND="
+ app-arch/unzip
+ >=sys-apps/sed-4
+"
+S=${WORKDIR}
+
+src_prepare() {
+ edos2unix *.c *.h *.doc
+
+ default
+
+ sed -i \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ linux
+}
+
+src_install() {
+ dobin netio
+ dodoc netio.doc
+}