summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/netwag
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/netwag')
-rw-r--r--net-analyzer/netwag/Manifest2
-rw-r--r--net-analyzer/netwag/metadata.xml9
-rw-r--r--net-analyzer/netwag/netwag-5.39.0.ebuild61
3 files changed, 72 insertions, 0 deletions
diff --git a/net-analyzer/netwag/Manifest b/net-analyzer/netwag/Manifest
new file mode 100644
index 000000000000..fcf686711622
--- /dev/null
+++ b/net-analyzer/netwag/Manifest
@@ -0,0 +1,2 @@
+DIST netwag-5.39.0-doc_html.tgz 46461 SHA256 5dfc818ac1a66274ace0524eddf5fce2b617cad3652e16e619e6fb541d6565c5 SHA512 499d201b510c5175b09c7dbcc8b9bec1d9aa2fbf90613a937f88be5835dd67acfe28e78483ce2124c4fa3b43ea8f409ce6115e48f12ae0ffc4ad684354488030 WHIRLPOOL 076bb7b93901cdfc9a1c24c92f53ed1fb7c0622b3a0548a9624de7c890f8abbdac20ded96485761ef5adfc67fa0c6e94463743a114bb74097b3c099af7379d21
+DIST netwag-5.39.0-src.tgz 164731 SHA256 e625c840797dc3568ede90dafdee6a0b63775d77c291d418cd9a2e7242e35a57 SHA512 a9f0279d42666eff636bb66258a17a4e10528b7329dfe5e5d8c0ddce15048d847a2a8e892ba82a606b37ceb328b8b31be52d7e8ee7aeb6feb1f3d254aa3a2401 WHIRLPOOL d2ceab34df6af18bd46162ce435ba0ac5fa8c2cac94436ce506925b36e4bb91d01e5c6b380fdba9eda038ce44591bc5e0a3485e6c1728a87c1419b8fd3858b5e
diff --git a/net-analyzer/netwag/metadata.xml b/net-analyzer/netwag/metadata.xml
new file mode 100644
index 000000000000..296a5fe08647
--- /dev/null
+++ b/net-analyzer/netwag/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>Toolbox of 222 utilities for testing Ethernet/IP networks</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ntwag</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/netwag/netwag-5.39.0.ebuild b/net-analyzer/netwag/netwag-5.39.0.ebuild
new file mode 100644
index 000000000000..cc0278e49905
--- /dev/null
+++ b/net-analyzer/netwag/netwag-5.39.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI=5
+
+DESCRIPTION="Tcl/tk interface to netwox (Toolbox of 222 utilities for testing Ethernet/IP networks)"
+HOMEPAGE="
+ http://ntwag.sourceforge.net/
+ http://www.laurentconstantin.com/en/netw/netwag/
+"
+SRC_URI="mirror://sourceforge/ntwag/${P}-src.tgz
+ doc? ( mirror://sourceforge/ntwag/${P}-doc_html.tgz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc x86"
+IUSE="doc"
+
+DEPEND="
+ ~net-analyzer/netwox-${PV}
+ >=dev-lang/tk-8
+ || (
+ x11-terms/xterm
+ kde-apps/konsole
+ x11-terms/eterm
+ x11-terms/gnome-terminal
+ x11-terms/rxvt
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src/src"
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/usr/local:/usr:" \
+ config.dat || die
+ sed -i \
+ -e 's|eterm|Eterm|g' \
+ genemake || die
+}
+
+src_configure() {
+ sh genemake || die "problem creating Makefile"
+}
+
+DOCS=(
+ "${WORKDIR}"/${P}-src/README.TXT
+ "${WORKDIR}"/${P}-src/doc/{changelog.txt,credits.txt}
+ "${WORKDIR}"/${P}-src/doc/{problemreport.txt,problemusage.txt,todo.txt}
+)
+
+src_install() {
+ default
+
+ use doc && dohtml -r "${WORKDIR}"/${P}-doc_html/*
+}