summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-26 10:59:41 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-26 10:59:59 +0200
commit486c3e75a9612e24bef1dfa19ec62aba3653632d (patch)
tree073bb70e691535be00f1c4ed3953808f505b6122 /net-analyzer/nmap
parentdev-scheme/greg: amd64 stable wrt bug #626694 (diff)
downloadgentoo-486c3e75a9612e24bef1dfa19ec62aba3653632d.tar.gz
gentoo-486c3e75a9612e24bef1dfa19ec62aba3653632d.tar.bz2
gentoo-486c3e75a9612e24bef1dfa19ec62aba3653632d.zip
net-analyzer/nmap: Update live ebuild.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/nmap-7.60.ebuild13
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild41
2 files changed, 34 insertions, 20 deletions
diff --git a/net-analyzer/nmap/nmap-7.60.ebuild b/net-analyzer/nmap/nmap-7.60.ebuild
index 2e1a4c752581..e925ad725d85 100644
--- a/net-analyzer/nmap/nmap-7.60.ebuild
+++ b/net-analyzer/nmap/nmap-7.60.ebuild
@@ -37,9 +37,7 @@ RDEPEND="
dev-libs/liblinear:=
dev-libs/libpcre
net-libs/libpcap
- libssh2? (
- net-libs/libssh2[zlib]
- )
+ libssh2? ( net-libs/libssh2[zlib] )
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
nmap-update? (
@@ -60,8 +58,6 @@ DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
"
-
-S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-5.10_beta1-string.patch
"${FILESDIR}"/${PN}-5.21-python.patch
@@ -72,6 +68,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.25-libpcre.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
)
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use ndiff || use zenmap; then
@@ -128,7 +125,9 @@ src_prepare() {
configure.ac
cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
+
eautoreconf
+
if [[ ${CHOST} == *-darwin* ]] ; then
# we need the original for a Darwin-specific fix, bug #604432
mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
@@ -141,14 +140,14 @@ src_configure() {
econf \
$(use_enable ipv6) \
$(use_enable nls) \
- $(use_with ncat) \
$(use_with libssh2) \
- $(usex libssh2 --with-zlib) \
+ $(use_with ncat) \
$(use_with ndiff) \
$(use_with nmap-update) \
$(use_with nping) \
$(use_with ssl openssl) \
$(use_with zenmap) \
+ $(usex libssh2 --with-zlib) \
$(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
--cache-file="${S}"/config.cache \
--with-libdnet=included \
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index ef0334de9f3f..d78311ad1c1b 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -10,7 +10,7 @@ inherit autotools flag-o-matic git-r3 python-single-r1 toolchain-funcs user
MY_P=${P/_beta/BETA}
DESCRIPTION="A utility for network discovery and security auditing"
-HOMEPAGE="http://nmap.org/"
+HOMEPAGE="https://nmap.org/"
EGIT_REPO_URI="https://github.com/nmap/nmap"
SRC_URI="https://dev.gentoo.org/~jer/nmap-logo-64.png"
@@ -18,7 +18,10 @@ SRC_URI="https://dev.gentoo.org/~jer/nmap-logo-64.png"
LICENSE="GPL-2"
SLOT="0"
-IUSE="ipv6 libressl +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
+IUSE="
+ ipv6 libressl libssh2 ncat ndiff nls nmap-update nping +nse ssl system-lua
+ zenmap
+"
NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
@@ -32,35 +35,38 @@ RDEPEND="
dev-libs/liblinear:=
dev-libs/libpcre
net-libs/libpcap
- zenmap? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )
- system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
+ libssh2? ( net-libs/libssh2[zlib] )
ndiff? ( ${PYTHON_DEPS} )
nls? ( virtual/libintl )
- nmap-update? ( dev-libs/apr dev-vcs/subversion )
+ nmap-update? (
+ dev-libs/apr
+ dev-vcs/subversion
+ )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
+ system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
+ zenmap? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
"
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
"
-
-S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-5.10_beta1-string.patch
"${FILESDIR}"/${PN}-5.21-python.patch
- "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
"${FILESDIR}"/${PN}-6.46-uninstaller.patch
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+ "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
"${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
"${FILESDIR}"/${PN}-7.25-libpcre.patch
- "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
)
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use ndiff || use zenmap; then
@@ -94,14 +100,21 @@ src_prepare() {
sed -i \
-e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
Makefile.in || die
-
# Fix desktop files wrt bug #432714
sed -i \
-e 's|^Categories=.*|Categories=Network;System;Security;|g' \
zenmap/install_scripts/unix/zenmap-root.desktop \
zenmap/install_scripts/unix/zenmap.desktop || die
+
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS(libz)/d' \
+ -e '/AC_CONFIG_SUBDIRS(libssh2)/d' \
+ configure.ac
+
cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
+
eautoreconf
+
if [[ ${CHOST} == *-darwin* ]] ; then
# we need the original for a Darwin-specific fix, bug #604432
mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
@@ -114,12 +127,14 @@ src_configure() {
econf \
$(use_enable ipv6) \
$(use_enable nls) \
+ $(use_with libssh2) \
$(use_with ncat) \
$(use_with ndiff) \
$(use_with nmap-update) \
$(use_with nping) \
$(use_with ssl openssl) \
$(use_with zenmap) \
+ $(usex libssh2 --with-zlib) \
$(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
--cache-file="${S}"/config.cache \
--with-libdnet=included \