summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/syweb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/syweb')
-rw-r--r--net-analyzer/syweb/Manifest1
-rw-r--r--net-analyzer/syweb/files/postinstall-en.txt8
-rw-r--r--net-analyzer/syweb/files/reconfig20
-rw-r--r--net-analyzer/syweb/metadata.xml5
-rw-r--r--net-analyzer/syweb/syweb-0.65.ebuild43
5 files changed, 77 insertions, 0 deletions
diff --git a/net-analyzer/syweb/Manifest b/net-analyzer/syweb/Manifest
new file mode 100644
index 000000000000..b96ba4278772
--- /dev/null
+++ b/net-analyzer/syweb/Manifest
@@ -0,0 +1 @@
+DIST syweb-0.65.tar.gz 37052 SHA256 b37492b7180f27731b7ed3241f9e39d57633d10d0af3f9a19b52ed3df33595a2 SHA512 ca4a4ad6f48dc4ff32c11979d6f34ae6f87462fd295780cdef6609ca425d21698ff43e2c5ffbf43a1f1ecccef4718891992160d1fbc1325726c474d113f824b2 WHIRLPOOL 5b5edb41e65da5e53a33d32a5320dafcc540b7b5770c0f42213684cdaef5d1dce4a2310d11e8b62c1371ad62083c2be9ffff3d5c405e3ca331d30e777b3f338e
diff --git a/net-analyzer/syweb/files/postinstall-en.txt b/net-analyzer/syweb/files/postinstall-en.txt
new file mode 100644
index 000000000000..291d66d4e381
--- /dev/null
+++ b/net-analyzer/syweb/files/postinstall-en.txt
@@ -0,0 +1,8 @@
+Test your syweb installation by pointing your browser to the URL
+http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/configtest.php
+
+If you don't want any user interaction, move index_noui.php to index.php.
+
+syweb expects a <host>/*.rrd style directory structure under
+/var/lib/symon/rrds. Customize ${MY_INSTALLDIR}/setup.inc
+if this is incorrect for your setup.
diff --git a/net-analyzer/syweb/files/reconfig b/net-analyzer/syweb/files/reconfig
new file mode 100644
index 000000000000..79324cc1c7d0
--- /dev/null
+++ b/net-analyzer/syweb/files/reconfig
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+die() {
+ echo "#####"
+ echo $1
+ echo "#####"
+ exit 1
+}
+
+sed_var() {
+ sed -i "/\\$symon['$1']/s|=.*|='$2';|" "${MY_INSTALLDIR}"/setup.inc \
+ || die "sed $1 failed"
+}
+
+[[ $1 == "clean" ]] && exit 0
+
+sed_var rrdtool_path /usr/bin/rrdtool
+sed_var cache_dir "${VHOST_ROOT}"/syweb/cache
+sed_var host_tree /var/lib/symon/rrds
+sed_var layout_dir "${VHOST_ROOT}"/syweb
diff --git a/net-analyzer/syweb/metadata.xml b/net-analyzer/syweb/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-analyzer/syweb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/syweb/syweb-0.65.ebuild b/net-analyzer/syweb/syweb-0.65.ebuild
new file mode 100644
index 000000000000..c4c1824d8cf8
--- /dev/null
+++ b/net-analyzer/syweb/syweb-0.65.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WEBAPP_MANUAL_SLOT="yes"
+inherit webapp
+
+DESCRIPTION="Web frontend to symon"
+HOMEPAGE="http://www.xs4all.nl/~wpd/symon/"
+SRC_URI="http://www.xs4all.nl/~wpd/symon/philes/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ net-analyzer/rrdtool"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG README
+ docinto layouts
+ dodoc symon/*.layout
+
+ dodir "${MY_HOSTROOTDIR}"/syweb/cache
+ insinto "${MY_HOSTROOTDIR}"/syweb
+ doins symon/hifn_test.layout
+ webapp_serverowned "${MY_HOSTROOTDIR}"/syweb/cache
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/syweb/*
+ webapp_configfile "${MY_HTDOCSDIR}"/setup.inc
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
+
+ webapp_src_install
+}