summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/tsung
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/tsung')
-rw-r--r--net-analyzer/tsung/Manifest2
-rw-r--r--net-analyzer/tsung/metadata.xml8
-rw-r--r--net-analyzer/tsung/tsung-1.5.1.ebuild34
-rw-r--r--net-analyzer/tsung/tsung-1.6.0.ebuild34
4 files changed, 78 insertions, 0 deletions
diff --git a/net-analyzer/tsung/Manifest b/net-analyzer/tsung/Manifest
new file mode 100644
index 000000000000..df726951047d
--- /dev/null
+++ b/net-analyzer/tsung/Manifest
@@ -0,0 +1,2 @@
+DIST tsung-1.5.1.tar.gz 1422049 SHA256 551457ffe89d1c5b7d064b13fe82e6bff00523ccc7a00367b0ae38cad0c2282b SHA512 e6efe3b1b44d0511febe189e63087a484e16f7c1f77f3e3fc3f84154061f9d7020e5b93bac32a45ae9a519a0e34ba50e0d155d3199996c95876f060caa410db6 WHIRLPOOL b1e35c23993b68053b74f1b38ea2ecc20c5c5c4f514a7e4daacc85fd8a61586ddb407d9c12b6d5d4016907eb9d145b670db7aef9b51ca7e870e0f26122dbbe24
+DIST tsung-1.6.0.tar.gz 1585794 SHA256 56846c3a90fd7037d9a76330cb8f3052238344491e2fe6ef1ebdb0b620eb3d84 SHA512 c66a84fc9b6781398ed4dee67f076fcddca28c5156782c05d6f5d7ce3e5e2ed6dbdb4076585f45a42aea65237b68aa08c8c80539706202a10cfec4e3ac8170cd WHIRLPOOL 3f083239c6c0950b6420dd7d401d0267f30655f5a3470f136326e6cc35414f779d58eb8e8aeac40eecb279976f5228369e5786e9df2b582e4ed75b45dc9fd35b
diff --git a/net-analyzer/tsung/metadata.xml b/net-analyzer/tsung/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/net-analyzer/tsung/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/tsung/tsung-1.5.1.ebuild b/net-analyzer/tsung/tsung-1.5.1.ebuild
new file mode 100644
index 000000000000..8bc875d843a3
--- /dev/null
+++ b/net-analyzer/tsung/tsung-1.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+# Seems to be misconfigured
+RESTRICT="test"
+
+inherit eutils
+
+DESCRIPTION="Erlang's multi-protocol distributed load testing tool"
+HOMEPAGE="http://tsung.erlang-projects.org/"
+SRC_URI="http://tsung.erlang-projects.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/erlang"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ ./configure --prefix="/usr" || die "econf failed"
+}
+
+src_compile() {
+ emake || die "Failed building"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Failed installing"
+}
diff --git a/net-analyzer/tsung/tsung-1.6.0.ebuild b/net-analyzer/tsung/tsung-1.6.0.ebuild
new file mode 100644
index 000000000000..e9bd34102d56
--- /dev/null
+++ b/net-analyzer/tsung/tsung-1.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+# Seems to be misconfigured
+RESTRICT="test"
+
+inherit eutils
+
+DESCRIPTION="Erlang's multi-protocol distributed load testing tool"
+HOMEPAGE="http://tsung.erlang-projects.org/"
+SRC_URI="http://tsung.erlang-projects.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/erlang"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ ./configure --prefix="/usr" || die "econf failed"
+}
+
+src_compile() {
+ emake || die "Failed building"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Failed installing"
+}