summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-30 11:21:42 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-30 11:21:42 +0200
commit378bb3556692362ea71f268bfcc1131ad90d66da (patch)
tree00115b6a33345fa685700d7833cdb6ee0fc88dc2 /net-analyzer
parentnet-analyzer/wireshark: Version bump. (diff)
downloadgentoo-378bb3556692362ea71f268bfcc1131ad90d66da.tar.gz
gentoo-378bb3556692362ea71f268bfcc1131ad90d66da.tar.bz2
gentoo-378bb3556692362ea71f268bfcc1131ad90d66da.zip
net-analyzer/wireshark: Add more USE flags, update live ebuild.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/metadata.xml11
-rw-r--r--net-analyzer/wireshark/wireshark-2.4.0_rc2.ebuild20
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild21
3 files changed, 44 insertions, 8 deletions
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index 461d8656cff0..e88111bc335c 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -30,21 +30,32 @@
<use>
<flag name="adns">Use the GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
<flag name="androiddump">Install androiddump, an extcap interface to capture from Android devices</flag>
+ <flag name="capinfos">Install capinfos, to print information about capture files</flag>
+ <flag name="captype">Install captype, to print the file types of capture files</flag>
<flag name="ciscodump">Install ciscodump, extcap interface to capture from a remote Cisco router</flag>
<flag name="crypt">Use <pkg>dev-libs/libgcrypt</pkg> to decrypt traffic</flag>
+ <flag name="dftest">Install dftest, to display filter byte-code, for debugging dfilter routines</flag>
<flag name="doc-pdf">Build documentation in pdf format (US and a4 paper sizes)</flag>
+ <flag name="dumpcap">Install dumpcap, to dump network traffic from inside wireshark</flag>
+ <flag name="editcap">Install editcap, to edit and/or translate the format of capture files</flag>
<flag name="libssh">Use <pkg>net-libs/libssh</pkg> (for sshdump)</flag>
<flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for handling XML configuration in dissectors</flag>
+ <flag name="mergecap">Install mergecap, to merge two or more capture files into one</flag>
<flag name="netlink">Use <pkg>dev-libs/libnl</pkg></flag>
<flag name="nghttp2">Use <pkg>net-libs/nghttp2</pkg> for HTTP/2 support</flag>
<flag name="pcap">Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
<flag name="randpkt">Install randpkt, a utility for creating pcap trace files full of random packets</flag>
<flag name="randpktdump">Install randpktdump, an extcap interface to provide access to the random packet generator (randpkt)</flag>
+ <flag name="reordercap">Install reordercap, to reorder input file by timestamp into output file</flag>
<flag name="sbc">Use <pkg>media-libs/sbc</pkg> for playing back SBC encoded packets</flag>
+ <flag name="sharkd">Install sharkd, the daemon variant of wireshark</flag>
<flag name="smi">Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
<flag name="snappy">Use <pkg>app-arch/snappy</pkg> for snappy compression and decompression</flag>
<flag name="spandsp">Use <pkg>media-libs/spandsp</pkg> for for G.722 and G.726 codec support in the RTP Player</flag>
<flag name="sshdump">Install sshdump, an extcap interface to capture from a remote host through SSH</flag>
+ <flag name="text2pcap">Install text2pcap, to generate a capture file from an ASCII hexdump of packets</flag>
<flag name="tfshark">Install tfshark, a terminal-based version of the FileShark capability</flag>
+ <flag name="tshark">Install tshark, to dump and analyzer network traffic from the command line</flag>
+ <flag name="udpdump">Install udpdumpi, to get packets exported from a source (like a network device or a GSMTAP producer) that are dumped to a pcap file</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-2.4.0_rc2.ebuild b/net-analyzer/wireshark/wireshark-2.4.0_rc2.ebuild
index 69dc87248c68..566d8052d7e4 100644
--- a/net-analyzer/wireshark/wireshark-2.4.0_rc2.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.4.0_rc2.ebuild
@@ -12,10 +12,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="
- adns androiddump +caps ciscodump cpu_flags_x86_sse4_2 doc doc-pdf
- geoip gtk kerberos lua +netlink nghttp2 +pcap portaudio +qt5 sbc selinux
- smi libssh libxml2 randpkt randpktdump snappy spandsp sshdump ssl tfshark
- zlib
+ adns androiddump +capinfos +caps +captype ciscodump cpu_flags_x86_sse4_2
+ +dftest doc doc-pdf +dumpcap +editcap geoip gtk kerberos libssh libxml2 lua
+ +mergecap +netlink nghttp2 +pcap portaudio +qt5 +randpkt +randpktdump
+ +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl +text2pcap
+ tfshark +tshark +udpdump zlib
"
REQUIRED_USE="
ciscodump? ( libssh )
@@ -146,11 +147,22 @@ src_configure() {
econf \
$(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
$(use_enable androiddump) \
+ $(use_enable capinfos) \
+ $(use_enable captype) \
$(use_enable ciscodump) \
+ $(use_enable dftest) \
+ $(use_enable dumpcap) \
+ $(use_enable editcap) \
+ $(use_enable mergecap) \
$(use_enable randpkt) \
$(use_enable randpktdump) \
+ $(use_enable reordercap) \
+ $(use_enable sharkd) \
$(use_enable sshdump) \
+ $(use_enable text2pcap) \
$(use_enable tfshark) \
+ $(use_enable tshark) \
+ $(use_enable udpdump) \
$(use_with adns c-ares) \
$(use_with caps libcap) \
$(use_with geoip) \
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 68d8ab358157..7304f25144ed 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -12,10 +12,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="
- adns androiddump +caps ciscodump cpu_flags_x86_sse4_2 doc doc-pdf
- geoip gtk kerberos lua +netlink nghttp2 +pcap portaudio +qt5 sbc selinux
- smi libssh libxml2 randpkt randpktdump snappy spandsp sshdump ssl tfshark
- zlib
+ adns androiddump +capinfos +caps +captype ciscodump cpu_flags_x86_sse4_2
+ +dftest doc doc-pdf +dumpcap +editcap geoip gtk kerberos libssh libxml2 lua
+ +mergecap +netlink nghttp2 +pcap portaudio +qt5 +randpkt +randpktdump
+ +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl +text2pcap
+ tfshark +tshark +udpdump zlib
"
REQUIRED_USE="
ciscodump? ( libssh )
@@ -91,6 +92,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.99.8-qtchooser.patch
"${FILESDIR}"/${PN}-2.1.0-sse4_2-r1.patch
+ "${FILESDIR}"/${PN}-2.4-androiddump.patch
"${FILESDIR}"/${PN}-99999999-androiddump.patch
)
@@ -149,11 +151,22 @@ src_configure() {
econf \
$(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
$(use_enable androiddump) \
+ $(use_enable capinfos) \
+ $(use_enable captype) \
$(use_enable ciscodump) \
+ $(use_enable dftest) \
+ $(use_enable dumpcap) \
+ $(use_enable editcap) \
+ $(use_enable mergecap) \
$(use_enable randpkt) \
$(use_enable randpktdump) \
+ $(use_enable reordercap) \
+ $(use_enable sharkd) \
$(use_enable sshdump) \
+ $(use_enable text2pcap) \
$(use_enable tfshark) \
+ $(use_enable tshark) \
+ $(use_enable udpdump) \
$(use_with adns c-ares) \
$(use_with caps libcap) \
$(use_with geoip) \