summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-23 20:49:45 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-30 21:33:38 +0300
commit6af4fc3588e4b3bb3fde552a8d00d7f8884def97 (patch)
tree954f004c9b34cf154e7338b0d19a3897d0485590 /net-analyzer
parentnet-misc/iperf: add 3.17.1 (diff)
downloadgentoo-6af4fc3588e4b3bb3fde552a8d00d7f8884def97.tar.gz
gentoo-6af4fc3588e4b3bb3fde552a8d00d7f8884def97.tar.bz2
gentoo-6af4fc3588e4b3bb3fde552a8d00d7f8884def97.zip
net-analyzer/tcpreplay: add 4.5.1
Closes: https://bugs.gentoo.org/900040 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.5.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index 821f42c144ad..1d1f538bcb2a 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,2 +1,3 @@
DIST tcpreplay-4.4.3.tar.xz 750072 BLAKE2B 218fe1c5faab0fdd75a031afce8f468c85886a4cf21a4d9bd34089bd106756ee0e65e0df605efecb3260ccff266553a44d8ee10249b35524a044c6c5db86fcc7 SHA512 d8186a5faf3fbe5505da34cfc466c0375c4f298c997fe85505ea898c8c1241c16f98269596b682983a3e5cbd8493882334c925ff750d95995f3b13c5b83357cf
DIST tcpreplay-4.4.4.tar.xz 748344 BLAKE2B 05f586c9d68e1ee47fc5dfdbf14d866ccbd921a5734a52de4ba6c1f33f37628e510eddbf9059130c9858207690ec2c14dfbf3819f923436aa64fcc3fc2ce074d SHA512 a6907c98779c96b2acf53e2f13e832f2c9a7ee840acc40d23c7290c2ceefb5885d314453dec9463069218011bee86bb7df057966120aacd6cddda942821aea9b
+DIST tcpreplay-4.5.1.tar.xz 809628 BLAKE2B 38c61646b86ff9ed740372fe9e40d85beab4b8feda5c5281fb00e45ceca441192389611885f209931accf079aca43d3dee214e66fefc188e539836cff5097a10 SHA512 8cc5fda16077051d7f4cd078567eb35b8f4ad7d0e04542ae12ec10b86899c804d3d929c37f9f0325f19f3ed651e767d5a6fe140d42e04151591cee6c1337b8df
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.5.1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.5.1.ebuild
new file mode 100644
index 000000000000..4a2240e9cef4
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.5.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+IUSE="debug pcapnav +tcpdump"
+
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
+ >=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ elibc_musl? ( sys-libs/fts-standalone )
+ pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
+"
+RDEPEND="${DEPEND}"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ pathfind # sun/solaris only command, bug 900040
+)
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use elibc_musl && append-flags "-lfts"
+ # By default it uses static linking. Avoid that, bug #252940
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config)
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump)
+ --enable-dynamic-link
+ --enable-local-libopts
+ --enable-shared
+ --with-libdnet
+ --with-testnic2=lo
+ --with-testnic=lo
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]] ; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up."
+ die "self test failed - see ${S}/test/test.log"
+ }
+ fi
+}