summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-03 06:30:02 +0100
committerSam James <sam@gentoo.org>2023-04-03 06:30:02 +0100
commitb7ad8ff888194db07b1d8fdba6c91ef9b2337176 (patch)
treef50d1a778f62db40ee0c3a357793ba5b1598e897 /net-analyzer
parentapp-misc/tmate: add msgpack subslot dep, fix build w/ msgpack-6 (diff)
downloadgentoo-b7ad8ff888194db07b1d8fdba6c91ef9b2337176.tar.gz
gentoo-b7ad8ff888194db07b1d8fdba6c91ef9b2337176.tar.bz2
gentoo-b7ad8ff888194db07b1d8fdba6c91ef9b2337176.zip
net-analyzer/gvm-libs: fix build w/ misbehaving pcap-config
Closes: https://bugs.gentoo.org/829183 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gvm-libs/files/gvm-libs-21.4.4-pcap-config-whitespace.patch34
-rw-r--r--net-analyzer/gvm-libs/gvm-libs-21.4.4-r3.ebuild3
2 files changed, 36 insertions, 1 deletions
diff --git a/net-analyzer/gvm-libs/files/gvm-libs-21.4.4-pcap-config-whitespace.patch b/net-analyzer/gvm-libs/files/gvm-libs-21.4.4-pcap-config-whitespace.patch
new file mode 100644
index 000000000000..5569c713727b
--- /dev/null
+++ b/net-analyzer/gvm-libs/files/gvm-libs-21.4.4-pcap-config-whitespace.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/829183
+https://github.com/greenbone/gvm-libs/commit/de63a18fd2263b89bed70c00f7232939b0744002
+
+From de63a18fd2263b89bed70c00f7232939b0744002 Mon Sep 17 00:00:00 2001
+From: hubblexplorer <81538364+hubblexplorer@users.noreply.github.com>
+Date: Mon, 20 Feb 2023 06:11:00 +0000
+Subject: [PATCH] Fix: Resolve error on compile (#741)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* Resolve error on compile
+
+Fix for error " `pcap-config --libs` contains leading whitespace. "
+
+* Approved changes
+
+Co-authored-by: Juan José Nicola <jjnicola@gmail.com>
+
+---------
+
+Co-authored-by: Juan José Nicola <jjnicola@gmail.com>
+Co-authored-by: Juan José Nicola <juan.nicola@greenbone.net>
+--- a/boreas/CMakeLists.txt
++++ b/boreas/CMakeLists.txt
+@@ -62,6 +62,7 @@ if (PCAP_CONFIG)
+ execute_process (COMMAND pcap-config --libs
+ OUTPUT_VARIABLE PCAP_LDFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
++ string(STRIP "${PCAP_LDFLAGS}" PCAP_LDFLAGS)
+ execute_process (COMMAND pcap-config --cflags
+ OUTPUT_VARIABLE PCAP_CFLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
diff --git a/net-analyzer/gvm-libs/gvm-libs-21.4.4-r3.ebuild b/net-analyzer/gvm-libs/gvm-libs-21.4.4-r3.ebuild
index bb2129681464..9c945a9f6ea6 100644
--- a/net-analyzer/gvm-libs/gvm-libs-21.4.4-r3.ebuild
+++ b/net-analyzer/gvm-libs/gvm-libs-21.4.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -52,6 +52,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-20.8.1-disable-automagic-dep.patch
+ "${FILESDIR}"/${PN}-21.4.4-pcap-config-whitespace.patch
)
src_prepare() {