summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-03-06 16:09:55 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-03-07 17:56:17 -0800
commitc7971638d61c40c604f8db5d4d28fd973928efd0 (patch)
treeb06e4df5e3d47c7b28cadd7a8ad09fcffc3c798b /net-dns/hash-slinger
parentsys-cluster/nova: bup (diff)
downloadgentoo-c7971638d61c40c604f8db5d4d28fd973928efd0.tar.gz
gentoo-c7971638d61c40c604f8db5d4d28fd973928efd0.tar.bz2
gentoo-c7971638d61c40c604f8db5d4d28fd973928efd0.zip
net-dns/hash-slinger: bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-dns/hash-slinger')
-rw-r--r--net-dns/hash-slinger/Manifest1
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-dns/hash-slinger/Manifest b/net-dns/hash-slinger/Manifest
index 0b3d97f69bc1..84bef35003ca 100644
--- a/net-dns/hash-slinger/Manifest
+++ b/net-dns/hash-slinger/Manifest
@@ -1 +1,2 @@
DIST hash-slinger-2.6.tar.gz 34864 SHA256 121143efea136958ad6a42cb0a8fa80d95b1e4fc45632019d8f07a534d6efab2 SHA512 1e5d67ed2ef8eae910927fbd7419928d87ba31a91ca43a1c163b05f725da96a50d30e1539c4c55a68a22f0e2c9a2f7c7101fbdcfb5fc903e87fe4c22e20f33af WHIRLPOOL 7ff36bad9db31e6d8769a525fc60691cb6af3bd6970b9bbf55d56f7e3c08a6a97a35fd1363dbed012239432b7dfd2594d616dc4d0a80ae47c82b724e17183f41
+DIST hash-slinger-2.7.tar.gz 37684 SHA256 cd888eaee222bbe994d60aab7bc638b6c3417f43b68d0e6a8f1802104f6d7b8d SHA512 b1b3e46c4cdd8b983b55156c9bcc58afc973c2503cde48283e98306e381753547f425bfaee68707ae10b2e31b71d01485b34e4a9841c9ce2048f9551f23d0976 WHIRLPOOL 91e232827c63a1c2ab92e691ce71c4d301b1dc34d410e583b53e58e83a1f77a712cd76627c15f812849b06689258b60305792adcbb779d544bd4f574010f9190
diff --git a/net-dns/hash-slinger/hash-slinger-2.7.ebuild b/net-dns/hash-slinger/hash-slinger-2.7.ebuild
new file mode 100644
index 000000000000..f2c2d28fedf5
--- /dev/null
+++ b/net-dns/hash-slinger/hash-slinger-2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
+HOMEPAGE="https://people.redhat.com/pwouters/hash-slinger/"
+SRC_URI="https://people.redhat.com/pwouters/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipsec +openpgp +ssh"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/ipaddr[$PYTHON_USEDEP]
+ dev-python/m2crypto[$PYTHON_USEDEP]
+ net-dns/unbound[python,$PYTHON_USEDEP]
+ virtual/python-dnspython[$PYTHON_USEDEP]
+ ipsec? ( net-misc/libreswan[dnssec] )
+ openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
+ ssh? ( net-misc/openssh )
+"
+
+src_install() {
+ local tools
+ tools="tlsa"
+ use ssh && tools+=" sshfp"
+ use openpgp && tools+=" openpgpkey"
+ use ipsec && tools+=" ipseckey"
+ for tool in $tools ; do
+ doman ${tool}.1
+ python_foreach_impl python_doscript ${tool}
+ done
+ dodoc BUGS CHANGES README
+}