summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-09 09:53:12 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-17 11:18:33 +0200
commit19e71b2bf9b030645e194a2cb274ca3337607768 (patch)
tree272447bbe1938b43f367558ddb56e7f594d849ce /net-dns/https_dns_proxy
parentnet-im/zoom: Remove old. (diff)
downloadgentoo-19e71b2bf9b030645e194a2cb274ca3337607768.tar.gz
gentoo-19e71b2bf9b030645e194a2cb274ca3337607768.tar.bz2
gentoo-19e71b2bf9b030645e194a2cb274ca3337607768.zip
net-dns/https_dns_proxy: update live ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns/https_dns_proxy')
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
index 4952e64d90ee..3c26883fb122 100644
--- a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -1,27 +1,31 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit git-r3 cmake-utils
+EAPI=7
+inherit cmake
-DESCRIPTION="A lightweight DNS-over-HTTPS proxy."
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/aarond10/https_dns_proxy.git"
+ inherit git-r3
+else
+ MY_COMMIT="2d9285e2b94bce21c588c8160f8fac660806987a"
+ SRC_URI="https://github.com/aarond10/https_dns_proxy/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+fi
+
+DESCRIPTION="A lightweight DNS-over-HTTPS proxy"
HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
-EGIT_REPO_URI="https://github.com/aarond10/${PN}.git"
-SRC_URI=""
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
DEPEND="dev-libs/libev
net-dns/c-ares
- >=net-misc/curl-7.53.0[http2,ssl]
- "
+ net-misc/curl[http2,ssl]"
RDEPEND="${DEPEND}"
src_install() {
- cmake-utils_src_install
- exeinto /usr/bin
- doexe "${S}_build/https_dns_proxy"
+ cmake_src_install
+ dobin "${S}_build/https_dns_proxy"
}