summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-12-18 11:11:22 +0100
committerSam James <sam@gentoo.org>2020-12-29 20:49:44 +0000
commit2d7d43dc3221dbca1f58cb84570043522a4b5702 (patch)
tree6893e0ac31522704036c66e7bc408dc2546e1d69 /net-dns/knot
parentsys-apps/ipmitool: security cleanup (drop <1.8.18_p20201004-r1) (diff)
downloadgentoo-2d7d43dc3221dbca1f58cb84570043522a4b5702.tar.gz
gentoo-2d7d43dc3221dbca1f58cb84570043522a4b5702.tar.bz2
gentoo-2d7d43dc3221dbca1f58cb84570043522a4b5702.zip
net-dns/knot: bump to 2.9.8 and 3.0.3
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/18703 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/Manifest2
-rw-r--r--net-dns/knot/knot-2.9.8.ebuild102
-rw-r--r--net-dns/knot/knot-3.0.3.ebuild102
3 files changed, 206 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index b0d293950bdd..aed7ed61e7b2 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,2 +1,4 @@
DIST knot-2.9.7.tar.xz 1188904 BLAKE2B f20355f211db316a1e39321a1200130e2af4e895eff92eca36c93d5b8f78fcd9dd8fa1ec25edf7a0fa9bae4aa2a92b2fca890be1da4134b894792235de0b546e SHA512 399b48491c000aa3f16b87b1e313f2ea5fe369d19da0c81222ed43ca155bf4d4d1a561ef84bc08844eaf24d3dd07ded9a6ec3d831dd5f6ffb174ae773ae12931
+DIST knot-2.9.8.tar.xz 1194284 BLAKE2B c4329e5b2fc499851112d008af10c1a73bbe50cd07a4b5af984e99f389606b6f11c0b321dc26c14f872eb7cc70a99290a033f9aa9ff23a2b3694427605ffc704 SHA512 8104c3bdef2db4a79d6cd0fa4a30be1aa6edfa01363b97738d873445198cd031b4f5ab581d1a5277de49a8a042bb5340334be0579ceefa4b614e34c2cd454904
DIST knot-3.0.2.tar.xz 1313864 BLAKE2B f2ff8c75a9b239b924af2eecc5e5afed27030fc9be6e112a4f61479f40247396c1d2905f58329fa84907c6ce796bc9a56d6f8e1cc83b737e15713844e0add32f SHA512 677de7a80688d4820d56c020af1bb1da97546f44a616e2d72d7e0301fca4a7ab682994cf66e8c37403e65ddb45ea3e0eb37b3304739c1239364115588c589699
+DIST knot-3.0.3.tar.xz 1322748 BLAKE2B a0b9a99b66d1f02d0e631226c328376d2ca780b19522040525a7a4e9ec24bd22e0f0094ee98a01a75695727619b60b28d72484b3da4f5c92b63c368665aa637a SHA512 4a4de22f8324d8459a7012faa49fb1503ad3b2f23af434a82381a73bf3f43a66f096bba7b0dfc8a61f416d9e02ce97c449ed1590a8a899279ac793798423c339
diff --git a/net-dns/knot/knot-2.9.8.ebuild b/net-dns/knot/knot-2.9.8.ebuild
new file mode 100644
index 000000000000..2cc9e9753dfc
--- /dev/null
+++ b/net-dns/knot/knot-2.9.8.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/net-dns/knot/knot-3.0.3.ebuild b/net-dns/knot/knot-3.0.3.ebuild
new file mode 100644
index 000000000000..2cc9e9753dfc
--- /dev/null
+++ b/net-dns/knot/knot-3.0.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}