summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-07-27 21:37:32 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-17 19:17:53 +0300
commit5b43506ed9b31d9388b82b16375fa381f21aabde (patch)
tree0c34a7b4579e65bdea7ec79bde9703dad1af751d /net-dns/maradns
parentdev-lisp/c2ffi: add a missing dep for llvm (diff)
downloadgentoo-5b43506ed9b31d9388b82b16375fa381f21aabde.tar.gz
gentoo-5b43506ed9b31d9388b82b16375fa381f21aabde.tar.bz2
gentoo-5b43506ed9b31d9388b82b16375fa381f21aabde.zip
net-dns/maradns: bump version to 3.5.0022
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/26626 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns/maradns')
-rw-r--r--net-dns/maradns/Manifest1
-rw-r--r--net-dns/maradns/files/maradns-3.5.0022-flags.patch65
-rw-r--r--net-dns/maradns/maradns-3.5.0022.ebuild96
3 files changed, 162 insertions, 0 deletions
diff --git a/net-dns/maradns/Manifest b/net-dns/maradns/Manifest
index 0483ddcd84fc..5cfeb8c3d3e1 100644
--- a/net-dns/maradns/Manifest
+++ b/net-dns/maradns/Manifest
@@ -1,2 +1,3 @@
DIST maradns-3.5.0005.tar.xz 5351412 BLAKE2B c6b1c4fb93cb507045b3c09574d7ce30b0af92301e157216b4a5bbd2ed74ceb829ef4d11cd08048c7a685a09cdd4178cf3fc4e7b2465820d26d3a5c1b96f4a5e SHA512 2e7008ff6217929008292dde60d96eb2ec0499a170e1b5bda5fcfb27300d2ce6cecd8b3e2a2d4b09ff32b803f9f435230378e6b2e41e7b63c42653d8c931151d
DIST maradns-3.5.0020.tar.xz 7154452 BLAKE2B 4d193c06620332b90f4a004e787f9cbe61cd48adcee1dd667ecf0383c0fb81f5b7cae40ee953f077b2ccf060d7429863f741cf942c34c862d6c56092bc40600b SHA512 3478ccdc82d5be45826072f91c1b00c491f21f69bcce169cfeb3dfdd00e0012a9def884d711daa41ea18dce52e069dbb4c31e1e37ecda418565b5d8d6a0ea4d4
+DIST maradns-3.5.0022.tar.xz 7375408 BLAKE2B d79fd800099f41e6395537b8a9d945820cd295c9a3be8bec0850b8c85df65a607b07c3a0949a6ed058d1155514836d5a72a3ab0512a4369a979b021c80159908 SHA512 0c4df5aac0a979a74f811c9ccd30e2708f6b21816d9d70b88bf31ac4a65175b46c3a53adf439e098c57aa9b79250c26a38c8cdf26e0ee52637092a184d852076
diff --git a/net-dns/maradns/files/maradns-3.5.0022-flags.patch b/net-dns/maradns/files/maradns-3.5.0022-flags.patch
new file mode 100644
index 000000000000..9f6b81addfca
--- /dev/null
+++ b/net-dns/maradns/files/maradns-3.5.0022-flags.patch
@@ -0,0 +1,65 @@
+From 15470045421448a7a6813e2a4a96e18bba3b0aa4 Mon Sep 17 00:00:00 2001
+From: Victor Kustov <ktrace@yandex.ru>
+Date: Wed, 27 Jul 2022 21:28:31 +0300
+Subject: [PATCH] 2nd
+
+---
+ build/Makefile.linux | 32 ++++++++++++++++----------------
+ 1 file changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/build/Makefile.linux b/build/Makefile.linux
+index 965c7fb..572dccc 100644
+--- a/build/Makefile.linux
++++ b/build/Makefile.linux
+@@ -24,32 +24,32 @@ EXECS=server/maradns
+ # end the Solaris section
+ # Non-Solaris version of "M"
+ V="VERSION=$(VERSION)"
+-Q="DEFINES=-DSELECT_PROBLEM"
++Q="$(LDFLAGS) DEFINES=-DSELECT_PROBLEM"
+
+ # Debug
+
+ FLAGS = -O2 -Wall -DSELECT_PROBLEM
+-M="CC=$(CC) $(FLAGS)"
+-D="CC=$(CC) $(FLAGS) -DDEBUG -DTHREADS"
++M="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)"
++D="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DDEBUG -DTHREADS"
+ #FLAGS = -g
+
+ all:
+- cd libs ; make $(M) ; cd ../dns ; make $(M) ; \
+- cd ../rng ; make $(M) ; cd ../parse ; make $(M) ; \
+- cd ../qual ; make $(M) ; cd ../server ; \
+- make $(M) $(V) COMPILED=\"$(COMPILED)\" ; \
+- cd ../tools ; make $(M) ; \
+- cd ../deadwood-*/src/ ; make FLAGS=-O2 ; \
+- cd ../../tcp ; make $(M) $(V) ; cat ../00README.FIRST
++ cd libs ; $(MAKE) $(M) ; cd ../dns ; $(MAKE) $(M) ; \
++ cd ../rng ; $(MAKE) $(M) ; cd ../parse ; $(MAKE) $(M) ; \
++ cd ../qual ; $(MAKE) $(M) ; cd ../server ; \
++ $(MAKE) $(M) $(V) COMPILED=\"$(COMPILED)\" ; \
++ cd ../tools ; $(MAKE) $(M) ; \
++ cd ../deadwood-*/src/ ; $(MAKE) FLAGS=-O2 ; \
++ cd ../../tcp ; $(MAKE) $(M) $(V) ; cat ../00README.FIRST
+
+ debug:
+- cd libs ; make $(D) DEBUG="-DDEBUG -DTHREADS" ; \
+- cd ../dns ; make $(D) ; cd ../rng ; make $(D) ; \
+- cd ../parse ; make $(D) ; cd ../qual ; make $(D) ; \
++ cd libs ; $(MAKE) $(D) DEBUG="-DDEBUG -DTHREADS" ; \
++ cd ../dns ; $(MAKE) $(D) ; cd ../rng ; $(MAKE) $(D) ; \
++ cd ../parse ; $(MAKE) $(D) ; cd ../qual ; $(MAKE) $(D) ; \
+ cd ../server ; \
+- make $(D) $(Q) $(V) COMPILED=\"$(COMPILED_DEBUG)\" ; \
+- cd ../tools ; make $(D) ; \
+- cd ../tcp ; make $(D) $(V) ; cat ../00README.FIRST
++ $(MAKE) $(D) $(Q) $(V) COMPILED=\"$(COMPILED_DEBUG)\" ; \
++ cd ../tools ; $(MAKE) $(D) ; \
++ cd ../tcp ; $(MAKE) $(D) $(V) ; cat ../00README.FIRST
+
+ clean:
+ rm -f $(OBJECTS) core $(EXECS) ; \
+--
+2.35.1
+
diff --git a/net-dns/maradns/maradns-3.5.0022.ebuild b/net-dns/maradns/maradns-3.5.0022.ebuild
new file mode 100644
index 000000000000..d956f23b3b13
--- /dev/null
+++ b/net-dns/maradns/maradns-3.5.0022.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="A security-aware DNS server"
+HOMEPAGE="https://maradns.samiam.org"
+SRC_URI="https://maradns.samiam.org/download/${PV%.*}/${PV}/${P}.tar.xz"
+
+# The GPL-2 covers the init script, bug 426018.
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="examples ipv6"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl"
+DEPEND="
+ acct-group/maradns
+ acct-user/duende
+ acct-user/maradns"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+)
+
+src_prepare() {
+ default
+ python_fix_shebang tools/bind2csv2.py
+}
+
+src_configure() {
+ tc-export CC
+ ./configure \
+ $(usex ipv6 --ipv6 "") || die "Failed to configure"
+}
+
+src_install() {
+ # Install the MaraDNS and Deadwood binaries
+ dosbin server/maradns
+ dosbin tcp/zoneserver
+ dosbin deadwood-${PV}/src/Deadwood
+ dobin tcp/{getzone,fetchzone}
+ dobin tools/{askmara,askmara-tcp,duende,bind2csv2.py,csv1tocsv2.pl}
+
+ # MaraDNS docs, manpages, misc
+ docompress -x /usr/share/doc/${PF}/maradns.gpg.key
+ dodoc {CHANGELOG.TXT,COPYING,SUPPORT,maradns.gpg.key}
+ dodoc doc/en/{QuickStart,faq.*,*.md,README}
+ dodoc -r doc/en/{text,webpage,tutorial}
+ docinto deadwood
+ dodoc deadwood-${PV}/doc/{*.txt,*.html,CHANGELOG,Deadwood-HOWTO}
+ dodoc -r deadwood-${PV}/doc/internals
+
+ # Install examples (optional)
+ if use examples ; then
+ docinto examples
+ dodoc doc/en/examples/example_*
+ fi
+
+ # Install manpages
+ doman doc/en/man/*.[1-9]
+ doman deadwood-${PV}/doc/{Deadwood,Duende}.1
+
+ # Example configurations.
+ insinto /etc/maradns
+ newins doc/en/examples/example_full_mararc mararc_full.dist
+ newins doc/en/examples/example_csv2 example_csv2.dist
+ newins deadwood-${PV}/doc/dwood3rc-all dwood3rc_all.dist
+ keepdir /etc/maradns/logger
+
+ # Init scripts.
+ newinitd "${FILESDIR}"/maradns2 maradns
+ newinitd "${FILESDIR}"/zoneserver2 zoneserver
+ newinitd "${FILESDIR}"/deadwood deadwood
+
+ # systemd unit
+ # please keep paths in sync!
+ sed -e "s^@bindir@^${EPREFIX}/usr/sbin^" \
+ -e "s^@sysconfdir@^${EPREFIX}/etc/maradns^" \
+ "${FILESDIR}"/maradns.service.in > "${T}"/maradns.service \
+ || die "failed to create the maradns.service file (sed)"
+
+ systemd_dounit "${T}"/maradns.service
+}
+
+pkg_postinst() {
+ elog "Examples of configuration files can be found in the"
+ elog "/etc/maradns directory, feel free use it like:"
+ elog " cp /etc/maradns/mararc{_full.dist,}"
+ elog "and edit /etc/maradns/mararc as described in man mararc."
+}