summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/odsclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/odsclient')
-rw-r--r--net-dns/odsclient/Manifest1
-rw-r--r--net-dns/odsclient/files/1.03-gentoo.patch21
-rw-r--r--net-dns/odsclient/metadata.xml7
-rw-r--r--net-dns/odsclient/odsclient-1.03-r1.ebuild35
4 files changed, 64 insertions, 0 deletions
diff --git a/net-dns/odsclient/Manifest b/net-dns/odsclient/Manifest
new file mode 100644
index 000000000000..affdf3fb054c
--- /dev/null
+++ b/net-dns/odsclient/Manifest
@@ -0,0 +1 @@
+DIST odsclient-1.03.tar.gz 4263 SHA256 4c55c88e2aebce736f2a85fb750da0292d047bfc3bd7a042535cbd9545ecc384 SHA512 12cc8b734314ec23432fc7ca980e099eee04be84134740460b7ab3edcff1abfb116794504653ef0af72b27fdc2b074633b96196e1894092152e1bd0e8300ab11 WHIRLPOOL 8d924616fa70bb90c227b9c67ef93bb5712f97d821023a9aeac96cd2fd7347c2dfab050c75a9450317c4662e52eaf6b4364e29e5686ca6f80e49e0565f8b5d0b
diff --git a/net-dns/odsclient/files/1.03-gentoo.patch b/net-dns/odsclient/files/1.03-gentoo.patch
new file mode 100644
index 000000000000..76f93016a010
--- /dev/null
+++ b/net-dns/odsclient/files/1.03-gentoo.patch
@@ -0,0 +1,21 @@
+--- a/client.c
++++ b/client.c
+@@ -40,7 +40,8 @@
+ ret = getret(s);
+ if(ret == 795 || ret == 796)
+ {
+- fprintf(stderr, "Updated successfully\n");
++ fprintf(stderr, "Updated %s to %s successfully\n",
++ argv[3], ipaddress);
+ mydprintf(s, "QUIT\n");
+ close(s);
+ exit(0);
+@@ -50,7 +51,7 @@
+
+ }
+ }
+- fprintf(stderr, "Unable to update host\n");
++ fprintf(stderr, "Unable to update %s\n", argv[3]);
+ return 1;
+ }
+
diff --git a/net-dns/odsclient/metadata.xml b/net-dns/odsclient/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-dns/odsclient/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-dns/odsclient/odsclient-1.03-r1.ebuild b/net-dns/odsclient/odsclient-1.03-r1.ebuild
new file mode 100644
index 000000000000..b0d0f82c4ec8
--- /dev/null
+++ b/net-dns/odsclient/odsclient-1.03-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Client for the Open Domain Server's dynamic dns"
+HOMEPAGE="http://www.ods.org/"
+SRC_URI="http://www.ods.org/dl/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ sed -i Makefile -e 's| -o | $(LDFLAGS)&|g' || die "sed failed"
+
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dosbin odsclient
+ dodoc README
+}