summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-08 02:40:49 +0100
committerSam James <sam@gentoo.org>2023-10-08 02:40:49 +0100
commit32574ca6ce908f6884a3c7ed38c72331760e2bea (patch)
tree114345da77719301fe15b3b3b25f6df7bfa90e97 /net-dns
parentwww-servers/lighttpd: add github upstream metadata for lighttpd2 as well (diff)
downloadgentoo-32574ca6ce908f6884a3c7ed38c72331760e2bea.tar.gz
gentoo-32574ca6ce908f6884a3c7ed38c72331760e2bea.tar.bz2
gentoo-32574ca6ce908f6884a3c7ed38c72331760e2bea.zip
net-dns/c-ares: add 1.20.0
Closes: https://bugs.gentoo.org/900050 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.20.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index e3083da3527e..e20e7a20e81d 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -1,2 +1,4 @@
DIST c-ares-1.19.1.tar.gz 1579100 BLAKE2B 4b6c9593edb1a91ab76d54ddacb1cd5d67006d5e628ea1f3289f54e9360be32abeb5d8fc7d23e193feab3e7928e8efde82757eb12fe217dc92ed0d9132bedf5d SHA512 466a94efda626e815a6ef7a890637056339f883d549ea6055e289fd8cd2391130e5682c905c0fb3bd7e955af7f6deb793562c170eb0ee066a4a62085a82ba470
DIST c-ares-1.19.1.tar.gz.asc 488 BLAKE2B 9c47d7b3e67d9a2bd1e332912d21d20ca591fc34f81707c18a4615ea14ba2da00146d1998250a5f4dd2a0b1c04f9bd2013d4940ac734674c0bdff6815985e19d SHA512 1b204ab1a667af1326be4b7c62c0919aacd447a2e00efea4b8ef2ec9f2b13ffb236a836ff8953b0b3359727faf3fb8cfcd71d0b06a0e533a09f9e9ea66024f4e
+DIST c-ares-1.20.0.tar.gz 1599257 BLAKE2B 7be14be28fac55857dd09dcd63624c87eea883181ea11bc6623fb091a2ab60bd940ff285d9f6e58c7f936b52af61ac5e1c4150e090feae09edf7e411c869b6c5 SHA512 3f7e9c857e91bb35052b335f0e7348cbe336ce458c913803dac0f26c5e1386eff83cbd987160db3a23c0227c479b74706ce6864b322b9a3396039a2093ae33b1
+DIST c-ares-1.20.0.tar.gz.asc 488 BLAKE2B e02bca0b43774bd2dfac5216f822e30dce2463858298921f2e6c0d189b421861a2072664b00a6e5f39912d641387913d5923e98761005a23a0994fd61a47c709 SHA512 096e994b9045dc23f2dee32bdac6159d88f4d783d7ca21d1c8f58ece5a898ae3720616261d3aa67a045730afa938916676231b3956d3e885902bc96dd778b2b8
diff --git a/net-dns/c-ares/c-ares-1.20.0.ebuild b/net-dns/c-ares/c-ares-1.20.0.ebuild
new file mode 100644
index 000000000000..e0e327e77943
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.20.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
+inherit edo multilib-minimal verify-sig
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.org/"
+SRC_URI="
+ https://c-ares.org/download/${P}.tar.gz
+ verify-sig? ( https://c-ares.org/download/${P}.tar.gz.asc )
+"
+
+LICENSE="MIT"
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-danielstenberg )"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Checking for obsolete headers
+ malloc
+ calloc
+ free
+
+ # Non-existent on Linux
+ closesocket
+ CloseSocket
+ ioctlsocket
+ bitncmp
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-nonblocking
+ --enable-symbol-hiding
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ export ax_cv_uts_namespace=no
+ export ax_cv_user_namespace=no
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ *VerifySocketFunctionCallback*
+ # Seems flaky, even run manually?
+ *MockUDPMaxQueriesTest.GetHostByNameParallelLookups*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ edo ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}"))
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}