summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/corebird
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/corebird')
-rw-r--r--net-im/corebird/Manifest2
-rw-r--r--net-im/corebird/corebird-0.8.ebuild48
-rw-r--r--net-im/corebird/corebird-1.0.ebuild50
-rw-r--r--net-im/corebird/metadata.xml22
4 files changed, 122 insertions, 0 deletions
diff --git a/net-im/corebird/Manifest b/net-im/corebird/Manifest
new file mode 100644
index 000000000000..f4ffd33643b3
--- /dev/null
+++ b/net-im/corebird/Manifest
@@ -0,0 +1,2 @@
+DIST corebird-0.8.tar.gz 1655839 SHA256 4e68e174edc40b49d70a11c1b0a1b196ca9517daa8eae6ce2da3e8004acda611 SHA512 308bc0ade8ddda0b0be0949e5199bf6ac1b3658bf6e181821a205a602b2a22a97e77583cd5ca63ba272926810095104ae4117e54ccda10234d143c3377b9384d WHIRLPOOL 2e014590c0d9222a6a53d78d855ff9017fa9b3c68c2c354bc2acad1b028bd6253fa9510fbc5ce391bc65319829e14c5447b4be4cbcc8427faace790767e6d98c
+DIST corebird-1.0.tar.gz 1697452 SHA256 0ca4ca20b0281b2901382810ef8bd1682bb896c3915ad3bea3f2a41461118001 SHA512 098dd764a3aecaeda90ad5b0e24a4bf172025ce1a4105b713a1a73385d1de9cca028d7a34a39e9682ad4e2b2b22d4bf2889668c587e363cdfa6053136b1f4c39 WHIRLPOOL e033988b94632ad6b8d4e8c79a6125311466e81d746dd434801451f71e4590558b1797e8690ff033c1c04aeb4a299191993421a64e9d3a925409cda663478ab8
diff --git a/net-im/corebird/corebird-0.8.ebuild b/net-im/corebird/corebird-0.8.ebuild
new file mode 100644
index 000000000000..1bc2a1426145
--- /dev/null
+++ b/net-im/corebird/corebird-0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VALA_MIN_API_VERSION=0.24
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit eutils autotools-utils gnome2 vala
+
+DESCRIPTION="Native GTK+3 Twitter client"
+HOMEPAGE="http://corebird.baedert.org/"
+SRC_URI="https://github.com/baedert/corebird/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug glade gstreamer"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.40:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0[X,ffmpeg] )
+ >=net-libs/libsoup-2.42.3.1
+ >=net-libs/rest-0.7.91:0.7
+ >=x11-libs/gtk+-3.12:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ sys-apps/sed
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e "/manpagedir/s/manpagedir.*/&\/man1/g" data/Makefile.am || die
+ autotools-utils_src_prepare
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable glade catalog)
+ $(usex gstreamer "" --disable-video)
+ )
+ gnome2_src_configure "${myeconfargs[@]}"
+}
diff --git a/net-im/corebird/corebird-1.0.ebuild b/net-im/corebird/corebird-1.0.ebuild
new file mode 100644
index 000000000000..bbd83bf58908
--- /dev/null
+++ b/net-im/corebird/corebird-1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+VALA_MIN_API_VERSION=0.26
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit eutils autotools-utils gnome2 vala
+
+DESCRIPTION="Native GTK+3 Twitter client"
+HOMEPAGE="http://corebird.baedert.org/"
+SRC_URI="https://github.com/baedert/corebird/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gstreamer"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.40:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0[X,ffmpeg] )
+ >=net-libs/libsoup-2.42.3.1
+ >=net-libs/rest-0.7.91:0.7
+ >=x11-libs/gtk+-3.14:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/intltool-0.40
+ sys-apps/sed
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "/manpagedir/s/manpagedir.*/&\/man1/g" data/Makefile.am || die
+ autotools-utils_src_prepare
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(usex gstreamer "" --disable-video)
+ )
+ gnome2_src_configure "${myeconfargs[@]}"
+}
diff --git a/net-im/corebird/metadata.xml b/net-im/corebird/metadata.xml
new file mode 100644
index 000000000000..14d619e0d0f4
--- /dev/null
+++ b/net-im/corebird/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>thatslyude@gmail.com</email>
+ <name>Chandler Paul</name>
+ <description>Maintainer, Assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>markpariente@gmail.com</email>
+ <name>Mark R. Pariente</name>
+ <description>Maintainer, Assign bugs</description>
+ </maintainer>
+ <use>
+ <flag name="glade">Install glade catalogs for corebird</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">baedert/corebird</remote-id>
+ </upstream>
+</pkgmetadata>