summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-03-04 20:01:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-03-04 20:02:59 +0000
commite651546dc4872e416734014463215f663cb9308b (patch)
treeb07abb1fccf248b857d184b5d818acf79fd57b34 /net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild
parentnet-misc/openssh: Re-order maintainers (diff)
downloadgentoo-e651546dc4872e416734014463215f663cb9308b.tar.gz
gentoo-e651546dc4872e416734014463215f663cb9308b.tar.bz2
gentoo-e651546dc4872e416734014463215f663cb9308b.zip
net-im/skypetab-ng: pushed new snapshot, 0.5.2_p20150201
Reported-by: Gleb Bug: https://bugs.gentoo.org/576310 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild')
-rw-r--r--net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild b/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild
new file mode 100644
index 000000000000..86b11c4b2c0c
--- /dev/null
+++ b/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/kekekeks/skypetab-ng.git"
+ UNPACKER_ECLASS="git-2"
+ LIVE_EBUILD=yes
+else
+ UNPACKER_ECLASS="vcs-snapshot"
+fi
+
+inherit eutils qt4-r2 multilib ${UNPACKER_ECLASS}
+
+if [[ -z ${LIVE_EBUILD} ]]; then
+ KEYWORDS="-* ~x86 ~amd64"
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.bz2"
+fi
+
+DESCRIPTION="An LD_PRELOAD wrapper that adds tabs to Skype for Linux"
+HOMEPAGE="https://github.com/kekekeks/skypetab-ng"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[abi_x86_32(-)]
+"
+RDEPEND="${DEPEND}
+ || ( >=net-im/skype-4.1 <net-im/skype-4.1[-qt-static] )
+"
+
+pkg_setup() {
+ use amd64 && multilib_toolchain_setup x86
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-isdigit.patch
+}