summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-11-14 11:39:31 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-11-14 11:39:48 +0100
commitcd5e44659945d2495c8a50c174148f82bd4d7ca5 (patch)
treeae04b6812a966af2b99bf5ed59388ee78d836fe0 /net-im
parentwww-client/opera-developer: remove old (diff)
downloadgentoo-cd5e44659945d2495c8a50c174148f82bd4d7ca5.tar.gz
gentoo-cd5e44659945d2495c8a50c174148f82bd4d7ca5.tar.bz2
gentoo-cd5e44659945d2495c8a50c174148f82bd4d7ca5.zip
net-im/sendxmpp-amm: initial import
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/sendxmpp-amm/Manifest1
-rw-r--r--net-im/sendxmpp-amm/metadata.xml8
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-1.1.0.ebuild35
-rw-r--r--net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild35
4 files changed, 79 insertions, 0 deletions
diff --git a/net-im/sendxmpp-amm/Manifest b/net-im/sendxmpp-amm/Manifest
new file mode 100644
index 000000000000..3320bed7e3f4
--- /dev/null
+++ b/net-im/sendxmpp-amm/Manifest
@@ -0,0 +1 @@
+DIST sendxmpp-amm-1.1.0.tar.gz 14059 BLAKE2B 5070c8a8561a16a5fd87777aafe850597afdacba9def1a471ee37d3cd055e27666b3791dcf72c1d6358d9b91360caf1e6b60eea970ab576cb004e93c707a7bce SHA512 cc98e6b9858e51c3898bdd026ac9422c014b77aebb253b3ac216be710f07cbf6d5968ef38395acabf7650e9e13c8c06cc84f5ee1e7c5dbc6813ee09a9cd54cd2
diff --git a/net-im/sendxmpp-amm/metadata.xml b/net-im/sendxmpp-amm/metadata.xml
new file mode 100644
index 000000000000..87a759d410cf
--- /dev/null
+++ b/net-im/sendxmpp-amm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-1.1.0.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.0.ebuild
new file mode 100644
index 000000000000..700d92138fdb
--- /dev/null
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ORIG_PN="${PN%-amm}"
+
+DESCRIPTION="Send XMPP (Jabber) messages via command line"
+HOMEPAGE="https://github.com/flowdalic/sendxmpp"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/Flowdalic/${ORIG_PN}.git"
+ inherit git-r3
+ if [[ "${PV}" == "9999" ]]; then
+ MY_KEYWORDS=""
+ fi
+else
+ SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${ORIG_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+RDEPEND="
+ dev-lang/ammonite-repl-bin
+ !net-im/sendxmpp
+"
+
+src_install() {
+ default
+ dobin sendxmpp
+}
diff --git a/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
new file mode 100644
index 000000000000..700d92138fdb
--- /dev/null
+++ b/net-im/sendxmpp-amm/sendxmpp-amm-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ORIG_PN="${PN%-amm}"
+
+DESCRIPTION="Send XMPP (Jabber) messages via command line"
+HOMEPAGE="https://github.com/flowdalic/sendxmpp"
+
+if [[ "${PV}" == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ EGIT_REPO_URI="https://github.com/Flowdalic/${ORIG_PN}.git"
+ inherit git-r3
+ if [[ "${PV}" == "9999" ]]; then
+ MY_KEYWORDS=""
+ fi
+else
+ SRC_URI="https://github.com/flowdalic/${ORIG_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${ORIG_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+
+SLOT="0"
+
+RDEPEND="
+ dev-lang/ammonite-repl-bin
+ !net-im/sendxmpp
+"
+
+src_install() {
+ default
+ dobin sendxmpp
+}