summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2021-12-29 11:01:51 -0500
committerSam James <sam@gentoo.org>2022-01-07 05:06:19 +0000
commitdc58609e3079ec90ef2a2dbbfc96fbfae8f0237e (patch)
tree3ff508a9e32401de813e1b0577d241710ba57c03 /net-im
parentnet-im/toxic: Removed old version 0.8.3 (diff)
downloadgentoo-dc58609e3079ec90ef2a2dbbfc96fbfae8f0237e.tar.gz
gentoo-dc58609e3079ec90ef2a2dbbfc96fbfae8f0237e.tar.bz2
gentoo-dc58609e3079ec90ef2a2dbbfc96fbfae8f0237e.zip
net-im/toxic: Bump to version 0.11.3
Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/23460 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch39
-rw-r--r--net-im/toxic/toxic-0.11.3.ebuild115
3 files changed, 155 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 4247de967283..cec989e95f38 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1,2 +1,3 @@
DIST toxic-0.10.1.tar.gz 1165118 BLAKE2B d367039bef9c97c23c8e5453b607cf72f70776e8c86c41da0480eb04725a901bf33bb89727aee3010ad97d33ef2aa653ff09ea49b597cdf2008ff976c395065c SHA512 aec2e6612d639e0210ae68db3368b656647575e3d927444d0726422ff2cf9718dd5a8b3f37a8253cdc3714f09f9f96828dfccf7a7ae12f8a41ce3207f92a684d
DIST toxic-0.11.1.tar.gz 1204163 BLAKE2B 1e388982236badf1a27cb1cfd9e84ec635be6a576a0719a7394f32ac82f23796f94236ab807180620cbfa8c0c42f43ff244d2d99d27cd5ab3258c1ce69acc545 SHA512 53fba05271020547e779d63bea777f90f56b61e3eb2775afabe92e047a8347b4a9166628bb59d2eaab2e36a1121d791206ac68ff6604cb06fac6aaddbb05e787
+DIST toxic-0.11.3.tar.gz 1197252 BLAKE2B 4a7a3c4eed270330c6d79ad400778debda1b98b66beed1196cf4e36858d300141c468c4963d012b77d8232f7b3b3b419138505e46098bfac3cde48e9bc0b0e1c SHA512 2c8408004d9644b52cbe9477d7c486622fcef52f1d10a1bcdf7555656a2f2e1bd4c6f0594a7b0b3156fd6908c470c5b41c55e6e0914c3eb2067614013f0f259f
diff --git a/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch b/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch
new file mode 100644
index 000000000000..2101b64e3d9f
--- /dev/null
+++ b/net-im/toxic/files/toxic-0.11.3-NAME_MAX-and-PATH_MAX.patch
@@ -0,0 +1,39 @@
+diff -ruN src/autocomplete.c src/autocomplete.c
+--- src/autocomplete.c
++++ src/autocomplete.c
+@@ -29,6 +29,7 @@
+ #include <sys/dir.h>
+ #else
+ #include <dirent.h>
++#include <linux/limits.h>
+ #endif /* __APPLE__ */
+
+ #include "configdir.h"
+diff -ruN src/file_transfers.h src/file_transfers.h
+--- src/file_transfers.h
++++ src/file_transfers.h
+@@ -25,6 +25,10 @@
+
+ #include <limits.h>
+
++#ifdef __linux__
++#include <linux/limits.h>
++#endif
++
+ #include "notify.h"
+ #include "toxic.h"
+ #include "windows.h"
+diff -ruN src/settings.h src/settings.h
+--- src/settings.h
++++ src/settings.h
+@@ -25,6 +25,10 @@
+
+ #include <limits.h>
+
++#ifdef __linux__
++#include <linux/limits.h>
++#endif
++
+ #include <tox/tox.h>
+
+ /* Represents line_* hints max strlen */
diff --git a/net-im/toxic/toxic-0.11.3.ebuild b/net-im/toxic/toxic-0.11.3.ebuild
new file mode 100644
index 000000000000..540224d42d30
--- /dev/null
+++ b/net-im/toxic/toxic-0.11.3.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+audio-notify debug games llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+BDEPEND="dev-libs/libconfig:=
+ virtual/pkgconfig"
+
+RDEPEND="net-libs/tox:=
+ net-misc/curl
+ sys-kernel/linux-headers
+ sys-libs/ncurses:=
+ audio-notify? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ notification? ( x11-libs/libnotify )
+ debug? ( llvm? ( sys-devel/llvm:* ) )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? (
+ media-gfx/qrencode:=
+ png? ( media-libs/libpng )
+ )
+ sound? (
+ media-libs/openal
+ net-libs/tox:=[av]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to change assignment of CFLAGS and LDFLAGS"
+ #Fix incomplete invocation of python-config
+ sed -i -e "s/--ldflags/--ldflags --embed/" cfg/checks/python.mk || die "Unable to fix python linking"
+ #This is to fix incorrect include statements of NAME_MAX and PATH_MAX macros
+ eapply -p0 "${FILESDIR}/${P}-NAME_MAX-and-PATH_MAX.patch" || die "Unable to fix include statements"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if use debug; then
+ export ENABLE_RELEASE=0
+ if use llvm; then
+ export ENABLE_ASAN=1
+ fi
+ fi
+ if ! use games; then
+ export DISABLE_GAMES=1
+ fi
+ if ! use notification; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ if ! use png; then
+ export DISABLE_QRPNG=1
+ fi
+ if use python; then
+ export ENABLE_PYTHON=1
+ fi
+ if ! use qrcode; then
+ export DISABLE_QRCODE=1
+ fi
+ if ! use sound; then
+ export DISABLE_AV=1
+ fi
+ if ! use video; then
+ export DISABLE_VI=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ export USER_CFLAGS="${CFLAGS}"
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r "${ED}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}