summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 09:19:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 09:20:18 +0200
commitdfc50d6c9cc538e9d2f4e5705d8d45e976cb5063 (patch)
tree0964995e4307e90beb703ee15f60b08805b62345 /net-im
parentdev-python/eventlet: Remove old (diff)
downloadgentoo-dfc50d6c9cc538e9d2f4e5705d8d45e976cb5063.tar.gz
gentoo-dfc50d6c9cc538e9d2f4e5705d8d45e976cb5063.tar.bz2
gentoo-dfc50d6c9cc538e9d2f4e5705d8d45e976cb5063.zip
net-im/rocketchat-desktop-bin: add version 3.5.0
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index b135d5b0a3de..aadc47d0dfc9 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.4.0.x86_64.rpm 58636916 BLAKE2B d78af6b205ec58938a8e12767fb8e1ca8e6ad2ed2b44c2be6257384ee330bbb0175b16be27c2bcde08a26d3b3cc339f3713c69bede99e4c55f71b30c37b56176 SHA512 6bbb3cbbbe49270428fae18a9c2028f50f45bc83192a4c8d322ae8a8e04d17454c1cf529984f74a670243949a20efd82c56525c6ae4aa9c9f718d78165a08519
+DIST rocketchat-3.5.0.x86_64.rpm 58607404 BLAKE2B 6ec72bf04e94dbfb42e9a573c010443052fc8b8d1248856bc4889bb00c1bffe2a1e27b7ec10826f48e5f2e7c73915f4b469333e933adc41e505460b7149d4305 SHA512 677a4bc50a64a6a7f961ed609acdf03f28230b8c7df028083f073e2a8e61897416dbc4cc396410bc9a243e532cc9c46a1b8533c129f729de44953892d9ebdf01
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.0.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}