summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libtorrent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/Manifest2
-rw-r--r--net-libs/libtorrent/files/download_constructor.diff21
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.3.ebuild48
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.4.ebuild48
-rw-r--r--net-libs/libtorrent/metadata.xml5
5 files changed, 124 insertions, 0 deletions
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
new file mode 100644
index 000000000000..588fdf9c1dab
--- /dev/null
+++ b/net-libs/libtorrent/Manifest
@@ -0,0 +1,2 @@
+DIST libtorrent-0.13.3.tar.gz 732847 SHA256 34317d6783b7f8d0805274c9467475b5432a246c0de8e28fc16e3b0b43f35677 SHA512 40f504db26d52b0c65fc1008c7b1465bde0e316c776028c5448bf15c6fd38389fad780b0c200933e51f63974a43942603e0103d45a98a3dd57f23f01a306ef25 WHIRLPOOL 7ed5c4903413c9a1587a561a9ec4bedf86f1ed78c8f81c0d0ebe7bf7de9f45187cb41520d3187d62d3718c2fb379857fac255311618b42bfcf77794ee8636ff2
+DIST libtorrent-0.13.4.tar.gz 768382 SHA256 704e097119dc89e2ee4630396b25de1cd64b0549841347ea75b9ef9217084955 SHA512 6a5ea944c1193d1160563828c5901f0cf557f38c4de61153d505344f3c3c8509c765e01b6cc5e3a53ec2bb184a9e8db32ed4ec154e93a93822804210f0fa45d0 WHIRLPOOL dc3361a1fed59d64e8b6c2fed46d8e20134cd7f0c3b1cad2a1776375a4a3ff796a63fdfb027fa3f81fbb0b409db76592985444702ddf5e034e7c6384b602c4d4
diff --git a/net-libs/libtorrent/files/download_constructor.diff b/net-libs/libtorrent/files/download_constructor.diff
new file mode 100644
index 000000000000..e806cabb64b2
--- /dev/null
+++ b/net-libs/libtorrent/files/download_constructor.diff
@@ -0,0 +1,21 @@
+--- src/download/download_constructor.cc 2011-03-08 17:48:43.000000000 +0300
++++ src/download/download_constructor.cc.new 2011-03-08 17:36:42.000000000 +0300
+@@ -97,7 +97,17 @@
+
+ parse_name(b.get_key("info"));
+ parse_info(b.get_key("info"));
+-
++
++ // hack, quick fix for #2505
++ if (b.has_key_list("announce-list"))
++ if (b.get_key_list("announce-list").empty()) {
++ b.erase_key("announce-list");
++ } else {
++ Object::list_type & l = b.get_key_list("announce-list");
++ if (l.size() == 1 && !l.begin()->is_list()) {
++ b.erase_key("announce-list");
++ }
++ }
+ parse_tracker(b);
+ }
+
diff --git a/net-libs/libtorrent/libtorrent-0.13.3.ebuild b/net-libs/libtorrent/libtorrent-0.13.3.ebuild
new file mode 100644
index 000000000000..66b18a83155d
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 ssl"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+# epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
diff --git a/net-libs/libtorrent/libtorrent-0.13.4.ebuild b/net-libs/libtorrent/libtorrent-0.13.4.ebuild
new file mode 100644
index 000000000000..fe1cdc92dbd2
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 ssl"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+# epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
diff --git a/net-libs/libtorrent/metadata.xml b/net-libs/libtorrent/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-libs/libtorrent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>