summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libyahoo2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libyahoo2')
-rw-r--r--net-libs/libyahoo2/Manifest1
-rw-r--r--net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch16
-rw-r--r--net-libs/libyahoo2/libyahoo2-1.0.1.ebuild44
-rw-r--r--net-libs/libyahoo2/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/libyahoo2/Manifest b/net-libs/libyahoo2/Manifest
new file mode 100644
index 000000000000..06aaeb8e3705
--- /dev/null
+++ b/net-libs/libyahoo2/Manifest
@@ -0,0 +1 @@
+DIST libyahoo2-1.0.1.tar.gz 507023 SHA256 6cd2d02369358190e90e5286e7626ea4ff8d4341cdeb98e13f0bfa06852b2aa7
diff --git a/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
new file mode 100644
index 000000000000..b05190a02a71
--- /dev/null
+++ b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
@@ -0,0 +1,16 @@
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -21,11 +21,9 @@
+ noinst_PROGRAMS = yahoo autoresponder
+
+ yahoo_SOURCES = sample_client.c
+-yahoo_LDADD = libyahoo2.la
+-yahoo_LDFLAGS = -lssl
++yahoo_LDADD = libyahoo2.la -lssl
+
+ autoresponder_SOURCES = autoresponder.c
+-autoresponder_LDADD = libyahoo2.la
+-autoresponder_LDFLAGS = -lssl
++autoresponder_LDADD = libyahoo2.la -lssl
+
+ endif
diff --git a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
new file mode 100644
index 000000000000..8be4c29091dc
--- /dev/null
+++ b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="interface to the new Yahoo! Messenger protocol"
+HOMEPAGE="http://libyahoo2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs ssl"
+
+RDEPEND="dev-libs/glib:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ sed -i -e 's:-ansi -pedantic::' configure.ac || die #240912
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable ssl sample-client)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use ssl; then
+ dobin src/.libs/{autoresponder,yahoo} || die
+ fi
+
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README TODO
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/net-libs/libyahoo2/metadata.xml b/net-libs/libyahoo2/metadata.xml
new file mode 100644
index 000000000000..a4dd39fe7e4e
--- /dev/null
+++ b/net-libs/libyahoo2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <upstream>
+ <remote-id type="sourceforge">libyahoo2</remote-id>
+ </upstream>
+</pkgmetadata>