summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-09 04:19:14 +0100
committerSam James <sam@gentoo.org>2022-07-09 04:19:14 +0100
commitd61fcd9d32d9cdae3b2446ece5f26fe6206d1eb1 (patch)
tree52d0a3cd0af86e86d5d3bd61b070d80258e17c9a /net-libs/nDPI
parentx11-plugins/gkrellm-countdown: fix BDEPEND typo (diff)
downloadgentoo-d61fcd9d32d9cdae3b2446ece5f26fe6206d1eb1.tar.gz
gentoo-d61fcd9d32d9cdae3b2446ece5f26fe6206d1eb1.tar.bz2
gentoo-d61fcd9d32d9cdae3b2446ece5f26fe6206d1eb1.zip
net-libs/nDPI: add 4.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/nDPI')
-rw-r--r--net-libs/nDPI/Manifest1
-rw-r--r--net-libs/nDPI/nDPI-4.4.ebuild56
-rw-r--r--net-libs/nDPI/nDPI-9999.ebuild12
3 files changed, 66 insertions, 3 deletions
diff --git a/net-libs/nDPI/Manifest b/net-libs/nDPI/Manifest
index ee024387d46e..04012ad463f1 100644
--- a/net-libs/nDPI/Manifest
+++ b/net-libs/nDPI/Manifest
@@ -2,3 +2,4 @@ DIST nDPI-3.4.tar.gz 37976087 BLAKE2B 49e25586671a91278d90775c3dbc881ce4ca9ae4af
DIST nDPI-4.0-patches.tar.bz2 8744 BLAKE2B 48bfb2cf240823b64ab15a3f8a21acece878102ebb4cc807648b264ef091107a05d66fc672cccd1bc721ad3ea0edde786a1f133dfc84c91422604a9929e327ed SHA512 99a780c18c048ceec29c42828c420fe3f9624906eaef70f92af6abdbf7bc29133e048d7f8de85d8b73aa6667066e7ab5843fa293221d5ec8bbe87803dde83db6
DIST nDPI-4.0.tar.gz 120053617 BLAKE2B ea0f333bd62622c1ab792137f9bbf2e35cb3790aae191c5caeaea36c7ce376bfa84633e99e321c16bcfbe5812d6674b825bdc4197297cee76064ed88f344a577 SHA512 2526041bc02a210e65bad31323a66167d79a37d14697cf4459054cc54715e53f9673b0000cefa6b452bbe3b3e6c25f0bafcf59d24323d210e2ce6782d9153f81
DIST nDPI-4.2.tar.gz 126559327 BLAKE2B 079267939083e788ce8b13e89b194504031e4c3e628df335ece7aab72cc80b8d8538badd45dac9fdaeeed8cd5dd19a81fece9c1157cba9a91dfa130abef61473 SHA512 c58b228b7de2b5fa111234bb065f9be259cd0282d0058f5985180aab6567c9a18e3453ce9062bd3c057a096ec3dfdc21b7c9680e0148e34af10f707530d853b8
+DIST nDPI-4.4.tar.gz 151062073 BLAKE2B fca968c0d0abcf18a6895dc6066b754925a2aa3cb3f395383f9add25066adf14bb95444a30950e13f7f22223ff203b16e7373c875841f33d8c885be83ed0bb6d SHA512 c5e3d38f7b6533bd4b9f96520c1d965bf0a8e3ec7e2d514bc42683bdb73d8331e28ed695f5d3972ace9e35f1af23359f5a25c0f5a20f7a8cc7a6b5446d592468
diff --git a/net-libs/nDPI/nDPI-4.4.ebuild b/net-libs/nDPI/nDPI-4.4.ebuild
new file mode 100644
index 000000000000..e2efa26265f9
--- /dev/null
+++ b/net-libs/nDPI/nDPI-4.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edo
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ntop/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0/$(ver_cut 1)"
+
+DEPEND="dev-libs/json-c:=
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir = \${prefix}/$(get_libdir)%" \
+ src/lib/Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # "local" here means "local to the system", and hence means
+ # system copy, not the bundled one.
+ econf --with-local-libgcrypt
+}
+
+src_test() {
+ pushd tests || die
+
+ edo ./do.sh
+ edo ./do-unit.sh
+
+ popd || die
+}
+
+src_install() {
+ default
+
+ rm "${ED}/usr/$(get_libdir)"/lib${PN,,}.a || die
+}
diff --git a/net-libs/nDPI/nDPI-9999.ebuild b/net-libs/nDPI/nDPI-9999.ebuild
index a7730e61c252..e2efa26265f9 100644
--- a/net-libs/nDPI/nDPI-9999.ebuild
+++ b/net-libs/nDPI/nDPI-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools edo
DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
HOMEPAGE="https://www.ntop.org/"
@@ -34,11 +34,17 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # "local" here means "local to the system", and hence means
+ # system copy, not the bundled one.
+ econf --with-local-libgcrypt
+}
+
src_test() {
pushd tests || die
- ./do.sh || die "Failed tests"
- ./do-unit.sh || die "Failed unit tests"
+ edo ./do.sh
+ edo ./do-unit.sh
popd || die
}