summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 09:51:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 09:51:45 +0200
commit62710b3ba9d2e6b0c824c28dfa929142dda49bab (patch)
tree466eda0950a8f7ab654d384b550bfe892e0b69db /net-libs/onion
parentdev-libs/libevent: Add patch to fix Zombie leftovers (diff)
downloadgentoo-62710b3ba9d2e6b0c824c28dfa929142dda49bab.tar.gz
gentoo-62710b3ba9d2e6b0c824c28dfa929142dda49bab.tar.bz2
gentoo-62710b3ba9d2e6b0c824c28dfa929142dda49bab.zip
net-libs/onion: Initial import. Ebuild be me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'net-libs/onion')
-rw-r--r--net-libs/onion/Manifest1
-rw-r--r--net-libs/onion/files/cflags.patch20
-rw-r--r--net-libs/onion/metadata.xml13
-rw-r--r--net-libs/onion/onion-0.7.ebuild67
-rw-r--r--net-libs/onion/onion-9999.ebuild67
5 files changed, 168 insertions, 0 deletions
diff --git a/net-libs/onion/Manifest b/net-libs/onion/Manifest
new file mode 100644
index 000000000000..270ebb827f9f
--- /dev/null
+++ b/net-libs/onion/Manifest
@@ -0,0 +1 @@
+DIST onion-0.7.tar.gz 287822 SHA256 18785a462ea2d7214df8413de86eba2d74e414dace9716a2a7ce7b1cb3d4edb7 SHA512 9da45100ec91893e43c62cdabc1b022dc60fd2b509e387ce12fea69495fc68084afcc2534693955d340352cafc58e98a901a5ef981d1c92793ab15b7b6257d4c WHIRLPOOL e7d0695c2d45ac80edd271eaef0148474c12f1b53777714719af2bdd6d0b0d0c8375ecdc19990ee38f6dc2a31c2f7a19b7b70a4c3ac1a1fbef3548d1a923dad3
diff --git a/net-libs/onion/files/cflags.patch b/net-libs/onion/files/cflags.patch
new file mode 100644
index 000000000000..7c4094f77bc8
--- /dev/null
+++ b/net-libs/onion/files/cflags.patch
@@ -0,0 +1,20 @@
+Index: onion-0.7/CMakeLists.txt
+===================================================================
+--- onion-0.7.orig/CMakeLists.txt
++++ onion-0.7/CMakeLists.txt
+@@ -151,15 +151,6 @@ endif (SYSTEMD_ENABLED)
+ add_definitions(-D_BSD_SOURCE)
+ add_definitions(-D_POSIX_C_SOURCE=200112L)
+
+-##
+-IF (${CMAKE_BUILD_TYPE} MATCHES "Debug")
+- add_definitions(-D__DEBUG__)
+- SET(CMAKE_C_FLAGS "-Wall -Werror -O0 -fPIC")
+-ELSE (${CMAKE_BUILD_TYPE} MATCHES "Debug")
+- SET(CMAKE_C_FLAGS "-Wall -Werror -O2 -fPIC")
+-ENDIF (${CMAKE_BUILD_TYPE} MATCHES "Debug")
+-
+-
+ project (onion)
+
+ INCLUDE(CPackConfig.cmake)
diff --git a/net-libs/onion/metadata.xml b/net-libs/onion/metadata.xml
new file mode 100644
index 000000000000..5d3e5aabf6de
--- /dev/null
+++ b/net-libs/onion/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <use>
+ <flag name="libev">Use <pkg>dev-libs/libev</pkg> as thread poller instead of Linux's epoll.</flag>
+ <flag name="libevent">Use <pkg>dev-libs/libevent</pkg> as thread poller instead of libev or Linux's epoll.</flag>
+ <flag name="boehm-gc">Add <pkg>dev-libs/boehm-gc</pkg> support for memory allocations.</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/onion/onion-0.7.ebuild b/net-libs/onion/onion-0.7.ebuild
new file mode 100644
index 000000000000..6578fd1cefbf
--- /dev/null
+++ b/net-libs/onion/onion-0.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/davidmoreno/onion"
+fi
+
+inherit ${SCM} cmake-utils
+
+DESCRIPTION="C library to create simple HTTP servers and Web Applications"
+HOMEPAGE="http://www.coralbits.com/libonion/ https://github.com/davidmoreno/onion"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/davidmoreno/onion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="|| ( GPL-2+ Apache-2.0 ) AGPL-3"
+SLOT="0"
+IUSE="
+ gnutls pam png xml systemd sqlite
+ test examples cxx -libev -libevent
+"
+
+RDEPEND="
+ gnutls? ( net-libs/gnutls dev-libs/libgcrypt:0= )
+ pam? ( virtual/pam )
+ png? ( media-libs/libpng:0= x11-libs/cairo )
+ xml? ( dev-libs/libxml2:2 sys-libs/zlib )
+ systemd? ( sys-apps/systemd )
+ sqlite? ( dev-db/sqlite:3 )
+ libev? ( dev-libs/libev )
+ !libev? ( libevent? ( dev-libs/libevent ) )
+"
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl )
+"
+REQUIRED_USE="test? ( examples )"
+
+PATCHES=(
+ "${FILESDIR}/cflags.patch"
+)
+
+src_configure() {
+ use test || echo '' > tests/CMakeLists.txt
+ local mycmakeargs=(
+ "-DONION_USE_SSL=$(usex gnutls)"
+ "-DONION_USE_PAM=$(usex pam)"
+ "-DONION_USE_PNG=$(usex png)"
+ "-DONION_USE_XML2=$(usex xml)"
+ "-DONION_USE_SYSTEMD=$(usex systemd)"
+ "-DONION_USE_SQLITE3=$(usex sqlite)"
+ "-DONION_USE_TESTS=$(usex test)"
+ "-DONION_EXAMPLES=$(usex examples)"
+ "-DONION_USE_BINDINGS_CPP=$(usex cxx)"
+ "-DONION_POLLER=$(usex libev libev "$(usex libevent libevent default)")"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-libs/onion/onion-9999.ebuild b/net-libs/onion/onion-9999.ebuild
new file mode 100644
index 000000000000..405fa7b99ae4
--- /dev/null
+++ b/net-libs/onion/onion-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/davidmoreno/onion"
+fi
+
+inherit ${SCM} cmake-utils
+
+DESCRIPTION="C library to create simple HTTP servers and Web Applications"
+HOMEPAGE="http://www.coralbits.com/libonion/ https://github.com/davidmoreno/onion"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/davidmoreno/onion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="|| ( GPL-2+ Apache-2.0 ) AGPL-3"
+SLOT="0"
+IUSE="
+ gnutls pam png jpeg xml systemd sqlite boehm-gc
+ test examples cxx -libev -libevent
+"
+
+RDEPEND="
+ gnutls? ( net-libs/gnutls dev-libs/libgcrypt:0= )
+ pam? ( virtual/pam )
+ png? ( media-libs/libpng:0= x11-libs/cairo )
+ jpeg? ( virtual/jpeg:0 )
+ xml? ( dev-libs/libxml2:2 sys-libs/zlib )
+ systemd? ( sys-apps/systemd )
+ sqlite? ( dev-db/sqlite:3 )
+ boehm-gc? ( dev-libs/boehm-gc )
+ libev? ( dev-libs/libev )
+ !libev? ( libevent? ( dev-libs/libevent ) )
+"
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl )
+"
+REQUIRED_USE="test? ( examples )"
+
+src_configure() {
+ use test || echo '' > tests/CMakeLists.txt
+ local mycmakeargs=(
+ "-DONION_USE_SSL=$(usex gnutls)"
+ "-DONION_USE_PAM=$(usex pam)"
+ "-DONION_USE_PNG=$(usex png)"
+ "-DONION_USE_JPEG=$(usex jpeg)"
+ "-DONION_USE_XML2=$(usex xml)"
+ "-DONION_USE_SYSTEMD=$(usex systemd)"
+ "-DONION_USE_SQLITE3=$(usex sqlite)"
+ "-DONION_USE_GC=$(usex boehm-gc)"
+ "-DONION_USE_TESTS=$(usex test)"
+ "-DONION_EXAMPLES=$(usex examples)"
+ "-DONION_USE_BINDINGS_CPP=$(usex cxx)"
+ "-DONION_POLLER=$(usex libev libev "$(usex libevent libevent default)")"
+ )
+ cmake-utils_src_configure
+}