summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-28 01:47:07 +0000
committerSam James <sam@gentoo.org>2024-03-28 01:47:07 +0000
commit5f34085acefc46c97581d47817157fc8ce3762af (patch)
tree8b362d92519a63759963b8b862ee4ec2184e2907 /net-libs/rustls-ffi
parentsys-apps/moar: add 1.23.9 (diff)
downloadgentoo-5f34085acefc46c97581d47817157fc8ce3762af.tar.gz
gentoo-5f34085acefc46c97581d47817157fc8ce3762af.tar.bz2
gentoo-5f34085acefc46c97581d47817157fc8ce3762af.zip
net-libs/rustls-ffi: drop nightly Rust flag
Backport an upstream PR to allow us to drop RUSTC_BOOTSTRAP. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/rustls-ffi')
-rw-r--r--net-libs/rustls-ffi/files/rustls-ffi-0.12.1-no-rust-nightly.patch48
-rw-r--r--net-libs/rustls-ffi/rustls-ffi-0.12.1.ebuild7
2 files changed, 52 insertions, 3 deletions
diff --git a/net-libs/rustls-ffi/files/rustls-ffi-0.12.1-no-rust-nightly.patch b/net-libs/rustls-ffi/files/rustls-ffi-0.12.1-no-rust-nightly.patch
new file mode 100644
index 000000000000..dd8d582d4a84
--- /dev/null
+++ b/net-libs/rustls-ffi/files/rustls-ffi-0.12.1-no-rust-nightly.patch
@@ -0,0 +1,48 @@
+https://github.com/rustls/rustls-ffi/issues/397
+https://github.com/rustls/rustls-ffi/pull/398
+
+From 68b7153018647baec43ea950f28b2f84e87f5296 Mon Sep 17 00:00:00 2001
+From: Daniel McCarney <daniel@binaryparadox.net>
+Date: Wed, 27 Mar 2024 21:08:16 -0400
+Subject: [PATCH] Cargo: configure cargo-c to use vendored .h
+
+Presently we pre-generate the rustls.h header file using `cbindgen`,
+commit the result to `src/rustls.h`, and check that the generated result
+matches the checked-in result in CI.
+
+The new experimental cargo-c build regenerates its own header file using
+`cbindgen` by default unless told to do otherwise. We'd prefer it didn't
+do this because we're using a `cbindgen` feature that requires nightly
+rust.
+
+This commit updates the `Cargo.toml` capi metadata to tell cargo-c to
+skip generation of its own header file. We then configure the
+pre-generated checked-in header file as an asset to be copied into the
+install include directory.
+
+This better matches how the `Makefile` build allowed building the static
+lib without needing nightly rust or `cbindgen`.
+---
+ Cargo.toml | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/Cargo.toml b/Cargo.toml
+index 7a910a9d..4c2b2e94 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -41,6 +41,7 @@ regex = "1.9.6"
+ [package.metadata.capi.header]
+ name = "rustls"
+ subdirectory = false
++generation = false # Prefer a vendored .h
+
+ [package.metadata.capi.library]
+ name = "rustls"
+@@ -50,3 +51,6 @@ rustflags = "-Cmetadata=rustls-ffi"
+ [package.metadata.capi.pkg_config]
+ name = "rustls"
+ filename = "rustls"
++
++[package.metadata.capi.install]
++asset = [{ from = "src/rustls.h", to = "include" }]
+
diff --git a/net-libs/rustls-ffi/rustls-ffi-0.12.1.ebuild b/net-libs/rustls-ffi/rustls-ffi-0.12.1.ebuild
index 999355fd18f4..b9e9e999f6a9 100644
--- a/net-libs/rustls-ffi/rustls-ffi-0.12.1.ebuild
+++ b/net-libs/rustls-ffi/rustls-ffi-0.12.1.ebuild
@@ -56,6 +56,10 @@ BDEPEND="dev-util/cargo-c"
QA_FLAGS_IGNORED="usr/lib.*/librustls.*"
+PATCHES=(
+ "${FILESDIR}"/rustls-ffi-0.12.1-no-rust-nightly.patch
+)
+
src_prepare() {
default
@@ -70,9 +74,6 @@ src_configure() {
# Hopefully fixed with https://github.com/rustls/rustls-ffi/pull/389
export RUSTFLAGS="${RUSTFLAGS} -C link-arg=-Wl,-z,notext"
- # https://github.com/rustls/rustls-ffi/issues/397
- export RUSTC_BOOTSTRAP=1
-
multilib-minimal_src_configure
}