summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-21 12:23:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-21 12:32:12 +0100
commit296ba5b1ec7f7c1811d9b6a1ece41a5b3cff096c (patch)
tree3c53fec15796f69a86fe5451c1e437c590df6361 /net-libs/socket_wrapper
parentnet-fs/samba: Removed old. (diff)
downloadgentoo-296ba5b1ec7f7c1811d9b6a1ece41a5b3cff096c.tar.gz
gentoo-296ba5b1ec7f7c1811d9b6a1ece41a5b3cff096c.tar.bz2
gentoo-296ba5b1ec7f7c1811d9b6a1ece41a5b3cff096c.zip
net-libs/socket_wrapper: Bump to version 1.1.9
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs/socket_wrapper')
-rw-r--r--net-libs/socket_wrapper/Manifest1
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.1.9.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index 67d60703b3c2..24e1763b8809 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1,3 +1,4 @@
DIST socket_wrapper-1.1.6.tar.gz 54150 BLAKE2B c9d655d87e4462bf36289c7800e17fed9db24153fd82e11eaa1007a1507e3ec146d94beb6425c6e43941f904698eaddbf138707adda74735d7812845751176f8 SHA512 8d5868877cdc7b20efbb8073276574d65d61a8fea73df2924a3fa4581284d30d7a1f03351c470a473e0e2eb6ed1a1513a98559a620b3976741892bb807cfe7ea
DIST socket_wrapper-1.1.7.tar.gz 54774 BLAKE2B 132b3875cc3434b2ae9c9e37c664737c7916fee9f1c0a6207b85e881c37c6222d17f8ca191519d8bafcbfad7700c7e24726fa807a5cd2ceb233ebf129a282e54 SHA512 3ddf7c1e0bf75268ed9bb44dfb02028d2d678a206ce6290ee1fc8da851ccf0cf97255c2cc498212abf65b96a9114563c4f922816d0109d379b096682a6bfe1f1
DIST socket_wrapper-1.1.8.tar.gz 771657 BLAKE2B 83474eb48638abed2937caf01e85c1405a9b539ce91d3f710bce8ee253a7e69c605a0f1c19186001573e07e5a49d0a676a7936ce9d69910de6a300a6607b5c77 SHA512 55c64a4897a09bf2680132337d24bdd5f01e57369b0e1611dea9daca8a57f44d3b6625d3c3e631f954db3f4fc7e85f7ca229ec647f4bfd756f0bcabc6558498d
+DIST socket_wrapper-1.1.9.tar.gz 772252 BLAKE2B ab8031ddd5b22fc9534daf996dd137466d2592bb83dfac4f15fb1adc3f0369544ad74b5b8fdb8dd61a09b6264f445604571d1b6b886401b96720ccd0499219bc SHA512 62458c7881c0d4e0e7f1ef3ec8dc4277a0f886cd1e9c73f6a20f23ed4546bcc959169fbac909e193e60567985f196358f6567de68b89ac4d4d5ec8473c8afb64
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.1.9.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.1.9.ebuild
new file mode 100644
index 000000000000..4cbcd2bedf10
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.1.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}