summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 11:17:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 15:03:37 +0100
commit5c734e9fbe789d54100072ce68408871b129b22c (patch)
treecc07291e397203223493963658097caf03495f50 /net-libs/socket_wrapper
parentmedia-libs/openexr: Stabilize 2.5.5 ppc, #770229 (diff)
downloadgentoo-5c734e9fbe789d54100072ce68408871b129b22c.tar.gz
gentoo-5c734e9fbe789d54100072ce68408871b129b22c.tar.bz2
gentoo-5c734e9fbe789d54100072ce68408871b129b22c.zip
net-libs/socket_wrapper: 1.3.2 version bump, switch to cmake.eclass
Closes: https://bugs.gentoo.org/737614 Closes: https://bugs.gentoo.org/770571 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/socket_wrapper')
-rw-r--r--net-libs/socket_wrapper/Manifest1
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/socket_wrapper/Manifest b/net-libs/socket_wrapper/Manifest
index 025082872d5a..8b296abbd49c 100644
--- a/net-libs/socket_wrapper/Manifest
+++ b/net-libs/socket_wrapper/Manifest
@@ -1 +1,2 @@
DIST socket_wrapper-1.2.3.tar.gz 67476 BLAKE2B 66858406398ce3f33311390812f5fe377a7064d94be5af15fe03c363ab39798fd5a5dad7259e4ef477887c3de8b1d4d1739d08128adea0b1759b3227b4657214 SHA512 78eb85da900b43cbb5b639f19a159fc55ec1209a1a86d5d1eee5f22225d749043712b74c0f8fcb77f5a9bb705568f4cd1cbc89f85941946c745ca2d3a60878b2
+DIST socket_wrapper-1.3.2.tar.gz 86255 BLAKE2B 33f526a8871cfb1a889a84660ea8e82b6e591646924e16d2c452bb001e0eb4c1457b8151208bbec55c13c40fd124c160fc85d0df227519f62a2683e4ea1acb85 SHA512 f4d3a7026f1777a4c3b5481a0f6e6057b6372e9b64f44523ec1ebf0a34159d7154493dce6ee3c95fbea15607c6ada1382f2475d5d553133a061c80719c135b9d
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild
new file mode 100644
index 000000000000..b714f672e700
--- /dev/null
+++ b/net-libs/socket_wrapper/socket_wrapper-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="A library passing all socket communications through unix sockets"
+HOMEPAGE="https://cwrap.org/socket_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}