summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-26 16:10:05 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-26 21:10:39 +0200
commit553be092524167fadd8bd7614e9beab3fb5d7fd0 (patch)
treedcacbd7fa0721e8e81436c91c96aec9670a4d697 /net-libs/wvstreams
parentapp-emulation/qemu: security patches (diff)
downloadgentoo-553be092524167fadd8bd7614e9beab3fb5d7fd0.tar.gz
gentoo-553be092524167fadd8bd7614e9beab3fb5d7fd0.tar.bz2
gentoo-553be092524167fadd8bd7614e9beab3fb5d7fd0.zip
net-libs/wvstreams: Fix patches.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch12
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch8
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch4
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch8
4 files changed, 16 insertions, 16 deletions
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
index b284da8f3e79..a1ad88817932 100644
--- a/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
@@ -5,8 +5,8 @@ See -gcc47-patch and -magic.patch in Fedora git:
http://pkgs.fedoraproject.org/gitweb/?p=libwvstreams.git;a=tree
---- include/wvtask.h
-+++ include/wvtask.h
+--- a/include/wvtask.h
++++ b/include/wvtask.h
@@ -45,7 +45,8 @@
typedef void TaskFunc(void *userdata);
@@ -26,8 +26,8 @@ http://pkgs.fedoraproject.org/gitweb/?p=libwvstreams.git;a=tree
static WvTaskList all_tasks, free_tasks;
static void get_stack(WvTask &task, size_t size);
---- include/wvuid.h
-+++ include/wvuid.h
+--- a/include/wvuid.h
++++ b/include/wvuid.h
@@ -7,6 +7,7 @@
#ifndef __WVUID_H
#define __WVUID_H
@@ -36,8 +36,8 @@ http://pkgs.fedoraproject.org/gitweb/?p=libwvstreams.git;a=tree
#include "wvstring.h"
#if WIN32
---- utils/wvtask.cc
-+++ utils/wvtask.cc
+--- a/utils/wvtask.cc
++++ b/utils/wvtask.cc
@@ -58,7 +58,8 @@
int WvTask::taskcount, WvTask::numtasks, WvTask::numrunning;
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch
index 473d3e832933..38218d7213a9 100644
--- a/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-glibc212.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/333301
---- ipstreams/wvunixdgsocket.cc
-+++ ipstreams/wvunixdgsocket.cc
+--- a/ipstreams/wvunixdgsocket.cc
++++ b/ipstreams/wvunixdgsocket.cc
@@ -1,5 +1,5 @@
#include "wvunixdgsocket.h"
-#ifdef MACOS
@@ -9,8 +9,8 @@ http://bugs.gentoo.org/333301
#include <sys/types.h>
#include <sys/stat.h>
#endif
---- streams/wvatomicfile.cc
-+++ streams/wvatomicfile.cc
+--- a/streams/wvatomicfile.cc
++++ b/streams/wvatomicfile.cc
@@ -11,7 +11,8 @@
#include "wvfileutils.h"
#include "wvstrutils.h"
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
index c27e7233627f..327e19a0c11b 100644
--- a/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-openssl-1.0.0.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/304283
---- crypto/wvx509.cc
-+++ crypto/wvx509.cc
+--- a/crypto/wvx509.cc
++++ b/crypto/wvx509.cc
@@ -1157,7 +1157,11 @@
if (ext)
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
index d6f7d6e76174..688178c3a1bd 100644
--- a/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-parallel-make.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -131,12 +131,19 @@
# libwvstreams: stream/event handling library
#
@@ -34,8 +34,8 @@
TESTS += $(call tests_cc,dbus/tests)
libwvdbus_OBJS += $(call objects,dbus)
libwvdbus.so: $(libwvdbus_OBJS) $(LIBWVSTREAMS)
---- wvrules-posix.mk
-+++ wvrules-posix.mk
+--- a/wvrules-posix.mk
++++ b/wvrules-posix.mk
@@ -85,12 +85,15 @@
$(AR) s $1
endef