summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-05-15 15:03:56 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-05-17 16:58:56 +0200
commitbc0d43f4a79a0cd693c54d478f6572e8f7c9efd7 (patch)
tree5959ad5ca7e2b49fa3c119a12e50fc50abf217ee /net-libs
parentdev-libs/isa-l: keyword 2.30.0-r1 for ~x86 (diff)
downloadgentoo-bc0d43f4a79a0cd693c54d478f6572e8f7c9efd7.tar.gz
gentoo-bc0d43f4a79a0cd693c54d478f6572e8f7c9efd7.tar.bz2
gentoo-bc0d43f4a79a0cd693c54d478f6572e8f7c9efd7.zip
net-libs/xrootd: add 5.5.5
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/files/xrootd-5.5-system-isa-l.patch286
-rw-r--r--net-libs/xrootd/metadata.xml1
-rw-r--r--net-libs/xrootd/xrootd-5.5.5.ebuild205
4 files changed, 493 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index c6298f5fa708..00b69e31c314 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,2 +1,3 @@
DIST xrootd-5.4.3.tar.gz 3182127 BLAKE2B ed3f6a943167eafb5f6d7f78ca34f44c9a18b5ed672a4e622acb1e6e6997bd21756a30bf24f0b799ab4f16e7e1fb3f61a042f4e5e00f965b898fc5a287bf995a SHA512 189ec8e20901fd07093494187502e031a60d4ade22af33067313fad7a1bf6a6feb5c5d9d59d3a86d13a6a767e5a93cf4836da02e9cae11c81ccac07199898d72
DIST xrootd-5.5.4.tar.gz 3241021 BLAKE2B 505890ab7dbd0530d3c42390c9a6858cf0c8b53d42631b3bed615cb9b7c4d738bb791d26e625b010fef79f57291eb8bcd653ec629d240df92d37c12c973210f8 SHA512 1bf8fec3e20950e1dfbb5a7914c2f2b1d7d1fc1ce6b419dda129bb6cfb083ae674a14732b7b7330dee2287635749d91f8ee7e16badd71c723d189a1a44c309dd
+DIST xrootd-5.5.5.tar.gz 3243062 BLAKE2B 697dbd9d42e3fd9c6d2cf86a1c120e3752e74abbae2cf69be4c20292c568ad2f20fbea9320a2e22c04b53232d32915f9f7ea08c0e93117e8e72f181d5b642044 SHA512 864b4fe686c0a618a2672b624b7c5a00a4e87b4bd97842f8e25666b48a23f01e7d91d926013e9f435fb439a9c464ebbca8818720ec6c067c04d0603d1381cdba
diff --git a/net-libs/xrootd/files/xrootd-5.5-system-isa-l.patch b/net-libs/xrootd/files/xrootd-5.5-system-isa-l.patch
new file mode 100644
index 000000000000..4ab928aed7bb
--- /dev/null
+++ b/net-libs/xrootd/files/xrootd-5.5-system-isa-l.patch
@@ -0,0 +1,286 @@
+commit fb01136cc18af34447d9438827cc736f720e4c24
+Author: Guilherme Amadio <amadio@cern.ch>
+Date: Fri Nov 11 17:33:00 2022 +0100
+
+ [CMake] Adapt build system to be able to use pre-installed isa-l
+
+diff --git a/cmake/XRootDDefaults.cmake b/cmake/XRootDDefaults.cmake
+index 5c25975bb..1bef0cce3 100644
+--- a/cmake/XRootDDefaults.cmake
++++ b/cmake/XRootDDefaults.cmake
+@@ -33,4 +33,5 @@ option( ENABLE_XRDCLHTTP "Enable xrdcl-http plugin."
+ cmake_dependent_option( ENABLE_SCITOKENS "Enable SciTokens plugin." TRUE "NOT XRDCL_ONLY" FALSE )
+ cmake_dependent_option( ENABLE_MACAROONS "Enable Macaroons plugin." TRUE "NOT XRDCL_ONLY" FALSE )
+ option( FORCE_ENABLED "Fail build if enabled components cannot be built." FALSE )
++cmake_dependent_option( USE_SYSTEM_ISAL "Use isa-l installed in the system" FALSE "ENABLE_XRDEC" FALSE )
+ define_default( XRD_PYTHON_REQ_VERSION 3 )
+diff --git a/src/XrdCl/CMakeLists.txt b/src/XrdCl/CMakeLists.txt
+index fb43d1f1b..32d3ccb4e 100644
+--- a/src/XrdCl/CMakeLists.txt
++++ b/src/XrdCl/CMakeLists.txt
+@@ -28,8 +28,6 @@ endif()
+ # XrdEc sources
+ #-------------------------------------------------------------------------------
+ if( BUILD_XRDEC )
+- link_directories( ${ISAL_LIBDIR} )
+- include_directories( ${ISAL_INCDIR} )
+ set( XrdEcSources
+ ${CMAKE_SOURCE_DIR}/src/XrdEc/XrdEcRedundancyProvider.cc
+ ${CMAKE_SOURCE_DIR}/src/XrdEc/XrdEcUtilities.cc
+@@ -37,7 +35,6 @@ if( BUILD_XRDEC )
+ ${CMAKE_SOURCE_DIR}/src/XrdEc/XrdEcReader.cc
+ XrdClEcHandler.cc
+ )
+- set( ISAL_LIB isal )
+ add_compile_definitions( WITH_XRDEC )
+ endif()
+
+@@ -119,19 +116,17 @@ target_link_libraries(
+ ${ZLIB_LIBRARIES}
+ ${EXTRA_LIBS}
+ ${CMAKE_DL_LIBS}
+- ${OPENSSL_LIBRARIES}
+- ${ISAL_LIB})
++ ${OPENSSL_LIBRARIES})
+
+ set_target_properties(
+ XrdCl
+ PROPERTIES
+- INTERFACE_LINK_LIBRARIES ""
+- LINK_INTERFACE_LIBRARIES ""
+ VERSION ${XRD_CL_VERSION}
+ SOVERSION ${XRD_CL_SOVERSION} )
+
+ if( BUILD_XRDEC )
+- add_dependencies( XrdCl isa-l )
++ target_include_directories(XrdCl PUBLIC ${ISAL_INCLUDE_DIRS})
++ target_link_libraries(XrdCl ${ISAL_LIBRARIES})
+ endif()
+
+ #-------------------------------------------------------------------------------
+diff --git a/src/XrdEc/CMakeLists.txt b/src/XrdEc/CMakeLists.txt
+index 43aa3ff5e..53754340c 100644
+--- a/src/XrdEc/CMakeLists.txt
++++ b/src/XrdEc/CMakeLists.txt
+@@ -1,9 +1,6 @@
+ include( XRootDCommon )
+ include( ExternalProject )
+
+-link_directories( ${ISAL_LIBDIR} )
+-include_directories( ${ISAL_INCDIR} )
+-
+ #-------------------------------------------------------------------------------
+ # The XrdEc shared library
+ #-------------------------------------------------------------------------------
+@@ -27,19 +24,14 @@ add_library(
+ target_link_libraries(
+ XrdEc
+ XrdCl
+- isal
+ )
+
+ set_target_properties(
+ XrdEc
+ PROPERTIES
+- INTERFACE_LINK_LIBRARIES ""
+- LINK_INTERFACE_LIBRARIES ""
+ VERSION ${XRD_EC_VERSION}
+ SOVERSION ${XRD_EC_SOVERSION} )
+
+-add_dependencies( XrdEc isa-l )
+-
+ #------------------------------------------------------------------------------
+ # Install XrdEc library
+ #------------------------------------------------------------------------------
+diff --git a/src/XrdEc/XrdEcObjCfg.hh b/src/XrdEc/XrdEcObjCfg.hh
+index 3978b1c77..24fb99429 100644
+--- a/src/XrdEc/XrdEcObjCfg.hh
++++ b/src/XrdEc/XrdEcObjCfg.hh
+@@ -10,7 +10,7 @@
+
+ #include "XrdOuc/XrdOucCRC32C.hh"
+
+-#include "isa-l/crc.h"
++#include <isa-l/crc.h>
+
+ #include <cstdlib>
+ #include <string>
+diff --git a/src/XrdEc/XrdEcRedundancyProvider.cc b/src/XrdEc/XrdEcRedundancyProvider.cc
+index 47f48a431..c41232aee 100644
+--- a/src/XrdEc/XrdEcRedundancyProvider.cc
++++ b/src/XrdEc/XrdEcRedundancyProvider.cc
+@@ -15,7 +15,7 @@
+
+ #include "XrdEc/XrdEcRedundancyProvider.hh"
+
+-#include "isa-l/isa-l.h"
++#include <isa-l.h>
+ #include <cstring>
+ #include <sstream>
+ #include <algorithm>
+diff --git a/src/XrdIsal.cmake b/src/XrdIsal.cmake
+index fe819f495..f110df69d 100644
+--- a/src/XrdIsal.cmake
++++ b/src/XrdIsal.cmake
+@@ -1,57 +1,47 @@
+-include( XRootDCommon )
+-include( ExternalProject )
++if(USE_SYSTEM_ISAL)
++ find_package(isal REQUIRED)
++endif()
++
++if(ISAL_FOUND)
++ return()
++endif()
+
+ #-------------------------------------------------------------------------------
+ # Build isa-l
+ #-------------------------------------------------------------------------------
+
+-set(MAKEOPTIONS "")
+-if("${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "i386" OR "${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "i686")
+- set(MAKEOPTIONS "arch=32")
+-endif()
++include(ExternalProject)
++include(FindPackageHandleStandardArgs)
+
+-#EXECUTE_PROCESS(
+-# COMMAND git ls-remote --tags https://github.com/01org/isa-l
+-# COMMAND awk "{print $2}"
+-# COMMAND grep -v {}
+-# COMMAND awk -F "/" "{print $3}"
+-# COMMAND tail -1
+-# OUTPUT_VARIABLE ISAL_VERSION
+-#)
++set(ISAL_VERSION v2.30.0)
++message(STATUS "Building ISAL: ${ISAL_VERSION}")
+
+-set( ISAL_VERSION v2.30.0 )
+-MESSAGE( STATUS "Building ISAL: ${ISAL_VERSION}" )
++set(ISAL_ROOT "${CMAKE_BINARY_DIR}/isa-l")
++set(ISAL_LIBRARY "${ISAL_ROOT}/.libs/libisal.a")
++set(ISAL_INCLUDE_DIRS "${ISAL_ROOT}")
+
+-set( ISAL_BUILDDIR "${CMAKE_BINARY_DIR}/isal/build" CACHE INTERNAL "" )
+-set( ISAL_INCDIR "${CMAKE_BINARY_DIR}/isal/include" CACHE INTERNAL "" )
+-set( ISAL_LIBDIR "${CMAKE_BINARY_DIR}/isal/lib" CACHE INTERNAL "" )
+-
+-set( ISAL_HEADERS
+- ${ISAL_BUILDDIR}/include/crc64.h
+- ${ISAL_BUILDDIR}/include/crc.h
+- ${ISAL_BUILDDIR}/include/erasure_code.h
+- ${ISAL_BUILDDIR}/include/gf_vect_mul.h
+- ${ISAL_BUILDDIR}/include/igzip_lib.h
+- ${ISAL_BUILDDIR}/include/mem_routines.h
+- ${ISAL_BUILDDIR}/include/multibinary.asm
+- ${ISAL_BUILDDIR}/include/raid.h
+- ${ISAL_BUILDDIR}/include/reg_sizes.asm
+- ${ISAL_BUILDDIR}/include/test.h
+- ${ISAL_BUILDDIR}/include/types.h
++ExternalProject_add(isa-l
++ URL https://github.com/intel/isa-l/archive/refs/tags/${ISAL_VERSION}.tar.gz
++ URL_HASH SHA256=bcf592c04fdfa19e723d2adf53d3e0f4efd5b956bb618fed54a1108d76a6eb56
++ SOURCE_DIR ${CMAKE_BINARY_DIR}/isa-l
++ BUILD_IN_SOURCE 1
++ CONFIGURE_COMMAND ./autogen.sh COMMAND ./configure --with-pic
++ BUILD_COMMAND make -j ${CMAKE_BUILD_PARALLEL_LEVEL}
++ INSTALL_COMMAND ${CMAKE_COMMAND} -E copy_directory ${ISAL_ROOT}/include ${ISAL_ROOT}/isa-l
++ BUILD_BYPRODUCTS ${ISAL_LIBRARY} ${ISAL_INCLUDE_DIRS}
+ )
+
+-ExternalProject_add(
+- isa-l
+- SOURCE_DIR ${ISAL_BUILDDIR}
+- BUILD_IN_SOURCE 1
+- GIT_REPOSITORY https://github.com/01org/isa-l.git
+- GIT_TAG ${ISAL_VERSION}
+- CONFIGURE_COMMAND ./autogen.sh COMMAND ./configure --with-pic
+- BUILD_COMMAND make ${MAKEOPTIONS}
+- INSTALL_COMMAND mkdir -p ${ISAL_INCDIR}/isa-l
+- COMMAND mkdir -p ${ISAL_LIBDIR}
+- COMMAND cp ${ISAL_HEADERS} ${ISAL_INCDIR}/isa-l
+- COMMAND cp ${ISAL_BUILDDIR}/isa-l.h ${ISAL_INCDIR}/isa-l
+- COMMAND cp ${ISAL_BUILDDIR}/.libs/libisal.a ${ISAL_LIBDIR}/
++add_library(isal STATIC IMPORTED)
++
++set(ISAL_LIBRARIES isal)
++add_dependencies(isal isa-l)
++
++set_target_properties(isal
++ PROPERTIES
++ IMPORTED_LOCATION "${ISAL_LIBRARY}"
++ INTERFACE_INCLUDE_DIRECTORIES "$<BUILD_INTERFACE:${ISAL_INCLUDE_DIRS}>"
+ )
+
++# Emulate what happens when find_package(isal) succeeds
++find_package_handle_standard_args(isal
++ REQUIRED_VARS ISAL_INCLUDE_DIRS ISAL_LIBRARIES VERSION_VAR ISAL_VERSION)
+
+--
+commit f702ed624f9d57fb155ebf9c28b11def766da1da
+Author: Guilherme Amadio <amadio@cern.ch>
+Date: Fri Nov 11 15:35:15 2022 +0100
+
+ [CMake] Add a CMake find module for isa-l
+
+diff --git a/cmake/Findisal.cmake b/cmake/Findisal.cmake
+new file mode 100644
+index 000000000..06468f993
+--- /dev/null
++++ b/cmake/Findisal.cmake
+@@ -0,0 +1,55 @@
++#.rst:
++# Findisal
++# ---------
++#
++# Find Intelligent Storage Acceleration Library.
++#
++# Result Variables
++# ^^^^^^^^^^^^^^^^
++#
++# This module defines the following variables:
++#
++# ::
++#
++# ISAL_FOUND - True if isa-l is found.
++# ISAL_INCLUDE_DIRS - Where to find isa-l.h
++# ISAL_LIBRARIES - Where to find libisal.so
++#
++# ::
++#
++# ISAL_VERSION - The version of ISAL found (x.y.z)
++# ISAL_VERSION_MAJOR - The major version of isa-l
++# ISAL_VERSION_MINOR - The minor version of isa-l
++# ISAL_VERSION_PATCH - The patch version of isa-l
++
++foreach(var ISAL_FOUND ISAL_INCLUDE_DIR ISAL_ISAL_LIBRARY ISAL_LIBRARIES)
++ unset(${var} CACHE)
++endforeach()
++
++find_path(ISAL_INCLUDE_DIR NAME isa-l.h PATH_SUFFIXES include)
++
++if(NOT ISAL_LIBRARY)
++ find_library(ISAL_LIBRARY NAMES isal PATH_SUFFIXES lib)
++endif()
++
++mark_as_advanced(ISAL_INCLUDE_DIR)
++
++if(ISAL_INCLUDE_DIR AND EXISTS "${ISAL_INCLUDE_DIR}/isa-l.h")
++ file(STRINGS "${ISAL_INCLUDE_DIR}/isa-l.h" ISAL_H REGEX "^#define ISAL_[A-Z_]+[ ]+[0-9]+.*$")
++ string(REGEX REPLACE ".+ISAL_MAJOR_VERSION[ ]+([0-9]+).*$" "\\1" ISAL_VERSION_MAJOR "${ISAL_H}")
++ string(REGEX REPLACE ".+ISAL_MINOR_VERSION[ ]+([0-9]+).*$" "\\1" ISAL_VERSION_MINOR "${ISAL_H}")
++ string(REGEX REPLACE ".+ISAL_PATCH_VERSION[ ]+([0-9]+).*$" "\\1" ISAL_VERSION_PATCH "${ISAL_H}")
++ set(ISAL_VERSION "${ISAL_VERSION_MAJOR}.${ISAL_VERSION_MINOR}.${ISAL_VERSION_PATCH}")
++endif()
++
++include(FindPackageHandleStandardArgs)
++find_package_handle_standard_args(isal
++ REQUIRED_VARS ISAL_LIBRARY ISAL_INCLUDE_DIR VERSION_VAR ISAL_VERSION)
++
++if(ISAL_FOUND)
++ set(ISAL_INCLUDE_DIRS "${ISAL_INCLUDE_DIR}")
++
++ if(NOT ISAL_LIBRARIES)
++ set(ISAL_LIBRARIES ${ISAL_LIBRARY})
++ endif()
++endif()
diff --git a/net-libs/xrootd/metadata.xml b/net-libs/xrootd/metadata.xml
index 1073a8452a26..16c259164057 100644
--- a/net-libs/xrootd/metadata.xml
+++ b/net-libs/xrootd/metadata.xml
@@ -21,5 +21,6 @@
<flag name="http">Enable http protocol support</flag>
<flag name="libxml2">Use <pkg>dev-libs/libxml2</pkg> for XML parsing (preferred) instead of bundled tinyxml</flag>
<flag name="server">Install xrootd server and related plug-ins</flag>
+ <flag name="xrdec">Enable erasure coding support (XrdEc plugin) with <pkg>dev-libs/isa-l</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-libs/xrootd/xrootd-5.5.5.ebuild b/net-libs/xrootd/xrootd-5.5.5.ebuild
new file mode 100644
index 000000000000..9137e1925da2
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.5.5.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517="setuptools"
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+"
+
+inherit cmake docs distutils-r1 systemd
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://xrootd.slac.stanford.edu/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples fuse http kerberos +libxml2 python readline +server systemd test xrdec"
+
+RESTRICT="!test? ( test )"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ virtual/libcrypt:=
+ fuse? ( sys-fs/fuse:0= )
+ http? (
+ net-misc/curl:=
+ net-libs/davix
+ )
+ kerberos? ( virtual/krb5 )
+ libxml2? ( dev-libs/libxml2:2= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ systemd? ( sys-apps/systemd:= )
+ xrdec? ( dev-libs/isa-l )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ test? ( >=dev-python/pytest-7.1.2[${PYTHON_USEDEP}] )
+ )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+REQUIRED_USE="
+ http? ( kerberos )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( server )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.3-crc32.patch
+ "${FILESDIR}"/${PN}-5.4.3-cmake_no_python.patch
+ "${FILESDIR}"/${PN}-5.4.3-python_tests_py3.patch
+ "${FILESDIR}"/${PN}-5.5-system-isa-l.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdClTests\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/bindings/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+# FIXME: support xrdec - currently only builds against bundled isa-l
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_ISAL=TRUE
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex libxml2 "no" "yes")
+ -DCMAKE_DISABLE_FIND_PACKAGE_systemd=$(usex systemd "no" "yes")
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_MACAROONS=no
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_SCITOKENS=no
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VOMS=no
+ -DENABLE_XRDCL=yes
+ -DENABLE_XRDCLHTTP=$(usex http)
+ -DENABLE_XRDEC=$(usex xrdec)
+ -DFORCE_ENABLED=yes
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+
+ docs_compile
+ # secondary documentation for python bindings
+ if use python && use doc; then
+ emake -C bindings/python/docs html
+ fi
+}
+
+python_test() {
+ epytest
+}
+
+src_test() {
+ pushd "${BUILD_DIR}/tests" > /dev/null || die
+ # There are more tests but, they require a docker environment with various containers.
+ # The tests below are the ones which do not require a server to be running.
+ ./common/test-runner ./XrdClTests/libXrdClTests.so "All Tests/UtilsTest/" || die
+ ./common/test-runner ./XrdClTests/libXrdClTests.so "All Tests/SocketTest/" || die
+ ./common/test-runner ./XrdClTests/libXrdClTests.so "All Tests/PollerTest/" || die
+ popd > /dev/null || die
+
+ # Python tests currently require manual configuration and start-up of an xrootd server.
+ # TODO: get this to run properly.
+ #use python && distutils-r1_src_test
+}
+
+src_install() {
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${ED}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use systemd; then
+ systemd_dounit packaging/common/*.{service,socket}
+ fi
+ fi
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ keepdir /etc/xrootd/config.d
+ keepdir /var/log/xrootd
+
+ fowners -R xrootd:xrootd /etc/xrootd
+ fowners -R xrootd:xrootd /var/log/xrootd
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+
+ if use test; then
+ for f in test-runner xrdshmap; do
+ rm "${ED}"/usr/bin/${f} || die "Failed to remove test helper ${f} from installed tree"
+ done
+ rm "${ED}"/usr/$(get_libdir)/libXrd*Test*.so || die "Failed to remove test libraries from installed tree"
+ fi
+}