summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntonio Quartulli <a@unstable.cc>2017-10-03 09:56:18 +0800
committerPatrice Clement <monsieurp@gentoo.org>2017-10-03 23:33:38 +0200
commit8569656db073515227caa52f2bd4d5020de74796 (patch)
tree0dcb556f5824c99037ea16a07eb2a22f3d611d66 /net-misc/axel
parentapp-emacs/cycle-buffer: update SRC_URI. (diff)
downloadgentoo-8569656db073515227caa52f2bd4d5020de74796.tar.gz
gentoo-8569656db073515227caa52f2bd4d5020de74796.tar.bz2
gentoo-8569656db073515227caa52f2bd4d5020de74796.zip
net-misc/axel: version bump to 2.14.1.
At the same time improve the instructions given by the ebuild about how to use axel with portage. Closes: https://bugs.gentoo.org/628456 Closes: https://github.com/gentoo/gentoo/pull/5841 Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/Manifest1
-rw-r--r--net-misc/axel/axel-2.14.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
index 48500a58b562..289d41fbb9b5 100644
--- a/net-misc/axel/Manifest
+++ b/net-misc/axel/Manifest
@@ -1,2 +1,3 @@
DIST axel-2.12.tar.gz 82995 SHA256 28e7bb26b7be3f56a61b60ef07e15e05ea9a41850b0ed45a0c56d6d2202f4a8b SHA512 5e163c319366f7efd16f8b35dbcf901300c884ab303696dabe87ad47511f56cc3f1e399af738dc79ca717ca70fd529b6dd1adf30f5162cfb530105ce34e2eaf2 WHIRLPOOL dece4ad9eae5441e0b24952a96189417e75eb155ad46b199ce531b35fa6d027ffb75a16c016044a37dd4e76601865e51c0310b69b7fc70b974f9b67a6b2b1fe5
+DIST axel-2.14.1.tar.gz 89356 SHA256 acf6820d98a792faf309fc9acf22f7caf4b8a4b7001072c8f546b3c4fc755e39 SHA512 72c37fc6def0c765ed8220c27efe22255073b1e3cf1c8f6bda5ee2ce9cd36ac46263ac602a185efd40ca8f197a268612f2dcda69bcb49891c2538b910d971e8b WHIRLPOOL 1384ab65a689200f68d2549deb2f22526ae82a25f1b580ce5a270babc33d577513c2732a57676ea1e51b99eb09267960a5e24b6507ebca64a61d6ab4070eb374
DIST axel-2.4.tar.bz2 44995 SHA256 ebc7d40e989c680d2afa632a17e5208101608924cf446da20814a6f3c3338612 SHA512 34d73cea19f2bf393aa8d3e4b6c24296f8b1d4e6177da6f4728763e013d5d9d073aa5dae31d0ff175126e8fcbd973daf94674a70f100afc9e7d00b92b78b8ec9 WHIRLPOOL 373af984738008572847ae0ed84a518d0b61323e3612f48affa96175792b0856c2bd13601ddcdd0c81ead5059ee41130759bf9b0ada2a2654f767ec69d992a0f
diff --git a/net-misc/axel/axel-2.14.1.ebuild b/net-misc/axel/axel-2.14.1.ebuild
new file mode 100644
index 000000000000..4bd7ad89659d
--- /dev/null
+++ b/net-misc/axel/axel-2.14.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug libressl nls ssl"
+
+REQUIRED_USE="libressl? ( ssl )"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, create a script in'
+ einfo '/usr/local/bin/fetchwrapper.sh with the following content:'
+ einfo
+ einfo ' #!/bin/bash'
+ einfo ' set -e'
+ einfo ' /usr/bin/axel -o "$1.axel" "$2"'
+ einfo ' mv "$1.axel" "$1"'
+ einfo
+ einfo 'and then add the following to your make.conf:'
+ einfo ' FETCHCOMMAND='\''/usr/local/bin/fetchwrapper.sh "\${DISTDIR}/\${FILE}.axel" "\${URI}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}