summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2023-07-02 18:29:57 +0200
committerStephan Hartmann <sultan@gentoo.org>2023-07-02 18:30:05 +0200
commitf50f937f56f860f5b506c14b1589de73435a05e3 (patch)
treef685624262cf294520b229b96de255d12e5b9b4b /net-misc/croc
parentsys-devel/autoconf: stable 2.71-r6 for hppa, bug #908629 (diff)
downloadgentoo-f50f937f56f860f5b506c14b1589de73435a05e3.tar.gz
gentoo-f50f937f56f860f5b506c14b1589de73435a05e3.tar.bz2
gentoo-f50f937f56f860f5b506c14b1589de73435a05e3.zip
net-misc/croc: add 9.6.4
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'net-misc/croc')
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-9.6.4.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index 073698ddc28e..0fd42f8fa8d8 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,3 +1,5 @@
DIST croc-9.6.0.tar.gz 2858439 BLAKE2B fb1edc8a7c926894e7402892e029940be63a947ad692ea3f634f07c1c7c56ef687a5a0d6aab8c2814d09e9dc1324ba234f278525e93031ae0a2c889630dd04c1 SHA512 df0ebb71ac1e897864b5a01531a4d9fd20e1f56eb4fb11f8aed25456d6571acf5703d6415669446d239add59ec5510751358768b0ef890b6fded2ac03160d84b
DIST croc-9.6.2-deps.tar.xz 27304100 BLAKE2B 6eac681bcc60db0b81abad19c3d8d994f2ea88618d90ade0229e9af436334e7bd3e907fa211e3b60a21049550d51c6e325bd9dfccacd4106abab32c7d49d9b66 SHA512 73d979f0d5a939b22304f1dc1976c096b7bee186f060d80aef4f64226a04d9b4f820d39ece9c9c9473791b4436d9e3fdb577f1342453dbbf2c4b765519e5a983
DIST croc-9.6.2.tar.gz 507769 BLAKE2B df99a7d5d60f753d4d7fd5924bb09be6b21513acbc0c454d2e199fca4ab38eee0b443a091e3b3c64e155cb460e760959d955969231df8a93da2472a6b93703f0 SHA512 a3ad2f6a4bc6a45fa356963bd123ea755caa30c6a3b63e63cc67823ce27d44d62610ff9bfa498f694e356f673c3fcb3cec7ac669bedcde6eaf63111a78538965
+DIST croc-9.6.4-deps.tar.xz 26792064 BLAKE2B 31ead16462c1e10fff9e756c44f4ac7d47dcaa444dcb2fdcdd7f762d1617640a736d4223f74c9dd4f27b62bb3d635fe3035ec0127b3e50a7d8fa83ba26cdce43 SHA512 bc69c6d678888621d93be878a49ad71c04e6b38742d1c1558a1a84d1a63c71c9a901149048e6e4f0385514dbb551e89585e8ed25fc6ec89b9f2437f78f52a1e5
+DIST croc-9.6.4.tar.gz 508495 BLAKE2B 985b3f27fd807e62eda121dcad45e150621ff50cf82fc778cac601fdb16e0aab6bab886326bd80b0cc218608ddddd42a3f537fdfeec3948d1617a4169fefdd0e SHA512 d6eab257ee49d12d07e38b37ae1d60cbf70f627618ea32f2ec74370a09e78cad929de4b7d2bd02e9f300f698d45c8c28f4b4eb337a0be8f29e046fee4bb19b1f
diff --git a/net-misc/croc/croc-9.6.4.ebuild b/net-misc/croc/croc-9.6.4.ebuild
new file mode 100644
index 000000000000..a3b14bea8b93
--- /dev/null
+++ b/net-misc/croc/croc-9.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~sultan/distfiles/net-misc/croc/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}